Help! My Mouse Is Stuttering!

vbimport

#1

So last week, my Logitech MX620 mouse started doing this stuttering thing which basically makes my workstation unusable for any task. It has so much lag and half of time doesnt even pick up clicking. I have to click multiple times for it to register a single one.

Ive defragged thinking maybe it was hard drive lag. ive even ccleaner’d my pc too getting rid of all of the extra crap. Nothing seems to work. Ive replaced the batteries, same thing.The weird thing is, when i took my tower (and mouse) home and used it, it worked fine. So, I WAS thinking maybe some sort of interference at work but there is nothing new around my desk (or even in the office) that should create that problem. And my tower is sitting on top of my desk (right next to the mouse) so the transmitter is close to it. (i only bring that up because my mx1100 mouse did sort of the same thing and i had to get a usb extension cord to bring the transmitter closer to the mouse iteself).

Im completely stumped. Im currently looking for a mired mouse to try and see if that solves the problem.

i’ve got some big projects this week, so im in some trouble here if i cant get this fixed soon. Any help is much appreciated. Thanks much in advance!


#2

[QUOTE=uronmy49311;2518579]
Im currently looking for a mired mouse to try and see if that solves the problem. [/QUOTE]:iagree: Connecting a wired mouse is the first thing I’d try.
If you have a LInux Live disc at hand, you could use this to see if there is the same problem.

Michael


#3

uninstalling the driver and reinstalling that latest driver might help.


#4

[QUOTE=coolcolors;2518689]uninstalling the driver and reinstalling that latest driver might help.[/QUOTE]Not a bad idea :wink: But for troubleshooting I’d suggest using the basic drivers that come with the OSinstead of the custom drivers from the manufacturer.
(Logitech mouseware is heavily bloated these days :eek: )

Michael


#5

[QUOTE=mciahel;2518701]Not a bad idea :wink: But for troubleshooting I’d suggest using the basic drivers that come with the OSinstead of the custom drivers from the manufacturer.
(Logitech mouseware is heavily bloated these days :eek: )

Michael[/QUOTE]

I guess that is true but I don’t recall. I currently have logitech wave/mouse combo and love it. Had three logitech wireless/mouse comb and with the latest wave/combo works well for my usage just remember to check the mouse/keyboard batter or make sure your rechargeable battery is in good condition.


#6

Most likely battery, interference from other equipment or low signal, in that order.


#7

well, ive changed the battery. it still happens. as far as interference goes, nothing has changed around my desk or even in the office as far as i know, so i dont think it could be that. i have plugged a wired mouse in and so far so good tho. so, maybe it IS interference. any ideas on how to check for that? or fix it? thanks again for the suggestions.


#8

If that software from logic works like my wave pro it should have a secure setup configuration in the setup. You have to go into the device manager for logitech to find it and configure it for secure connection from interferences.


#9

thanks… i’ll have to check that out, although i dont remember seeing it there… but i’ll check. thanks


#10

[QUOTE=coolcolors;2519002]If that software from logic works like my wave pro it should have a secure setup configuration in the setup. You have to go into the device manager for logitech to find it and configure it for secure connection from interferences.[/QUOTE]

no dice… my logitech software doesnt have any sort of secure setup config, unless i missed it. so far the wired mouse works perfecty too. so its either the wireless mouse is bad or its interference from something unknown all of a sudden.

any other ideas? thanks again.


#11

Hi,

since the wireless mouse didn’t work on two computers, I guess it’s simply faulty. I’d contact Logitech support for advice. At least here in Germany, Logitech customer support is excellent.

Michael


#12

ive never actually tried the mouse on another computer. same computer in a different location, but never another computer. i guess i could try that next. But when i DID have my work computer at home the mouse seemed to work perfectly which is why im leaning more towards interference… anyway, im using it again right now at work and seems to be better. no lag as of yet (5 hours). so we’ll see what happens… thanks again.