Help me save my server from death

vbimport

#1

I’m going to murder my server. Please prevent this tragedy from happening!

I’m at the end of my rope, I pray someone can help me.

I’ve searched forums here for the last three days, and can’t find anything that fixes my problem.

I built a machine to use as a server. It’s running Windows Server 2003. I’ve got a LiteOn 451S burner in it, and a LiteOn 18P9S reader. I have Nero 6.6.0.13 installed as the burning software. I cannot burn data to a DVD to save my life.

First, I left the firmware alone on the burner. Installed Nero v6.3.0.3 on it. Launch Nero, it gives me an error about “known compatibility issues with this operating system”. I continued, ignoring the error, and attempted to burn a data DVD. Burned fine, or appeared to. Upon data verification, about 5% of the files failed.

Then I updated the firmware to CG5G. Tried again, again ignoring the error. Exact same result, exact same files failing data verification.

Dug around, found the upgrade for Nero to v6.6.0.13. Ran that. Tried again, now I have a new error. The DVD seems to burn fine, but during the data verification process, I get sector errors every 2 seconds, all the way through the process, the source and destination sectors are different (I think is the error).

Tried upgrading the firmware again, this time to VS0G. Same exact result, sector errors.

I’m at a loss at what to do. Is there some problem with Nero and Windows Server 2003? Is the burner foobared? Am I missing something extremely simple?

Any help is greatly appreciated, I’m about || this close to chucking my server out my window.

If there’s anything else I need to provide, please let me know. I’m completely new to the whole DVD burning thing, so I apologize in advance.

Thanks!


#2

Thats kind of an old burner. You could get another one prety cheap. Still, theres no reason that you shouldn’t try to get it to work. Forgive my being to lasy to go figure out what firmware vsog is but are you running it 451s@832s? I’m running an 851s@832s and it is still my fastest burner when burning at 8x. While I think it is a great burner, it is a little pickier with media that say for instance, my nec 3500 that will burn just about anything. I think the 851’s were considered a little beter than the 451’s though.
If you haven’t, I would defanatlly omnipatch your firmware. It can greatly improve the performance of liteon burners.
http://club.cdfreaks.com/showthread.php?t=97590
Second thing is media. Liteons (especially earlier models like yours and mine) do not like - media so stick with +r’s.
What kind of media are you using? Use this free program to find the media code (manufacture id and media type id) of the disks you are using. This is the true manufacture of the disk.
http://dvd.identifier.cdfreaks.com/
Post what you find out. If you want some media that is just about guarenteed to work well with a liteon, get some maxell 4x+r’s. Check the media code if you get some, but they are just about always ricohjpnr01. Liteons love ricohjpnr01’s. They should burn very well at 8x even though they are 4x media (some people have been overspeeding it all the way up to 12x with nec 3500 burners and are getting good results).
Something else, have you been running kprobe scans on your disks? The 451’s were a little buggy with how they reported in kprobe, but it doesn’t hurt to try.
http://club.cdfreaks.com/showthread.php?t=83441#media-kprobe


#3

Firmware VS0G is SOHW-832S, gotten from here : http://codeworks.cdfreaks.com/firmwares.html That’s also where I got the CG5G firmware from. I haven’t run the omnipatcher, I’ll give that a shot when I get home (am at work atm). As far as media, I bought a 25pack of Maxell 8x +R DVDs, which from what I gather is a decent media type. I found a list somewhere showing who actually manufactured media, but I can’t remember where.

Haven’t tried kprobe yet, so far all the errors I’m seeing are from Nero when it performs data verification.

Also, I tried burning a CD last night, just to get some files backed up. This CD also failed, about 2% of the files backed up were different when Nero performed its data verification. These were Memorex CD-Rs.

Seems with both DVD and CDs screwing up, either by burner or my software is shot. Or, I totally screwed up the firmware upgrade. Basically, I DLed the firmwares from the site listed above, and ran the .exe from Windows. Do I need to run Omnipatcher first?

Sorry for the stupid questions, and thanks for the response.


#4

Maxell 8x+r should be maxell002 (but could be ricohjpnro2 or ritekr03). Its usally the maxell media code and it is very good media. Check it with dvd identifier. Even good quality medias can burn bad without good firmware support though. Omnipatcher can sometimes fix this. When you use omnipatcher, thier is a button that says apply recomended tweaks or something like that. Defanatly use that as that is what will imporve some of the write stratagys so certain medias will burn beter. I havent flashed new firmware on my liteon in a while as the firmware I am using (vsob) has been working very well for me. If memory serves though, get another copy of the firmware that you want to use (like vsog if thats what you like), and load the firmware into omnipatcher (it should work on the .exe windows installer if I recall right, read the omnipatcher thread for instructions). Then flash the firmware that omnipatcher modified. You can use omni patcher on any liteon firmware. It sounds like you have tried diffrent firmwares so I would run a kprobe scan on a dvd that has been burned. It can give you a beter idea of exactlly how bad it is burning and if it is bad overall or just in a spot. If it is just bad in one spot, that usally indicates that the firmware and media don’t work well together, whereas if it is bad throughout the whole burn, it could be the burner is not working right, the media is defective, or again, the firmware and media don’t work well together. Post the media code from dvd identifier and a kprobe scan (ran at 4x) and I can give you an indication of how well it did. By the way, I think that I already mentioned this, but some 451S drives didn’t do that well with kprobe (the newer drives give more reliable scan results) but I would still try and see what it gives for results as it still might help you troubleshoot the situation.

Links
dvd identifier
http://dvd.identifier.cdfreaks.com/my_site/download.htm
kprobe thread with a link to the software
http://club.cdfreaks.com/showthread.php?s=&threadid=93944
the place where you can find out what media codes certain brands use
http://www.videohelp.com/dvdmedia
omnipatcher thread
http://club.cdfreaks.com/showthread.php?t=97590
Defanatly look through the liteon forum too. thier are other tools too. Thier is an eprom utility that can reset the eprom (I have never used this and don’t know much about it). Liteons aparently learn to burn media. If it learns wrong it can keep burning bad. Reseting the eporm makes it learn over again. At least that is what I understand it to do, but like I said, I havent used it so read the thread on it in the liteon forum.


#5

Excellent, thanks a ton for your help. I’m heading home for lunch, and will give the kprobe and dvd identifier a shot, along with omnipatcher. Will report back when I get back to work. cross fingers


#6

Okay. Here’s what happened :

DVD Identifier reports RITEK-R03-002. As far as I can tell, that’s supposed to be pretty good media.

Ran Kprobe on one of the DVDs that reported a bunch of errors. This is what I got:

Date : 5/31/2005 1:07:14 PM
Model : 1-0-0-0 E:LITE-ON DVDRW SOHW-832S VS0G
Disc : DVD+R , RITEKR03 [RiTEK Corporation]
Speed : Max
ECC blocks sum (PI/PIF) : 8/1
Scanned range : 0 - 1868762
Sampling count : 101844
Errors : 0
PI Max : 375
PI Average : 34.76
PI Total : 493461
PIF Max : 209
PIF Average : 3.93
PIF Total : 55820

It doesn’t show errors, which I find odd. I tested to make sure, after Nero reported errors, and one of the filenames that it said was different from the original would not open. The one on disk did; the one on the DVD couldn’t open, windows told me the .zip file was corrupted. So it seems the files did in fact get screwed up, but I don’t know how.

I also have a screenshot of the results, but it’s in .bmp format and is rather large. I don’t have a converter on this machine at the moment. I’ll try to get it converted and see if I can post it in this thread later, if that would help any.

Ran Omnipatcher on the CG5G firmware I found on this site, here : http://codeworks.cdfreaks.com/firmwares.html
It didn’t seem to do anything, it showed 0 changes. I went ahead and re-saved it.

Installed that firmware that Omnipatcher had modified, changing it from the VS0G that I had. Tried to burn another DVD.

Data verification results in 800000 errors. All of them are in this format : “Sector xxxxxxx on disc has different content to source”.

Sigh. Any further thoughts? Should I get a hammer and beat the burner to death?

I’m just paranoid it’s an IDE/software/OS problem, and buying another DVD burner would result in the exact same problems, which would lead to me throwing the server off the highest building I can find.

Thanks a ton for your help.


#7

Try this first (since I didn’t seem to have recomended it yet and it is quick and easy). Download cdspeed (free)
http://www.cdspeed2000.com/
and run a burst rate test. While it only needs to be about 12mb/s for 8x (I think), it should be at lest about 20mb/s.
Next do a transfer rate test. If the curve is nice and smooth (or thier are just a few small sudden dips that come right back up, that can be caused when the burner switched burn speeds), then it means that the drive is not having problems reading the disk (if it has problems reding the disk, it slows down to try to read it which causes the scan to drop down. you can save the transfer rate test as a png and post it too. If the transfer rate test is smooth, then I would tend to think that the data is getting corupted somewhere along the way rather than it being a bad burn, and the kprobe scan can help cooelate that so post the graph (you can just rescan and save as a png if nessasary). Scan at 4x this time (the option is on the right side in the middle). It takes longer but will make the scan more comparible to everybody elses scans.
Kprobe should give you an option to save in png format which is below the size limit for what can be posted here (click go advanced and attach the image). Pi average of 35 is aceptable but pi max of 375 it total shit. Pif average of 4 is a little high but acceptable but pif max of 209 is total shit again. Small single spikes can sometimes be ignored because they can be caused while the drive is reading, but if their is even a small area going that high that part of the burn will most liklly be unreadable. You can tell more from the graphs but those maximums indicate that it may have screwed up somewhere while burning. Considering that that the averages are so low, and the highs are so high, I would suspect that it is only messing up in areas, not the whole burn, in which case it is probably a media/firmware combination problem.
I cannot really say for sure.
A couple things you could try. When you installed the drive, did you use a new ide cable or the exsisting one? If you used the exsisting one, try a diffrent ide cable. A bad or cheap ide cable can cause all kinds of problems including data coruption and it can be a very hard problem to pin down.
Try switching if it is master or salve, and switch which channel it is on. Believe it or not, it sometimes makes a diffrence (dvd burners can be quirky like that). Since you said this was a server, is it running off a pci card ide controler? Some (more than a few) controler cards have issues with optical drives.
Clonedvd has a free trial (but I guess that you are burning data so that woulddn’t help). Try diffrent software (see if you can find something with a free trail so you can just use it to trouble shoot). Do you have other burning programs besides nero installed? While it usally doesn’t cause porblems, occationally it does.
No need to try all this before posting again (I just came up with as many ideas to trouble shoot it as I could think of). Try something and post and maybe it will expose the problem (maybe do the scans and then post them).