HELP! Mad Dog External Wont Recognize Blanks

vbimport

#1

I posted this in the newb forum, no-one would touch it with a ten foot poll,
please help me!

BACKGROUND:
I’ve been troubling over this for about 3 days now. I recently (no more than a few months ago, mabee 6) purchased a Mad Dog Multimedia Dominator USB 2.0 External CD-RW / DVD combo drive. I have had few problems with the device to this point, It reads data and music cds, programs and dvds without difficulty… including burned cds (from other burners). I just recently tried to use it to burn a cd, and much to my surprise, it does not work. Despite the brand of medium, and / or burning software / utility, or any itteration of the two, I am stricken with the same problem:

CURRENT ERROR:
“Please insert a blank cd or compatable media into the drive”
“Drive is empty, Please insert a blank cd” ;

I have seen others with this problem and scoured forums long and hard (and please spare me the ‘of course it can’t read a blank, its blank!’ or ‘Is the cd in shiny side down?’ [yes someone asked me that])

things I tried:

ASPI:
Much to my amazement, I did not have an ASPI layer install whatsoever, so I did install and confirm all 4 components with that adeptec aspichk.exe or some such; version 4.6, thats the one everyone claims the least problems with, and the version forceASPI uses I think… Still the same deal.

FIRMWARE:
There are no firmware flashes for usb externals as far as I know ( I may be speaking from ignorance here, this is my first external drive ) but the drive is only a few months old and I have read pleanty of forum posts raving about the dependablity of this drive (!?) thus I doubt greatly it is a driver or hardware issue. The device has not been used a whole lot, and it reads terrificly, I doubt also that the lens is dirty or faulty. I DO have the latest USB 2.0 drivers installed.

SPYWARE:
I scanned my computer with Ad Aware and Spybot S n D, yet my plight persists… I am out of ideas, and I am not very keen at throwing more money at this problem.

I just bought a new drive! I have yet to burn ONE SINGLE CD since burners came to public markets, I wana try it! Please help me!

System Specs:
M-Tech Notebook
P4 2.5ghz 1gb ram 36.4gig hd, internal combo drive (no longer functioning and deactivated) etc. I’m not sure what else you’d need

I’ve tried these burning programs: Windows XP Pro builtin, Nero Express 5.5


#2

Hi, and welcome.

Do you have another computer that you could try the drive on? Find a friend who is willing to indulge you for 15 minutes (at least it’s an external, so it’s just plug-n-try), if you must. If it doesn’t work on another computer, then it’s most likely a defective drive, in which case, you should contact tech support and get a replacement.

If it works on someone else’s computer, then it’s a problem on your side. But until you’re sure that it really is a problem on your side, it’s not really worth your effort chasing through a maze of possibilities.


#3

Ok I dug up an old dell P3 500mhz with windows xp 192mb ram, and hooked it up; boots fine. I plug the drive in: blue screen of death IRQ error(?). This is odd, I did some checking, it seems XP wont allow you to change IRQs either. I suppose this could be IRQ related, but why does it read without problems? I’ll do a bit more checking but It doesnt smell like IRQ. Until then, my girlfriend has a nice notebook too, I’m gona get her to bring it over, but It will be another few days until then. Please if anyone has a suggestion post it

On another note, I’m aware that different burning programs use different encoding and writing methods and alot of them install the system files and layers that may be missing. If anyone has a suggestion for some free burning softwear to try please post it, I’m determined to fix this.


#4

Download the trial copy of Copy2DVD. It is a good burning program and works well with my usb burners. I may be that your Nero is to old for your drive.


#5

Ordinarily I would like to agree with you about the nero version issue, but the version of nero came WITH THE DRIVE! It is, of course, possible that they overlooked this, and that mad dog packages this version of nero with all their burners. I will try the program you recommended and report my result.


#6

I tried Copy to DVD:

ERROR: media not found!

more of the same old sh*t… this is getting irritating. Its quite evident this problem transcends my choice of burning software.

I’ve thought of another possible solution; the lens could be dirty. This is unlikely because of the age of the drive; it was manufactured in mid 2003, and purchased in early 04, I do smoke in my room, mabee some particulate accumulated on the lens. Blank cds DO have information on them identifying the format, total space etc. and it tends to be more faint than the data on comercial cds… I guess it could be the lens. I’ve tried to disassemble the drive but its next to impossible. I dont like those “cleaning” cds. They’ve messed up optical medium devices of mine in the past.

I’m going to test the drive on my girlfriend’s notebook. If this is yeilds the same result, I think I’m gona crack the bastard open with a prybar and swab the lens with lens cleaner and a lentless lens cloth.

Please, before I void the warrenty even worse, some one tell me something else to try!


#7

Update: I tried the Drive in my girlfriend’s laptop (who’s burner works perfectly)… Same thing! I disassembled the drive and cleaned the laser lens TWICE with lens cleaner and swab; and again with a lentless lens cloth. SAME PROBLEM.

The Mad Dog Dominator is NOT a good external usb drive. DO NOT BUY THIS DRIVE!!! MAKE ANGRY! WANT SMASH!

I may try the internal flash, as the usb mounting device is indeed an IDE controler. This is my absolute last resort. I have never flashed an external usb drive, and this could likely ruin it.


#8

Don’t you love those people that respond to questions without giving an answer? Well, I’d be one of them.

I’m in pretty much the same boat with my CD burner except mine is internal and it’ll only recognise (and burn without problem) these old Imation disks I bought years ago. Now that I’ve run out and tried other brands, it won’t recognise any of them. It won’t even recognise the new Imation disks that I bought today, though everything about them is the same as the old ones and the speed is 1-52x (I think I run about a 16x on here).

Sorry to hog your thread with that, but I thought your problem sounded similar to mine and two birds could be killed with one stone here. If not, I’ll post this question in its own thread later.