[help] LG GSA-H12N Go back to old firmware?

vbimport

#1

Hello my friends,

I just bought my new LG GSA-H12N and I am in trouble! Please help if you can. :sad:
My drive didnt function good. I used to get stuck after every second disc. It didnt read 70% of my CD’s. So stupid me, I thought i should upgrade the firmware. It came originaly with firmware UL01 and I upgraded it to UJ12.
Now i have to return my DVD drive to the store or service since it’s still not working well. But if they see i changed the firmware I think they will refuse to take it back or repair it ! :frowning:
I want to go back to the official firmware before i go to the service. I have two problems:

  1. I can find anywhere on internet the version UL01 to download?
  2. I have the newer UL02 but i cant flash the firmware back from UJ12 to UL02. The upgrade file doesnt recognize my drive at all??

Please help me! :o

Thanx in advance!


#2
  1. There is no UL01 to download
  2. You can use the MCSE tool by ala42 to patch the Firmware flasher UL02 to be able to “crossflash” your drive.

http://ala42.cdfreaks.com/MCSE/


#3

Thanx for your quick reply!
I have that tool now, but how to crossflash exactly? I loaded UJ12 firmware into the MCSE and in lower right corner pointed the model “GSA-H12N” and saved the firmware. After that, i flashed my DVD. And after that, i tried to flash it with official UL02 and still it didnt recognize my drive!? Where did I go wrong???
Thanx again!


#4

You need to select H12N in the drop box and a message pops up to confirm. Accept the message and save the patched flasher. Execute it with no disc in the drive.

More details see the MCSE for LG drives topic http://club.cdfreaks.com/showthread.php?t=133858&page=25&pp=25


#5

I did that! Thats what i wrote in my previous post. I took UJ12 firmware and choose the H12 in drop box. And saved it ofcourse. After flashing it, it stays the same. Only UJ12 firmwares are recognized when .exe file is executed. Every time i open the UL02, it doesnt recognize my DVD drive in drop box.
Maybe i should patch the UL02 firmware and then it might work?
I am not at home now but i will try later. If anyone knows any solution that will work for 100%, please let me know now.
Thanx in advance!


#6

:clap:


#7

That is the way. :bigsmile:


#8

Thanx guys. I will let you know as soon as get home. ;->


#9

It worked! Thank you guys for your help.
Now, hold your fingers for replacing of my drive without any problems :frowning:
And one more question, how do I return to RPCII state in firmware? In original it shows RPCII with 5 changes left. Now it shows RPCI without any limits!
I am afraid that service might think I tried to mess with multiregion so i ruined the DVD myself. I am just trying to return the DVD to the state as close as original from factory so i could take it to service for fixing or replacement.
Thanx in advance.


#10

When you have flashed the UL02, the state should be RPC2. Maybe AnyDVD is running?


#11

I dont have software like that. I even if had something like it before, it’s not running now for sure! When my drive arrived with UL01 it was RPC2. After flashing with UJ12 it became RPC1. Since then, anything i flash or do, it stays RPC1?! Very strange.
But i have some expirience with flashing the MTK based DVD (home) players. And once you flash it with Region 0 firmware, every firmware you flash after it, it will allways stay region 0. And that is because the region value is stored in EEPROM of the player and it is not in firmware, but you can change that value by setting the right value in firmware that will tell the EEPROM to change the region value and keep it that way.


#12

I also flashed from UL01 to UJ12 (RPC1), and than to UL02 and than to UJ13, and its again RPC2


#13

Yes, i had the same case with UJ13. I indeed was RPC2. I forgot to mention. But when i patched the UL02 (in order to go back from UJ13 to UL02), and after that i flashed it with official UL02, It became RPC1!!! Very strange.
I guess if you go now back to UL02 from your UJ13, you will see the same thing!


#14

It worked finaly. Just needed one more reboot. Damn m***soft :slight_smile:
Thanx to all of you for help and support!