Help! I think I`ve Killed My Sony!

vbimport

#1

Hi this is my first post, I had a similar problem with my Sony DWD22A as described in this post http://club.cdfreaks.com/showthread.php?t=120720 after reading the post I downloaded the file “Sony.710A.BYX2.stock.exe” and ran the file as per the instructions, however after the program got to 100% nothing happened, the close button was still grayed out I waited a good 15 minutes, the program said 100% but all buttons still grayed out, I rebooted my machine and now there is no D: drive or any other cd/dvd drive. Tried to run the program again but it can’t find any cd/dvd drive to flash to. Any and all help would be greatly appreciated.

Regards, Nervously

Andy
:o :o


#2

It sounds like that you had some typical flashing-in-Windows problems. Use MtkFlash to flash the BYX2.BIN firmware (included in the BYX2 package you downloaded), and that will update your drive to BYX2 and revive it at the same time.

From the FAQ > http://club.cdfreaks.com/showthread.php?t=109986#ts-misflash


#3

Did you happen to have disc in the drive while you flashed it?

You’re gonna have to find a dos flasher, think you can get it here.

Edit: It’s pretty hard to beat Code to the punch… :cool:


#4

I used to be very careful about removing any discs prior to a flash. And then there was once when I accidentally forgot to do so, and to my surprise, nothing bad happened. And ever since then, I’ve never bothered to remove any discs before a flash, and it’s never caused me any problems…


#5

flashed already 6 times, everytime there was a disc in the drive. nothing happened. you don’t even need to reboot your pc.


#6

Ok I have now got into DOS and using Mtkflash 1.83c am trying to fix my drive using the BYX2.bin file, I am using the following line “mtkflash 3 w/m byx2” I am guessing at 3 “secondary master”. when I hit enter it comes up with
“Port: 170, Master/Slave: a0” what does this mean.
Thanks
Andy


#7

According to your post in the firmware forum (please do not crosspost; continue in this thread instead of starting a new one in the firmware forum), you mentioned that this drive was for your laptop. Is this a drive in an external USB/Firewire enclosure? If so, then you cannot flash it using MtkFlash. You must remove the drive from the enclosure and hook it up to a desktop in order to use MtkFlash.


#8

Thanks for your reply and sorry i thought i had perhaps posted in the wrong forum.

the dvd drive is built into my laptop (internal), although i do have a pioneer 107 usb which i have flashed and it seems ok.


#9

Um. The Sony DW-D22A is not an internal laptop drive. It is a standard 5.25-inch half-height drive for desktop computers. And neither is the DRU-710A…


#10

Sorry you are correct it is a sony DW-D56A


#11

You find links to the firmware here. You have to flash it with ltnfw, select update bootcode when flashing.


#12

Thanks for the reply however according to the download page:

LtnFW is a Windows-based firmware flashing and backup tool. You can use this tool to flash drives using firmwares in the raw binary (.BIN) format. This tool can also be used to make a backup of your drive’s current firmware.”

This tool cannot be used for recovering dead/unrecognized drives. Only MtkFlash can be used for recoveries.

My drive is completely dead

Thanks Anyway

Andy


#13

Ok, then follow the link I posted to mtkflash.


#14

I have tried mtkflash with several diffrent bin files, However I keep getting the same result:

Port: 170, Master/Slave: a0
then nothing, after waitng for over half an hour if I press Esc I get:

Status = 00, should be 70
ERR: user break

Any help would be gratefully recieved.

Andy


#15

Which mtkflash version did you use ? Did you boot from a dos floppy disk ? Which command line did you use ?


#16

You might have to hold the drive’s eject button, at power up, to enable MTKFlash to work. :wink:


#17

Hi
Version 1.83c
Yes
mtkflash 3 w/m pds3
mtkflash 4 w/m pds3
mtkflash 1 w/m pds3
mtkflash 2 w/m pds3

Not sure if my drive is primary or secondary, Master or slave, using 3 and 4 gave me error above using 1 and 2 gave me:

[B][I]Port:1f0, Master/Slave: a0

ERR: file mtkflash.typ is not exist![/I][/B]


#18

Thanks tried it and did`nt work

Andy


#19

There has to be a blank after the ‘w’. mtkflash C will scan for devices, it should be secondary master, so use 3. Is the filename really pds3 ? I would expect pds3.bin, so check this in dos with the ‘dir’ command. You also have to add /b to get binary mode, so try:
mtkflash 3 w /b /m pds3.bin


#20

Note the error message that you bolded. You must have the “mtkflash.typ” file in the same folder as mtkflash. This file defines the settings used for different flash types. The file comes with mtkflash 1.83c