Help! I think I toasted my Sony DRX-700UL

vbimport

#1

arg :Z I was doing a firmware update for the Sony DRX-700UL and folllowed the instructions (uninstalled InCD, removed disk) but I forgot I had the drive connected via iLink and not USB as warned. The firmware update did not run and when I rebooted, I noticed that the drive was no longer listed in device manager. So I went back to a previous restore point, reinstalled InCD, and still no luck. Did I toast the drive?

The one thing that still works on the drive besides the door and read mechanisms is the ilink pass thru. having a digicam connected thru the drive is found, but not the drive itself.

is there anything i can do? i can’t see any reset switch on the outside. I even tried using AcronisTrue image recovery cD to see if at a low level the drive is recognized. its not. what to do? it was a wonderful burning system and now i have hosed it up with clients waiting!

i am running windows XP home sp2 on a sony laptop TR3. i have tried seeing the drive in both ilink and usb direct, but no luck. thanks!!!


#2

The drive is probably fine, Plug it into another computer and see if it is found there.


#3

thanks dhc, that was my next step and i am off to do that now (i live in a small village outside of kathmandu, so it’s a 4 hour trip there and back to a decent pc shop). i guess i should flash it there? but i dont understand why my system cant see it. i’ve even went back a week using my Acronis backup archives (clean working partition) with the same results. but off i go - will report back…


#4

Woa, that’s quite an inconvenience…

If the drive’s firmware was never flashed, as you said it was not, then the drive itself cannot be damaged. Instead, there is probably some sort of driver problem or something. Try unplugging the drive’s power, and unplugging it from the computer, then restart the computer. Then plug the drive’s power back in and connect the drive to another plug on the computer different from the one it was connected to before.

Merged his two threads
Everything below was his second thread.


#5

hi, i just downloaded omnipatcher and tried to apply Sony.700A.VY08.stock.exe to a sony DRX 700ul external that is not recognized by the os, so for all intents and purposes, a toaster. But it seemed to work! I got a message the first time saying 16 write strategy replacements applied / 4 writing speed adjustments applied. So what did i do? did it update my internal CD/DVD in my sony TR3 laptop instead? seems to still work fine.

let me explain my problem. i had a fully functioning drx700ul burner attached via firewire and tried to run the firmware update from the sony website. nothing happened at all. then in reboot the drive was gone. i’ve tried it on other XP os machines and it wont show up there either. i’ve tried usb interface and ieee interface. this drive appears lost. i live in nepal, and there is no way to get a replacement anytime soon. the sony repair center closed due to bombings and whatnot. i have folks waiting for DVDs and dont know what to do, although there is an internal liteon 16x on the market here. its internal and i have a laptop. so i am considering either trying to use the sony enclosure or find another to make a burner work on my usb/ilink laptop.

one suggestion was to pull the sony drive out and connect to a desktop via ide to see if it’s recognized. i guess thats my next step unless u all can help me. please try! this is a an underdevelped country in the midst of civil war and your efforts could be considered humanitarian! but whatever, i am deeply appreciative!!! thanks!!!


#6

with omipatcher, you can only patch the firmware file (.bin or .exe) after the patches you MUST save it and then run the flasher. but if your drive isn’t recognized, you must flash in dos.

Take the .bin file of a firmware (CG3E) and flash it in with MtkFlash or MtkWinFlash.
you can run the firmware through the patcher and save it before you flash it.


#7

Oh i get it - omnipatcher just patches the firmware update, not the firmware! duh. okay, but i have no idea how to see the drive in DOS, i do not even own DOS, and how would i find a DOS driver for this DVD drive?? There is no mention of DOS anywhere in the docs. But i am all ears, thanks!!!


#8

it seems like i will have to connect this via IDE, yes? but not on a laptop right?


#9

@ herojig
I did a ‘search’ and found mtkflash with instructions here. :slight_smile:
I know you are desperate, but please don’t double(or double-triple :rolleyes: ) post :cop:


#10

1/ Please do not crosspost. Posting about the problem in 6 different places will not yield an answer any quicker. The duplicate posts have been deleted.

2/ You are in a sticky situation because of the fact that the drive is in an enclosure and because you have a laptop. MtkFlash will not work for you. In situations like this, there is really not much that we can do (unless you’re willing to get a desktop PC, open up the external casing of the 700A, etc… well, you could buy a new internal drive and put it in the external casing I suppose). I think that the best course of action is to contact Sony and tell them what happened–that you followed their instructions and that the drive misflashed. You may be able to get a replacement for the drive. This is also the only way to solve the problem without losing your warranty! If you open up the external casing and whatnot, you will void your warranty.


#11

code65536, while i appreciate your sense of organization, of which i have never seen such efficency on any of the hundreds of forums that i subscribe to, i dont think it’s helpful, there are so many related issues and posts that address them i think it would have been helpful to leave things the way they were, but hey, who am i to complain.

there is nothing that sony can do, the drive was bought in the usa and reliable mail service in nepal is non-existent at this point in time, so yes, i am borrowing a desktop and trying to use mktflash and all the other suggestions that i have found very useful here in the other threads.

you say that “you could buy a new internal drive and put it in the external casing I suppose” well this is exactally what i was trying to assertain in the other threads, that’s why i was over in the liteon forum, as the guts of this thing seems to be a liteon 1633s, but how to find out now the thread was moved? you see, suppose is not good enough for me right now, i am trying to gather expert knowledge from this fine forum. thanks!!!
jigs

related issues:
liteon 1633s vs. sony 700ul
Vy08 vs fwupdate
mtkflash vs eeprom_utility
others…


#12

Actually, I don’t have any powers in the firmware forum. :wink:

But allow me to explain myself and why I felt that a consolidation is better… It is my opinion in this particular case that it would be better if everything is consolidated into one thread. MtkFlash is a firmware flash tool used usually for dead drive recoveries. The EEPROM utility doesn’t even have the ability to read the firmware, much less flash it, and thus, they are two very unrelated tools. The VY08 thread was intended mainly for the results of the firmware itself and not for dealing with misflashes (because misflashing can occur with any firmware, not just VY08, and thus, it is not an issue specific to VY08).

Anyway, this is what you said in the VY08 thread:

there was also another update called FWUdate that did something regarding waking up the usb after suspend - this is what killed my drive - does anyone know how to reflash this update or what it really does? i dont have a bin for this, only for VY08?

So you are saying now that it was the firmware update for the USB interface that killed your drive? You were never very specific when first posting about the problem, so it was assumed that it was VY08 that killed the drive…

  • FWUpdate is for the external enclosure in which your drive is enclosed.
  • VY08 is for the drive itself.

These are two different devices with two different firmwares. MtkFlash is designed to fix a misflash of the drive, not of the enclosure. So if your drive is not misflashed, then MtkFlash will not do you any good.

I do not know of any way to fix a misflashed enclosure except to get a replacement enclosure.


#13

code dude, this is very helpful info indeed! so i bet i just ruined the enclose and when my bud arrives with desktop (from another village) that will be the test, if the firmware is recognized in ide on desktop as ok, then this would prove your point, and i can get enclosures here. i’ll know in just a few hours. thanks so much for ur help even if i seem a bit cranky. i find this forum invaluable for all my cd/dvd activity and very grateful for it. i wont even bother to post the transcripts from sony support online chat, it was so silly. essentially it is as it always goes: if its broke, send it to us, we may be able to fix it sometime next year.

anyway, i will post back results of ide test. do you have any idea on what to look for in an enclosure? they are very limited here in stock and most stock is at least 1 year or more behind the (western) times.

jigs


#14

Solution: this is what you get when a cartoonist messes with firmware…

So my problem was with the ENCLOSURE firmware, which as far as I can tell is un-upgradeable in its current state. No prob, I’ll just scrounge up a usb-ide bridgeboard like the one in the picture, and retrofit the Sony drx-700UL 200USD$$!@@#$ case and then, good as new, well, maybe even better. Thank you all who contributed to this creation. I’ll never forget u.
jiggy


#15

FYI, the controller should be a prolific PL-3507. I don’t know if anything discussed in this thread would help or not.


#16

dhc014, thanks for that but the prob is not in the liteon/sony firmware but in firmware associated with the ide/usb/ieee board, which seems to contain a generic oxford 911 chipset. i guess if i had more guts and time i could try and find that firmware and somehow assertain which ide channel the drive is on, and try to flash it that way, but i have not idea on how to do that or where to find an appropriate bin file for the bridge. any ideas on that? i can get a generic enclosure here i think that i would then retrofit into the sony drx700ul enclosure. they all seem pretty standard, and as u can see from the pic, a very old Que ide-usb enclosure did the trick. it’s just pretty ugly sitting the way it is!
jigs

UPDATE: clicked on the wrong link in your last post! but the thread u pointed to is very hopeful, as it looks like that’s my chip! but all the posts there seem to be about how hard it is to find the firmware…but it’s promising. thanks!