Help - high cpu utilization

vbimport

#1

Nero cd/dvd speed shows:
1x - 10%
8x - 75%
Burst - 14MB/s

Which is about 10% higher than normal from what I gather and precludes burning faster than 8x :Z

I’ve tried; putting drive on primary IDE, new cables (80 conductor of course), diff. brands of disks, removing antivir and other things… (Task mgr shows 0-1% util - until burning/testing starts.)

DMA is enabled - shows “Multi-word DMA Mode 2” instead of Ultra-DMA. Forcing PIO results in CPU utilization of 1x @ 64% and burst rate @ 2MB/s so DMA is working.

System is Gigabyte GA-7DX Athlon 1.2Ghz w/ 768MB,
Benq 1620 flashed to B7P9 as secondary master.

Hoping someone has an answer so I can use my Benqy at it’s full potential.

TIA


#2

When using XP, use the original microsoft ide driver instead of motherboard specific drivers. If you already do, delete the ide channel in the device manager, reboot and let windows redetect it.


#3

If the motherboard is forcing multi-word DMA Mode 2 then the best you will get is 16.6 MB/'s so your almost hitting the ceiling so to speak its not the same as Ultra DMA Mode 2 which offers 33.3MB/'s

Gigabyte GA-7DX uses the AMD 761 northbridge & VIA 686B southbridge and the 686B is a really (there’s no other way to say it) crappy southbridge it might just be that it wont get any better…

You could try flashing the last bios update Gigabyte made for the motherboard in the off chance they fixed a few of the bugs or it will re-detect the drive in the bios as a UDMA 2 device. Gigyabyte don’t offer much in the way of bios tweaking but I remember their being a key Ctrl+F1 that enables some hidden settings for Gigabyte bios’s you could see if anything useful pops up or try removing the IDE controller from the device manager like ala42 said.


#4

While I don’t have a Gigabyte motherboard (mine is MSI), I had better results when I informed CMOS there was nothing installed on the secondary IDE. For whatever reason, as long as CMOS was out of the loop, the operating system had less trouble setting the drive to operate up to spec (burst reaching 23Mbytes per second +, CPU max about 15% or so at 16x, though I have dual CPU’s, they’re 1.5Ghz MP (like the XP’s); very similar to the Athlong 1.2Ghz T-Bird in most respects. I think, too, when I get 15%, that’s 15% of two CPU’s, which might mean it would read 30% of one CPU.


#5

Thanks 8T8, I upgraded the MB bios. Have a new option as to IDE cable type. Selecting 66/100 now gives me UDMA showing and CPU util is down to only :Z :Z 8% @ 1x and 48% at 8x with burst now up to 24MBps.

This may be as fast as this puppy goes :frowning: Anyway, 12x is now possible. I’m going to try a fresh install of XP on a spare disk just to rule out all those little software glitches that are possible. If that doesn’t work I guess I’ll have to consider some new hardware :eek:


#6

Your motherboard is not providing UDMA support.

Multi-Word DMA means that the motherboard has provided PIO and Windows will use DMA transfers in software for decent speed.

Try setting all of the IDE channels in use to Auto-Detect, Auto Type. This should help to enable UDMA.

Clearing the CMOS may be indicated. In that case, clear the CMOS with the power cord unplugged from the a/c outlet. On the first boot, enter the BIOS and choose “optimized defaults”/“high performance” if the mainboard has that option. Next, choose the save and restart option. On the second boot, enter the BIOS and set up your mainboard to support your particular configuration. Memory speed=CPU FSB speed. Turn off any onboard features that are duplicated by add-in cards. Turn off any onboard features that are unused such as extra printer and serial ports. Have the drive channels in use on auto-detect with auto-type and don’t use the “detect hard drives” feature.

If this does not “dislodge” the problem, then Newegg has a replacement mainboard from PCChips at $40 that will outperform most Gigabyte boards. :wink: http://www.newegg.com/app/viewproductdesc.asp?description=13-185-033&DEPA=0


#7

Have you read post #5 ? 24 MB/sec can only be reached with UDMA. MWDMA is limited to 16 MB/sec.


#8

After trying about everything and reinstalling a test setup I stumbled on the answer and another big question.

When I run the test with a commercial disk I get 8x at 8% cpu utilization :slight_smile: , but use a burned data disk (various media) and cpu utilization is 48% :Z - problem solved!

BUT, is this normal and why?