HELP:Flashing went wrong

vbimport

#1

Hello to everyone

I’ve got this REALLY shitty dvd-rw named Artec VOM-12e48x(I didn’t buy it) who reads about 40% of dvds and writes about 10% at a speed above 1x :sad: So I decided to upgrade the firmware (only 2 versions 100a and 100d for a drive that’s at least a year old, may I add) mainly because my brother’s drive -Asus DRW 0804p(107d 1.18 modded)- doesn’t read all the dvds written with this crap( ex: in a time interval of 1hour i wrote 6 TDK’s 8x - the ASUS red only 4 of them - WTF?!o0) .

BAD idea. I used the dos flash tool that came with the firmware(100d) followed the instructions precisely( flash 4 w /b ;4-secondary slave, 3-secondary master) and BOOM(not really) input error!! updated 00%. :a

Of course, the drive doesn’t work anymore and it’s not recognised by the BIOS. IS THERE ANY WAY TO FIX IT?


#2

Cmon, really nobody knows? :confused:


#3

Just to be sure, you did boot from a DOS boot floppy containing the flash.exe and firmware file and entered the command:


flash 4 w /b 100d500c.bin

Is this exactly what you did ?
Your drive uses a mediatek chipset, so it is very hard to kill. As a first try you could repeat the flashing process. To do so, switch off your pc, wait a bit, press the eject button of the drive and keep it pressed, switch on the pc and keep the button pressed for 10 seconds. Boot from your dos floppy and try again.
It might also help to remove the other device from the IDE bus.
If this does not help, repeat this process with mtkflash 1.83 and 1.80 available here.


#4
flash 4 w /b 100d500c.bin

Yup. That’s the one ( well it was a.bin cause i renamed the file :wink: )
Thanks for advice, I’ll try that now.


#5

IT WORKED!. Thank_you_thankyou_thankyou.
I used mtkflash 1.83


#6

Now that it works is there another drive that I can mod it to? (ex: Asus 0804p->Pioneer 107d)


#7

No, there is no other firmware you could use.


#8

Ok. The reason I want that is because it’s wery picky at writing dvd’s, I mean it writes the majority at 1x(can’t choose the speed) Does’t matter how good the dvd is, TDK, Verbatim. I use nero. Can I get over this using other software?


#9

Use DVDIdentifier and post the media codes of your good media that allow only 1x burning with the 100D firmware.


#10

This is it:


status

[19:09:20] DVD+R/+RW Medium Detected. Starting Identification…
[19:09:20] ** Initiating ADIP Retrieval Method 1 (Original ADIP)
[19:09:20] ERROR : ADIP Read M1 Failed : Illegal request - Invalid field in CDB [05/24/00]
[19:09:20] INFO : ADIP Read Method 1 Not Supported ; Method 2 Will Be Attempted
[19:09:20] ** Initiating ADIP Retrieval Method 2 (Copy Of ADIP)
[19:09:20] ADIP Read Method 2 Completed Without Errors
[19:09:20] Disc Identification Completed Successfully


Drive capabilities:

** INFO : Drive = (null) VOM-12E48X [FW 100D]
** INFO : Write Capabilities = DVD+R DVD+RW
** INFO : Write Capabilities = DVD-R DVD-RW
** INFO : Disc = [DVD+R:MCC-004-000]
** INFO : Reference Speed : 1x DVD = 1385 kBps
** INFO : An Writeable Disc Is Recommended For Accurate Results
** INFO : Write Speeds (Supported By This Drive On This Disc) Listed Below

** INFO : GET PERFORMANCE Write Speed Descriptor(s)
Descriptor #1 = 1385 kBps ( 1.00x) - [CLV/Non-Pure CAV]

** INFO : MODE SENSE Write Speed Descriptor(s) [Legacy Command]
** WARNING : MODE SENSE Is Obsolete And Not Always Properly Supported
Descriptor #1 = 1385 kBps ( 1.00x) - [CLV/Non-Pure CAV]


Media info:

DVD+R Verbatim 16x
Manufacturer Name: Mitsubishi Chemical Corp.
Man.ID MCC
Media tipe 004
Recording speeds 1x-16x


#11

Next time, make sure the info looks like this. :slight_smile:
MCC 004 is not supported by your firmware, so it is burned with the default strategy. Better by 8x media next time. You can add it with my MediaCodeSpeedEdit tool, by renaming one of the media codes you do not need. To start, you could take the save way and rename MCC 003 to MCC 004, which should allow 6x burning. Using unofficial firmware will void your warranty.
Do KProbe or nero cdspeed work with your drive to scan the burning quality ?


#12

I did what you said but it didn’t work :frowning:


#13

How can I bypass the media check?


#14

Just to be sure: Do you see the MCC 004 code in the media list when you load the modified firmware in MCSE ? Is MCC 003 missing now ? You did flash the modified firmware ?


#15

To answer your questions: Yes No Yes
No because i did’t modify MCC 003 but other crap and added support till 12x. Didn’t work. Then tried it exactly like you said, didn’t work