HELP: DVR-108DX fried?

When I first got the drive the 1.14 hacked firmware was available for this drive so I upgraded. Things were going fine. Today I moved it to a new machine and decided to see if there were any firmware upgrades.

This is where it gets confusing, I’m not sure of the order of things, but I went from 1.18 to 1.10 to…well I tried a whole bunch of firmware’s and they all now produce the same thing, an unusable drive.

I am still able to flash, but nothing I do makes the drive usable.

The drive is a true DVR-108DX (printed on the sticker, but it says it was made by pioneer).

So, which versions of the kernel/firmware do I need to make this thing work again?

Oh, some additional info, not sure if it matters:
I’m running Windows 2k.
When I put a disk in, it looks like it’s reading it. After the light stays solid for a few seconds it then flashes, slowly for another 10 seconds and then stops.

And here is the output when I run dvrflash:
Device parameter was not given, detecting all DVR drives:

    Device : D:
    Vendor : PIODATA
     Model : DVD-RW DVR-108DX
  Revision : 1.10

    Status : RPC-2 (region locked)
    Region : none
   Changes : 5 region changes remaining
             4 vendor resets remaining
             state is 'Region not set'

Thanks in advance!

Update:

Even though I tried this at one point, the following worked:

I flashed the kernel/firmware back to the original PIODATA 1.10
I then ran the PIODATA upgrade to 1.18

Now it reads disks fine! I haven’t tried burning anything yet.