Help Computer locks up running DVD2one

vbimport

#1

Problem : my computer locks up when running dvd2one, it jsut freezes anywhere between 1% and 15%. I have deselected all options in the dvddecryptor file mode and tried 3 different movies, no luck. Tried another computer and voila! I have an athlon thunderbird 1.0Ghz with 760mhz ram and a raid 0 array 80gbs running w2k pro. system monitors shows memory ok and processor running at 100% and then it quits, temps all good.

Any ideas? anyone else have this problem? Please Help


#2

Same exact problem here, driving me crazy!

The program sounds great, and I’m a longtime registered user of Remote Selector.

What can we do to try and narrow this down?

I get from 1-10%. Freezes to black screen, need hard reset. Two different movies via DVDDecrpyter. Tried changing the physical destination drive, same. Win98SE. Two IBM 75gxp drives. AMD Thunderbird 1.0 at 1.1ghz. 512mb RAM. ABIT KT-7 RAID mobo (the drives are not in RAID mode either).

I have not tried another system yet.

Have not seen this kind of lockup with other programs.

This stinks. I just got my DVD-RW and am dying to try this all out. Aggghhh.


#3

Hey Phungus … first I do not freeze to a black screen just the desktop screen. I have tried dvddecryptor and smartripper, no difference as far as i can tell. Tried defragging, sending source to both fat32 and ntfs drives, no good. Tried long movies ( minority report, private ryan, snatch (i did get snatch to work once)0 and some short movies under 1:40, no luck. I am really stumped, i thought for a while it might be fsb speed (133) but others are reporting it works on slowers computers than ours. I shut down all other programs still locked up …

also, this may be unrelated, but i tried to use ifoedit92 and now it locks up on me too! Grasping at straws but maybe codecs, or something misconfigured…

does the abit k7 have via chipset?


#4

Well it sounds to me you are having a memory issue. I suspect this program utilized quite a bit of memory buffering while it transcodes. One other idea for the black screen, are you running a shared memory video card possibly?


#5

In regard to the video card question, no it is not shared … it is an ATI Radeon 8500 AIW 128MB. The memory issue has occured to me … a month ago i had to replace one stick, it was causing all kinds of probs. now have a new 512mb pc133 pny in slot 1 and a 256mb in slot 2 same brand. The memory that was giving me the problems was tossed. I can’t discount your suggestion, i only know what the diagnostic tests showed me which was the usage being way below max…
I have been trying to think in broader terms and wondr now if it may be the via chipset, specifically VT82C686B, in combination with my audigy platinum ex soundcard. Creative reports a problem with large file transfers, when you combine the two on some mobos. Any way , for anyone with similar probs, maybe you will see similarity in equip:
ASUS A7V133 onboard Promise RAID
768MB PNY 133 RAM
1.0GHz Athlon Thunderbird Processor
2 WD 40GB HD (in Raid 0 config)
ATI AIW Radeon 128MB Vid
Creative Audigy Platinum Ex
2 Lan (DLink and Linksys)
Philips 2010 CDRW
Creative 6c DVD-ROM
Sony DRU-500a Firmware f (connected via firewire)
Win 2000 Pro SP3
all the latest drivers


#6

I was having a problem with a lock up with ifoedit when testing the DVD. It went away when I updated my Video Card Driver for my ATI AIW 7500 to the newest catalyst drivers. Give that a try…

ed


#7

My WinXP system was rebooting after about 2 minutes of encoding.

I disabled my firewall (after logging off DSL) and the problem went away!!!

After the usual 12 minutes, I just enable firewall and login again.


#8

OK.

Yes, Abit KT-7 RAID is VIA, an older KT133 board.

I’ve got 2 256MB sticks of good Crucial CAS2 RAM. Never really had a problem. Video card is a GF4-4400. Drivers on everything are pretty up to date if not the latest.

Don’t have any problems ripping stuff to HD (Pioneer 106 slot).

Sound card is a TB Santa Cruz.

I guess I’ll do the driver rounds, but I do that pretty regular and upadates are sporadic at best with older hardware. Cept the GF4. I think my VIA 4in1s are 4.33.

The only thing we have in common at all is a 1.0ghz Tbird. But I can’t imagine it’s that.

Only other running apps are an IR remote program and Palm HotSync Manager.

The memory issue sounds interesting. I’ve never run into a problem with the RAM, but do think I am pushing it. I will check and throttle back the timing in the BIOS if need be to defaults. Hrm. Maybe that is it…

I’ll be back. Thanks for the replies.


#9

Thank you all for your replies, I am investigating all of your ideas and will get back to you. I now leaning towards any ‘large file’ transfers; phungus i would please try moving one of your video_ts folders to another partition and let me know if you have any probs.

Thanks again all


#10

Yo gator920:

I defaulted all my SDRAM settings to their conservative defaults versus my normal turbo charged setrtings. No change. Actually, instead of locking at a black screen, it just reboted. Minor change :slight_smile:

I now have a fear that it may be an IRQ issue. My two HDs are on my embedded HighPoint 370 RAID controller (tho the drives are not in a RAID). I just looked and saw that my FireWire card is sharing this IRQ. It’s never been an issue before but…

I am going to make sure my BIOS, HighPoint BIOS/driver, and VIA 4in1s are all up to date. I know there are newer 4in1s then what I have installed (current are at 4.45).

After that, I will try to isolate the IRQ my HPT controller is on. I see you have an embedded Promise RAID controller. Is its IRQ being shared with another device? Make sure your mobo BIOS, Promise BIOS, and 4in1s are up to date.

I am curious if other people that have no problems are sharing the IRQ their HD controller is on (whether that is embedded RAID, standard IDE, whatever).

I have two HDs. C is HD1, D and E is split off HD2. I currently dump VOBS to E. And E to C or D crashes. I will try from C to D or E (backwards) but I don’t think that’s it.

Also. My board is KT133, yours is KT133A. Very closely related. Anyone reading with either chipset that has no problems?

I can’t test further until tonite. Until then…


#11

You bring up a good point… I checked my IRQs and it seems all my PCI, Vid card, promise controller, and usb are sharing the same irq! I am not sure how to isolate my raid controller to another irq, is that a bios setting or can it be controlled within windows? As far as via 4in1’s i also have the 4.45 (hyperion) installed, the latest mobo bios installed. But I have not updated my Raid bios in a long time (I need a place to dump my hds contents).
Turning off firewall and closing all programs does not help.

I’ll get back …


#12

gator–

I am quite please to report I solved my problem! I am rather sure given the disparity of our systems, that a similar solution awaits you. Hopefully. My issue ended up having nothing to do with my RAID controller sharing an IRQ.

The disparity is actually what lead me away from thinking about OS, drivers, software, BIOS settings, etc. And to think more low level hardware. Like I posted before, I have two drives, 1 45gb (boot) and 1 75gb (minidv, vobs, whatever data). I had been trying to use dvd2one on the second drive, running over 2 partitions (D and E). So I tried simply copying the VOBs of my test movie from E to D. Explorer (not IE, the desktop) crashed. Aha. Something with high disk activity and large xfers seems to be not right. Even tho I’ve never had a problem in ANY game, application, drive benchmark, DVD ripping, etc. The RAID controller the drives are on is ATA100 as are both drives.

So first I set the UDMA speed for the drive down in the HighPoint RAID controller BIOS from UDMA5 (ATA100) to UDMA4 (ATA66). It helped a little, things went further then before. I was on the right track. Time to crack the case.

I had my 45GB boot drive on IDE3 jumpered to Master with a proper looking ATA100 cable (blue, grey, black) that must have come with the board ages ago. Drive to black connector. Looked good. But what the hell had I done to the 75GB drive?

I recall having to get a cable locally when I got that 2nd drive off the Net as OEM. It is some weird-o cable, maybe pulled from some specific Intel board box or something? It has the color coding of an ATA100 cable, blue at mobo end, and grey and black ends, but the black is in the middle and the grey is on the end? I had the black end in the drive, and the drive was jumpered to Master on IDE4.

So I did a bunch of swapping and testing and in the end what I did was put the 2nd drive as Slave to the first drive on IDE3, and jumpered both drives to Cable Select instead of hard jumpering them.

dvd2one then worked!

My problem was a funky cable and/or the drives being hard jumpered instead of using Cable Select.

I was going to get a new proper ATA100 cable today and try that out on the 2nd drive back as a Master on IDE4. But maybe not. dvd2one works. Everything else still works like before. I tested both drives the “old” and new ways with HDTach 2.61, and got similar numbers. So performance does not seem to be an issue. I’ll prob try another cable just to confirm the one cable being some weird POS so I can drive a nail thru it :slight_smile:

So. Check your cabling, change drives to CS, swap drives around, make sure of course the RAID controller can do whatever UDMA mode your drives can and is set as such if your RAID BIOS has such settings.

Good luck!! Let us know…

…I’m now off to register dvd2one.


#13

One more thing.

That is alot of devices on one IRQ it seems like :slight_smile:

I have a full tower system maxed out, and share many IRQs, but not that many on just one. That seems a bit weird, but I can’t really say. I know there are all kinds of issues between 9x and 2000/XP and ACPI and IRQs and blah blah blah. Check around for a FAQ of some kind on your mobo. There are some great ones that talk about this for the Abit boards, prob some for Asus.

I’d def look at the cabling/drive jumper thing before mucking with card swapping and trying to reassign IRQs.

Good luck!


#14

Congrats! I am glad you have success. I tried to post last night but could not, hmm. Anyway, I also had succes but i don’t have a final solution. As stated, I had a bunch of hardware running on irq 9, so i disabled everything i could and reenabled one at a time and then combinations. It seems that my sound card and a combination of any one other piece of hardware was causing me to lock up. When the S Card was disabled, i completed three trials. Okay, so i thought i would just reassign the sb audigy or the raid controller to another irq. Sounds easy right, no. Changing slot settings in the bios did nothing to change assignments in windows. argghh! Moving things around wouldn’t seem to make a difference since every accessory is assigned irq 9 anyway. So what to do? Research.

Again your post sends me in a new direction; I can’t, however, use CS and put both drives on the same ide cable. Each drive for the raid array must on a seperate ide channel and cable, the settings for my wd hds suggest ‘single’ jumper setting (as i recall ‘master’ does not work in this arrangement). Western Digital states “Master/Slave and Cable Select methods refer to having multiple devices attached to the same IDE cable …” My mobo/bios and HDs support ULTRA 100 and UDMA.

My only conclusion from your suggestions, is that i may have a ‘funky’ cable, maybe i got’em mixed up when installing everything? I’m going to crack 'er open and see.

I’ll check it out and get back
Thanks again Phungus


#15

Okay, here’s the skinny:

I swapped ide cables in and out to see if that made any difference. NOPE.

Research: After some internet searching, I have uncovered a small problem with the via chipset, in particular the vt8363c (via kt133a) controller seems to have problems with high activity, such as large file transfers, there is a ‘fix’ at http://www.georgebreese.com/net/software/
i have not tried this patch because i also read this version is unstable with the asus a7v133.

To compound the VIA problem, it seems Creative SoundBLaster’s are known for being resource hogs.

It is possible to manually assign IRQs but that means turning off ACPI and the CPU running a little hotter.


#16

NOTE – I wrote this before your last “skinny” post but had a problem and by the time I got to cut/copy/repost you had posted “skinny”. Please disregard anything which obviouslly flies in the face of your new findings. Based on the “skinny” post… BUT, that said. It seems you can uninstall the 686b/latency patch. So you may as well try it?? As well as try to free up your IRQ9 by reallocating other cards to other IRQs by manually moving them in different PCI slots and/or disabling any legacy COM or LPT IRQs not being used to help free up IRQs. As well as making sure Legacy SB option is disabled or changed to share with IRQ7 on LPT1, if you need legacy SB sound.

Yeah, alot of people always had probs with Creative cards early on with the Abit boards I recall (Live, dunno about Audigy), it’s only one of 5 reasons I didn’t use a Creative card :slight_smile: I would have figured by now tho all the drivers for everything would be solid? I do recall seeing scads of posts a while back about “pci latency patch” and some VIA boards and especially like you say some SB cards.

Good luck again. Keep us updated. You can always upgrade your mobo and CPU whch I was about to do as I had been meaning to for a while anyway :slight_smile:

— snip—

gator–

I tried to post then too I think, the forums were down, it was before I
figured out my problem myself and I was dying thinking the forum had info
I could use but not get to :slight_smile:

Anyway. Your RAID config makes things a bit trickier perhaps. You may
not be able to switch drives UDMA settings or tinker around like I did.
I do have my drives on my RAID controller, they are just not RAIDed tho.

Since you had some luck when disabling your sound card it sounds like in
your case your problem is more IRQ related? Unlike mine, which was
cabling and drive related. You should def make sure your cables are
ATA100 compat and configured properly tho.

After that. I’d just have to say reorg your system until IRQ9 is not so
put upon. Certain PCI slots are always tied to certain IRQs I think. At
least they are on Abit boards. It may help you reshuffle your PCI cards.
The FAQs for the Abit boards, while Abit specific, also have links, info,
and pointers for IRQ issues and ACPI and other nonsense in general.
Perhaps they could help while you find a FAQ for your particular Asus
board. They are at www.viahardware.com, which redirects now to a new board.

They are at www.viahardware.com, which redirects now to a new
site, but look for the FAQs there, and then pick an Abit board, mine is
the KT7-RAID.

Like I said before, I have a full tower case maxed out with cards and
drives. 5 PCI, 1 AGP, 1 USB header. Plus 2 HDs. One floppy. 5 internal
5 1/4 drives. 1 external SCSI drive. And one external FireWire drive
(new Pioneer DVR-105). No wonder I had a minor problem :slight_smile:

I have alot of IRQ sharing going on, especially because I am reluctant to
give up my legacy COM and LPT IRQs for legacy reasons. I did have to
shuffle my cards around. Certain PCI cards just don’t “share” IRQs as
well as others do. I think Creative sound cards and some network cards
are high on the picky list. As is sharing with an AGP video card perhaps.

And it all comes down to the PCI slots I think, as they can be tied to
certain IRQ possibilities.

Can you give a list of your cards/devices and their IRQ usage? It seems a bit
off that so many are ganged up on IRQ9. I don’t think you have more PCI cards
then I do. Have you tried freeing up IRQs somehow so that IRQ9 is not so full?

Disable legacy SB support on your audio card, or try to
reassign it to share with IRQ7/LPT1. Disable any unused COM or LPT ports.
(new Pioneer DVR-105). No wonder I had a minor problem :slight_smile:

I have alot of IRQ sharing going on, especially because I am reluctant to
give up my legacy COM and LPT IRQs for legacy reasons. I did have to
shuffle my cards around. Certain PCI cards just don’t “share” IRQs as
well as others do. I think Creative sound cards and some network cards
are high on the picky list. As is sharing with an AGP video card perhaps.

And it all comes down to the PCI slots I think, as they can be tied to
certain IRQ possibilities.

Can you give a list of your cards/devices and their IRQ usage? It seems a
bit off that so many are ganged up on IRQ9. I don’t think you have more
PCI cards then I do. Have you tried freeing up IRQs somehow so that IRQ9
is not so full? Disable legacy SB support on your audio card, or try to
reassign it to share with IRQ7/LPT1. Disable any unused COM or LPT ports.
Etc.

Maybe posting a list of your devices by IRQ usage would help me think?
Do you have free slots? Have you tried moving cards around? Do you
really need 2 NICs? Are your NICs fully updated with BIOS and drivers?

Laters.


#17

gator–

how goes it?

now that i have got the program working, i am working on the whole best way to burn and media routine, as i just got my drive a few days before dvd2one was released. i need to order some 4x media. this overprice local 1x crap is killing me…


#18

hey phungus,
it goes, i have been talking myself into a new mobo for the last few days, what other solution could there be…lol. I have resigned myself to the fact i will have to reinstall windows with the ‘standard pc’ option instead of acpi compliant, so i can manually assign irqs. Pain in the *ss. Or I could disable my raid. Neither option is appealing and so …

I’m thinking of the asus a7n8x, a pretty sweet piece of hardware.
Nvidia chipset and Asus reliability, with some need options on board. 6 usb2.0, 2 iie1394, 2 onboard lans, raid, the list goes on.

what dvd burner did you get?

later


#19

Oh, yea local dvd prices are insane, i just ordered 100 dvd-pro dvd-rs for something like 70 bucks, cheap and seem to work on most any machine. But they burn slow. can’t have it all!


#20

The VIA 686B bug happens in combination with the Soundblaster Live series.
At Via the is a little program called: PCI Latency Patch 1.4.
It’s free and will solve the transfer errors over the IDE in combination with a Soundblaster Live.
I had a Soundblaster Live on a Abit KG-7 Raid mobo and always used this patch and had no problems.
Also, I disabled in the Bios some options (com ports, parralell ports etc) to free up the interrups.
Everything is USB over here.
Also, remember do NOT use a IDE-Cable over 60 cm, because you will get serious timing problems !
Futher more, since I have 2 HD on the Raid controller (Raid 0 for Preformance) and the chip is from Hightpoint, I always install the Raid driver from Highpoint.
This one is much fatser then the standart driver from XP.
Tested it with HD-Tach.
Hope this will help,

Lenco