HELP! - CDs not being read Correctly

i dont care …your in dos when it starts up …it never has a chance to go into windows xp …

this is actually how you could fdisk your drive if you didnt want to use the xp pro disk or having problems hell you can format

so when you say XP it dont matter this is done in dos and the links i provide will make the 98 disk for you if you hvae a floppy drive

cheers

then it will actually list all cd drives and there letters

Ok i just got back from this test…this gets better…

XP bootable disk

c:
“Invalid drive specification”
d:
“Invalid drive specification”

reads a: dir np.

95 boot disk… same thing.
Ill have to make a 98disk.

Btw, what about the nfts format. I thought 98/95 only recognized fat?

wohw… i aint goin to fdisk or format. Not yet and not until the tech sees it as it is, the inet connection is about the only thing that is helping me right now.

no i am saying those are dos commands too …all that is on the link I sent ya …

that is why it dont matter what OS your running …dos is dos and always be …

and when you boot up with the floppy link I gave it will list yoru cd burners …roms whatever and then from those letters just put a cd in and type the letter of cd rom …and then once you at the cd rom type DIR
and it should list everything on the cd
and I woudl jsut keep going into more directions with
cd and name of directory

like folder matt

type cd matt just go into them and you know you cdrom is working right

dos is dos

well it wont let you see the ntfs drive but will list your cd roms and that is what you want …and to see the c: drive just type FDISK and next it says something about drive being large …just hit yes who cares lol

and very last option is view partition info …or something like that it does nothing but shows you it is non dos partion or it might even say ntfs or non dos drive

Ok…

98 OEM w/CDrom support boot disk
–> CDR101 Not Ready Reading drive D:
(with original cds)
–> reads fine with burned cds though.

Which is the same as the intital problem. Ok what can we take from here?

flash firmware …or bios or new drive or new mobo …that is order i would go in and always check with the 98 boot

so in dos …did you use another disk other than one with problems …try another disk like game or somthing …then browse it …cause maybe just that cd …if not then order above i would go first …flash firware on drive …new bios …or new drive …

oh one other than i would swap cables to see that too
so you elimate cables like change the one hooked up to hard drive and one that is hooked up to cd rom …

other than that order above but not is is pointing straight to cd rom if it is not due to a cable if works after switching i would try a new cable

but i still would work order above …

but you have proved it you done all I said that is it hardware …I would try reading different disc too try a game disk you burnt or just some cd with data on it like just a normal disk

Ok gio mucho thx again. :bow:

note: yes… i tried more than 1 g.

Ok swap cables… ill check…

(btw One other thing i just remembered… i havnt burned anything until june/july of this year… which is about the same period ive only been using copies and that spike surge… that means i started to use the burner for writing only then… does this matter? Could using burner function do this sort of thing or change a setting of some sort. May be important i wouldnt know, but i thought it worth mentioning).

For the flash bios etc,… ill hold on to my guns, secure perimeter and wait till monday/tuesday for the cavalry :cop: with the supply wagon and let them do their voodoo that they do so well. :bigsmile:

power surges can do aloto of harmful things or spikes it electrical power …can do crazy stuff

Ok ive been checking the Computer manager event/error listings.

These are some of the events that are listed (these particular are repetitive) - the message istelf is a translation but basically thats what it says:

NB: not in precise order!

System Events


Date 22/9/03
Origin: atapi
type: error
ID: 9
detected controller detected in \Device\CdRom0.

Date 22/9/03
Origin: Cdrom
type: error
ID: 11
detected controller error in \Device\CdRom0.

Date 22/9/03
origin: redbook
type: information
ID: 10
This unit does not appear to support digital audio reproduction

Date 22/9/03
origin: Service Control Manager
type: error
ID: 7026
Loading of contoller failed at system start
ASPI32

Date 22/9/03
origin: atapi
type: error
ID: 9
Device, \Device\Ide\IdePort1, did not respond within time limit.

Date 22/9/03
origin: cdrom
type: warning
ID: 51
An error was detected in device, \Device\CdRom0 due to a paging operation.

Ok this is what i have to highlight. Any ideas?
Ill see if i can check in another machine to be sure tomorrow or with another drive.

Btw does anyone know a link where i can update my motherboard bios if necessary. Tried to look but im not sure if its the correct one. Better have it just in case i need it. Thx.

Important update.

I tried another cdrom connected and booted with win98boot w/drive support disk as u told me. It worked in dos!
Booted also from cd, no problems whatsoever.

Slight difference this cdrom was set to slave settings. Didnt bother to change. The cdrw uses master. Does this matter?

And also considering the prior post… Does this mean its the cdrw, gio?

I contacted my tech support and they are late with the order… so im still waiting.

well yes to me it is point back to the cdrw if you put another one in and it works but i would not say that just yet

what i would do it make sure the cdrw is the only thing on secondary channel and make sure it is set as cable select and go into windows xp and see if you see it …then if you do …I would boot to your dos disc and see if it will go threw

also see if you can browse the disc with the change directory command

cd [then the folder name]

then if you cant do that or it will not boot up and let you see that cd or the contents of the cd then yes I would consider it hardware issue and be bad cdrw but that is me …and I am sure other people would intend to agree

but if you can browse and boots up it is something in OS system or it is jumper settings on other devices causing problem

I always use cable select …I will let bios and the operating system figure it out but then again other people like just using master and slave …

but for me cable select works the best in my opinion let other things battle it out

and if you can see it in dos there are more steps to see how to fix it in windows xp

yes but some of those stuff you mention could be it but going step by step always helps … firmware update to drive might be need …but if you have another pc just put it in there real quick and see if it acts like normal …that is quickest way to find out if drive is bad …

well yes to me it is point back to the cdrw if you put another one in and it works but i would not say that just yet

what i would do it make sure the cdrw is the only thing on secondary channel and make sure it is set as cable select and go into windows xp and see if you see it …then if you do …I would boot to your dos disc and see if it will go threw

also see if you can browse the disc with the change directory command

cd [then the folder name]

then if you cant do that or it will not boot up and let you see that cd or the contents of the cd then yes I would consider it hardware issue and be bad cdrw but that is me …and I am sure other people would intend to agree

Sorry this is not very clear to me. Maybe its my fault. Ill try to be clear.

  1. CD-ROM (not CDrw) is the only one in sec channel. I disconnected CDRw to connect CDrom. Only had 1 connected at a particular time.

  2. Cable select? Not sure what you mean. I checked bios setup to see if it could recognize on autodetect settings (F3 & enter). But I usually use it on Auto, including this time aswell, and let it detect any peripheral connected. Is auto=cable select, is this what u mean? If so yes.

  3. I didnt check in windows xp. I deactivated cdrw before i went through this. Didnt try xp except for the boot up with cd. But i undestand where u goin with this… to see if its xp problem? Well it loaded up from cd all the drivers etc.
    [Wait could this be connected to ie?
    I had a fuck up support -pardon my french, but thats what it was- from my isp some time ago and they told me to unistall IE and reinstall… i had a problem right after due to this, but didnt (couldnt) unistall IE, it was security settings btw and i solved it on my own… no cant be… originals would read in dos otherwise… and it doesnt (just copies again). Cant see a direct relation anyway].

  4. I can browse with dir change in DOS. Double checked it again. Originals are read fine, and access fast as it should.

  5. It boots up and reads fine with the CD-Rom replacement. Not with the CD-RW… only reads copies still.

Jumper setting? Was working fine before, all jumpers set are as the vendor had them… i dont see why it wouldnt now.

Ive lost a Cdrom before. Also 2 disk drives… and a monitor and a short circuited power supply. Connection to power spikes or not is not clear. But i wont rule out that it may have been responsible in one circumstance or the other. This on another machines.

Now with the last cdrom trouble it didnt read disks -originals- too well (i didnt have copies at the time so i cant say if it would).

What gets me is… why does it read copies fine and originals not?
Anyone with cd problems has had this sort of thing also? Is this recurring. Ive read problems with copies… not with originals.

So would this be correct? :
-cd driver corruption
-bios (motherboard or/and writer)
-OS, Xp
-CDrw
-other?
any combination of these?

Btw, tried it the other day (Sat)… the phillips setup analyser is failing. Hmm…

Well my tech said, last week, it could be OS more likely or then the writer.
Well the same model writer replacement will make it clear i hope… the order is delayed.

okay sorry here i will tell ya

also I just was reading where you took your cd rom out of can you hook your cdrw on it and see if it runs from there at all ? can you use it in that operating system and boot in dos …if you can you know for sure it is your main system that the drive came out of … your OS .or bios but we know for sure it is in your machine that it came out of … i would do that real quick to find out if you cant do that do following below …

it does read your cd rom you hooked up correct ? in dos and windows xp …you can install stuff …i believe that is what you said

I would then take out the cd rom cause we know that works …so that illiminates the cable being bad or the ide channel

i then would hook up the cdrw you are having problems with …but before you do that there are jumpers on the drive …i would set it to cable select …

then i would make sure it is seen in bios and then boot up to dos with your boot disk … and put a cd in the drive
if you can read the disk and boot up to a disc then your cdrw is good …setting it to autoselect just lets the system figured it out but you can try master and slave just as long as bios see’s it …I would hve that as only drive on the cable on secondary channel

now if you can boot with the cdrw and put cd in dos and browse around it like the cd rom …then your drive is good … .

so now u have to look in operating system to see what is wrong …

i have seen lots of weird stuff with cd roms … and reading originals …but lets see if we can see it this way … any more questions just ask

Ok that makes much more sense now. Thx.

Ide and cable being the problem… eliminated. Gotcha. :wink:

CDrw on another machine… will do tomorrow.
Btw how do i set it to cable?? Is it a third setting in the jumpers?
Master/slave np.

Right now i hope its just the drive.

Ill keep you posted.

yes it should be listed on the drive … look at back where plug is …there are little jumpers …should say CS or if you have the drive you can look it up on internet to see the settings … … also putting in another pc u find out real quick if it is your pc prob …or not … keep us posted …

cheers

Ok i only got tdy the chance to try it on another pc.

Test results as follows:

98boot disk w/cdrom support

SL set

CDRom detected
reads CD copies fine, with dir etc.
with original cds the following occurs:

CDR101: Not ready reading drive

End test

Tried again with another (non problematic) cdrom and everything is fine.

sounds like a bad drive to me …

Yep. Thought it could be more complicated than just that at the start.
Looks like i need a new drive then.

Thx very much for all your help guys and especially giovanni.

Thx again.

no prob >.I go for simple things first … anytime you need help let me know … glad ya know the prob … now …heheh

last thing possible to flash the drive with new firmware with mtkflash ?

if there is firmware available ofcourse.
you could’t try that throw it away is the last thing:cool:

The tech came by tdy and replaced the drive… with a better one. They didnt have the same model in stock so thats why it took so long.

@burnerchief:
Yeah gio directed me to the phillips firmware site.
Btw i asked him about the reflash. And as i thought… i would have lost the manufacturers warranty if i did, anyways thats what he said. Im glad i didnt, (as i mentioned previously) would have voided it and would have to pay for it after… like this, a new drive is for free. :wink:
He said it could be lens problems, and they dont even reflash the drives themselves, they send it directly to the manufacturer for that. Warranty issues.

Problem solved and working.
Anyway thx again for your help.