HELP! - CDs not being read Correctly

Ok i really dont know which part of the forum this should go, so if the moderators move it plz leave me a PM.

Urgent Problem: CD-RW not reading CDs properly.

[CD writer is Phillips 4012P. I do not think at all its hardware nor damaged CDs. Im inclined to software trouble.]

Programs

Windows XP with
Nero and InCD
Daemon
Btw I recently unistalled Windows Media Player 9, and im back to 8. I mention this because it may be connected to formats issues.

Now i cant even re-install CD-RW drivers as the original WindowsXP CD is not being read either. More correctly its being read as an Audio CD (it also shows this in Explorer) and reads as a track .CDA file. [Btw i have not used this CD since it came with the computer 1 year ago. So its not damaged CDs plz take note]

My CD-R and CD-RW copies seem all to work ok, they are read correctly.
But so far all orginal CDs (except 1) do not read correctly at all.
I can even access the original package CDs that came with the computer.

Another issue related is that when i put another cd in, it does not read it at all, but shows as a previous cd i inserted before. Either a data cd (a copy that was read fine) or then as a .CDA file when it clearly is a data CD. Could be mistaken for rereading with the same error or a “cached” previous read error. I dont know?

Btw Audio CDs (orginals) are not being read, nor reproduced either.

I only noticed this today… was working fine before no problems. But as i have not used original CDs in a while i do not know what happened or what caused it, nor the exact moment of this problem appearing (it may have been awhile but i didnt notice until now).

Though the last time i had computer problems was with WMP 9 and i unistalled it back to version 8.

Meanwhile… im looking DESPERATELY for a solution!!!
Someone PLZ help!

If you can help i would be Much appreciated.
Thx in advance.

Is this only audio cd’s or any type of cd?
What happens when you double click on the .CDA files? Do they play?

I have a sneeky feeling this has something to do with the way XP keeps a record of what it should do with different type of CD’s (Open, Play ect…).
Maybe WMP overwrote the setting so it plays audio cd’s, but “forgot” to reset it when it was uninstalled.
The only way I can think of possibily fixing it would be to install some other media player that will play inserted CD’s.

Sorry it’s not much, but it’s all I can think of.

Thx for the reply…

>>Is this only audio cd’s or any type of cd?

Any type of cd, audio and data. And data burned copies work fine. (I dont have audio burned to try though).

>>What happens when you double click on the .CDA files? Do they play?

No. On either data or audio.

>> have a sneeky feeling this has something to do with the way XP keeps a record of what it should do with different type of CD’s (Open, Play ect…).

I was checking tdy stuff that could be related… volume manager? How it handles volume names. Is that it?
I dont know so im trying like mad to get answers and a fix.

>>Maybe WMP overwrote the setting so it plays audio cd’s, >>but “forgot” to reset it when it was uninstalled.

I thought about that to. Thats why i mentioned wmp, seeing other similar problems. Thats was the only 1 of 2 probs i had to date. But as i didnt notice (nor use cds) meanwhile the uninstallation im not sure.

Unistalling wmp9 according to MS troubleshoot is restoring a previous state with the prior player. Which i did.

Btw i tried to unistall wmp8 yesterday, it doesnt remove it completly. And without accessing Windows CD i cant reinstall anything right now.
I contacted microsoft just in case… but they replied they dont support OEM versions.

>>The only way I can think of possibily fixing it would be to install >>some other media player that will play inserted CD’s.

Any recomendations?

>>Sorry it’s not much, but it’s all I can think of.

Anything is good right now… Many Thx. :bow:

sorry but this is my thinking if you dont want to format and reload

why dont you just go into my computer and then tools and options and go to file types and then file types and change them in there or set to default or just changed what program it is open with ??? just my thinking

try using the drive in another system if u can. it’s the best way to see if the drive still works properly.

i’d download / install winamp, and set it as the default audio player, and see if it can access the disc when its placed in the drive.

actually, having re-read your original post, is auto-insert notification on? otherwise, there is an explorer bug that doesnt refresh when a new cd is inserted. mine does the same thing. i can still access the information, though. which sounds a little different than your situation, which leads me back to what i originally recommended.

Well i cant reformat, or reinstall because i cant read the original Windows CD. Anyways that would be last resort,… and would lose to much data. Not an option right now.

However, i just got off the phone with my tech vendor… and he recommended several steps since hes inclined at this time to be an OS problem. Make a safe reboot from CD and reinstall over Xp.
Which im going to do right now.

Then if that doesnt work he said it could be hardware. CDrw OR bios/motherboard corruption (in last case).

And btw i installed winamp yesterday as well as reinstalled wmp9. The problem remained.

So tdy ill try reinstalling with a cdboot, without a format.
Which means ill have to reinstall everything… so may take awhile before i come back here. Anyway ill make sure to post the fix… when it happens. (crossing fingers)

Anyways thx guys.

Nope. Booting from XP original CD didnt work either. Even tried original Win98 CD (never even entered this cd drive until now and havnt used it in over 2 years). And still Doesnt recognize their boot sector. :frowning:

So right now it looks its a hardware problem.
What i really dont understand is why copies (InCD UDF - CDFS format) are read perfectly.

I was readin other stuff and XP cd copy program uses ATAPI format for cd-r cd-rw.

Could be something related to ATAPI?
Operating System? CD-Rw hardware? Or Bios/motherboard issue?

from: http://support.microsoft.com/default.aspx?scid=kb;en-us;321641

Test Disc Read with Copy or Xcopy

Copy and Xcopy are command-line utilities that typically uncover a disc-reading issue. If Copy and Xcopy complete successfully, the issue is unlikely to be a problem with reading the disc. A failure to copy may indicate drive problems or system problems; in that case, do more troubleshooting.

To use Copy and Xcopy to test disc-reading, follow these steps:
Click Start, and then click Run.
In the Open dialog box, type cmd, and then press ENTER.
At the command prompt, type one of the following commands: To copy a folder:
copy <I>discdrive</I>:&lt;I>foldername</I> <I>drive</I>:\psstest /V

To copy the whole disk:
xcopy <I>discdrive</I>:*.* <I>drive</I>:\psstest /V /E

I tried the above. Device not read.
So as it said it may be drive or system problems.

Im still at it. :confused:

eek. your drive can read copies, but not regular cds? perhaps its a reflectivity thing? copies are more reflective. perhaps your lens needs cleaning - or your diode is dying on you. im not an expert at all in this matter, but as it seems to me, anyways, to be more of a hardware issue (selective reading;) ), im gonna move this for you. best of luck on solving it.

Thx ckin2001. And good hint aswell. That Reflectivity issue does make some some sense now, although i didnt know about that until yesterday. Was reading how copies are made and opacity of layers etc…

Btw I cleaned the cdplayer, one of the 1st things i did.
But that might have not been enough as its those cds with a brush on the underside.

Weather has been very hot during the summer and still is… temperature?

Ok since it may be more relevant now, pointing more to hardware issues, and i really made an effort to remember everything that may help…

I now clearly i remember the exact circumstances of a Bios prob i had some time ago… june/july… i had a power outtage, those 1sec lights on lights off thing.

Anyways i was using the computer at the time and when it restarted it couldnt boot, said the BIOS was incorrect.

Now i mentioned this to my tech and in other forums, but didnt mention it here. So its worth it at this time. This goes in the same period of time i havnt used original cds so it may be important.

The issue was the cpu processor speed was set incorrectly. Though i didnt touch it. I reset it to correct values (100mhz) and restarted ok.

The wmp9 issue was slightly after that. So im tracing back my tracks not missing anything.
But still it could have been a windows XP update? Software related again. But as i dont know much what goes into these updates i cant keep track. SP1 and all critical Updates are upto date. Where any updates regarding CD file formats, reading related etc?

But… Could power spikes dammage the cdplayer, lens, or BIOS in such a way that it produces these problems?
(btw i suspect power spikes are responsible for damaging a cd-ROM before, from my previous computer). It read some cds fine, other not…until it got harder to read anything. This was about 2 years ago or more. A new player solved the issue.

My vendor has made arrangements to get me the same model of CDwriter… 2 days and probably i can assert if its the reader or not for sure. Right now i hope its only and just that.

All these symptoms have come up in software (Incd, nero, wmp9, etc) and also hardware related issues. Ive check “everything” from chatrooms, forums, posts, logs, troubleshooters etc.

Anyway im taking issues 1 by 1 eliminating all possibilities i can think of and with your help here aswell. Thx.

Hmmm, power outage…possible.

One way to find out would be to re-flash the writer with the latest bios on the makers website. If the origional was damaged this should fix it.

Ckin2001 just a little incorrection to your hint on reflectivity… im sure you didnt double check :wink:

All links ive checked suggest Commercial CD have higher reflectivity of CR-Rs. Just for the sake or maintaining correct info as much as possible.

Here is the explination for this:

Often, CD readers may have problems reading CD-R media but are fine reading commercially pressed discs. Commercial CDs have physical pits and lands rather than an organic dye storage layer. These result in higher reflectivity than a CD-R and thus are easier to read.

Source: http://www.interstage.dk/Sider/Produkter/Presse/Emner/CDR/CDR_PRE.shtml

So this doesnt seem at all the source of the problem.

Thx anyway.

Petera… thx… problem Phillips doesnt have them easily available. In fact i havnt seen the correct bios for my model. I dont know if i have it in the cd packages that came with the computer… and at this stage even if i did would be useless, because of the problem.

I had in mind motherboard bios.
But ive read that reflashing CD bios solves some problems. Right now i prefer waiting for the new burner than lose warranty on the player (the CDrw is still under warranty, despite the rest is not).
Safer and cheaper right now. :wink:

The simple solution would be reader replacement. Seems to be the most common problem everywhere.

Anyway right now the symptoms seem to be of a “dying” CDrw.
Just by reading copies took me to think it was software. Of course im making a calculated guess with what i have. Which reminds me Bios is also software. yikes!

Maybe a motherboard Bios update would be good, but ill leave for the techs though. If they trash it… its their responsability to replace… if I trash it… it comes out of my pocket.

I dunno but that power spike could have done dammage… just hope it didnt mess up the motherboard/bios. :bow:

(anyone have bios probs before btw?)

ThOyman,

I have updated many bios but they where usually for lock ups … or needed bigger hard drive …

but u have to thnk bios is the whole little brain of computer that tells what to do …and has all intructions …

i dont update that unless board has problems and they are easily done … just like firmware on cd rw …i been reading all about your problem …why not take it to another pc and see if does same thing ? then you know it is your machine and it elimates the drive problem ? I always do that …then if works in buddy u have to take serious look in your machine …

also update firmware on cd rw is always good too …here is your firmware by the way

http://www.p4c.philips.com/mprdata/020903/0209030150_fus.zip that is straight download or if you dont trust me here is the page and you can scroll down to your drive
http://forum.rpc1.org/dl_firmware.php?category=6&manufactor=24

which is for phillips 4012p…

but from what i have read i really do think it is something software but i could be wrong …that is why moving to another pc would give you a direction to go in …

also power outtages and power spikes can ruin alot of computer stuff …at the place I work at we get alot of people that have trouble after storms … and some people that just have new houses built and wiring was done shotty or wrong …

just to let ya know

and yes I am actually really a technician, network engineer , and i do software and hardware

cheers

hi

if you can’t boot from the org winxp cd it should be a hardware or bios problem what kind of error do you get when you boot from cd?

Thx for all your help giovanni. And many thx to that link.

Yeah i agree, its more likely to be those 2 (CD or bios/motherboard). Narrowing it down…
On the safe side Ill leave bios updates for last.

And if the writer needs a reflash id better let the tech do it… the cd is still under warranty and i dont want to void it unecessarily.
The computer and writer (still is the same that came with it) have different warranty periods.

…but from what i have read i really do think it is something software…

Oh yes? geez im really messed up now… lol.
I know u aint sure but plz tell me why then and what, i may have missed something.

to burnercheif: Device not read, Boot sector not recognized or whatever is the default message of any unbootable cd.
And no i dont have a burned bootable copy.

Well that spike was the only thing Major that i had up to date that i can think of being directly related.
Ive had outtages before, but i normally disconnect until the power comes back on. Oh and i have a spike protector (or whatever u call it) but that is not fullproof i gather. I dont even know if the think works or just a gimmick, lol.

This one was a 1sec flick off, flick on, that rebooted my machine + changed the settings. I had the computer on, house lights on and it also flickered everywhere in the house, so it wasnt anything specific just to the computer power supply system.

The cause would be easier if i knew the exact moment of this problem settling in…
just remembered sometime later when i was looking like mad for a possible cause.
If it wasnt for the boot lock i wouldnt have taken so much notice.
Ive had short outtages while the puter was on, but on reboots everything was ok, never locked up on restart before. Normally they are long enough to disconnect, or boot up with power on button. This particular one wasnt.

[All others issues i cant find a direct relation clearly since it was working fine before. I had nero, incd, daemon all installed prior.
Unless it was XP update induced or the wmp9 issue.]

Im not sure if it changed any other settings… however, (i did not mention yet) the Bios Load and Setup Load settings are exactly the same.
Now i recall when i got the computer 1year ago, i checked those settings to know what i had… and loaded up both… and they where different. They normally always are anyway.

Well when the cd arrives (with the tech).:bigsmile:, next week i hope, we can be sure.


Ah… almost forgot to mention.
I used ol’ dos commands (as suggested by MS) with “xcopy” and “copy”. It failed to read and copy FROM the CD.

If it went ok it the CDrw would not be the problem as the troubleshooter suggests. (if anyone wants the link ill post it).
As it failed, MS suggests more troubleshooting to determine if it is the CDplayer.

Other than that not much progress.

sorry my two cents …

i didnt think it was hardware but hey i dont know your exact system setup …flashing bios or cdrw firmware is not bad at all reallly easy now a days …

just cause the cd rom is playing some discs just pulling up wrong program or none at all

that is why I would put it in another machine and see how it acts … but hey that is me …

and i have been wrong at times but yes i do agree flashing bios and updating firmware always helps …can never hurt …

i hope it is just a drive for you …do u have bootable disk like windows 98 boot disk or would ya like to know how to make bootable disk

also when i have weird problems i always go in bios and set fail safe mode … and then just change boot order from floppy …then cd rom …then hard drive …

that wya you can use a bootable floppy to find out what it wrong and then bootable cd …

hey just my thinking and how I do things

yes surge protections dont do the job sometimes …I learn that hte hard way …now i have a backup battery and surger protector hehhehe …hey it works …power goes out my pc can stay on for thirty mins but I usually shut it down …

just my thinking …but hey if u need help my signature tells all …

i hope it is just a drive for you … if you need help wiht cd firmware or anything just let us here know and i am sure oen of us will help

but if you take what you think the problem is out of the variable …then you narrow down problems … i go for quick solutions … and simple ones first …

Plz dont apologize giovanni, you are trying to help me and i really appreciate that!
I just took it, and probably complicating things, from all the things ive read. Within advestity or unkowns simplicity is always the better solution, i agree. :wink:

My hardware setup is as follows:

Easy PC, ECS P4 S5A
AMI BIOS - American Megatrends
Pentium 4
2Ghz
256 RAM

NVIDIA Geforce2 Mx 100/200, 64RAM

Ok i mentioned in my previous post that i didnt notice anything else changing. Not totaly correct there. Sorry Small detail: the time clock had different settings also.
I only was aware of this, when i noticed this problem now and went to bios to check. If it changed after that spike i didnt notice it, just changed the CPU speed to correct set. So i may have left it since the spike, i dont know, didnt check the time settings then.

I was reading some bios stuff the other day and considering the loadups probably it is best to do this also. I will ask the tech when he comes over to update the Bios. Never did it so im not confident with the procedure, risk is to great to do it myself right now. Caution is best here. Later yes and with backups before (tech & data) with full support.
Quite frankly i dont want to risk messing up and losing inet connection right now also. So for me its safer to wait a couple of days than fiddle around. Ive tried to minimize any changes and set in other issues. If things went wrong, would ruin my weekend completly. At least i can still use it, copies and inet. Im patient so np.

But im still taking notes here with all your help. :slight_smile:

Ill try a boot with a win98 disk. Ill make one for XP aswell and try that 2.
Ill see if i can test the drive in another machine.
The drive itself is the least of my worries, i always have a spare CD-ROM, can buy one easy 2, and ill have a replacement soon by the vendors anyway (just in case). The tech seemed pretty good, and planned ahead. He also advised the same.
Problem is i couldnt get in touch friday. So ill have to wait to monday. Anyways this is all usefull so i can update him on everything u commented.

Information beats Chaos. :wink:

Ill post any updates on the tests.

Thx to all.

no prob. …sorry I have to take technicial side in me out first …then if dont work I take the fred flinstone approach

beat it with big stick lol

kidding

you should only make boot disk for 98 …if you dont have a windows 98 boot i suggest going to

http://www.bootdisk.com/bootdisk.htm

get bootdisk windows 98 oem …

oh when you download that it makes an exe. just put it floppy disk in the floppy drive and it will over right floppy and just boot with it in the drive

that should put all your cdrom drives there

then just put cd in each cd rom drive and just type f:
[f is drive name …could be anything til it is read in all your drives]
then type dir and if it list what is on cd rom I would be inclined to reload pc cause if works in dos should work in windows
cheers

Bloody great…

Just tried to make a bootable diskette with winXP
(giovanni i have XP)…

“Unexpected E/S Error”

Wont format with Dos Boot selected. It is formatting without MSBoot selection however.
Next i tried making a reformat with boot sector. And its working.
Ok gio… but it wont have cd devices though. Im ignorant on how XP works this btw so maybe im wrong.

Anyways i was more used to troubleshooting 95/98, Ill have to look for my 98bootdisk… long time no use. Its here somewhere. lol.

Oh my… i remember when Dos 3 to 6 was so much simple. Wheres that stick. :bigsmile: