Help. CDRW is mode PIO4 now!

vbimport

#1

Hi,

I just reinstalled WinXP Pro got the latest 4in1, bios for mobo, CDRW, etc and got everything up and running. I just noticed that my BIOS boot page reports my Liteon 12102b CDRW as mode PIO4.

I have an Epox 8KHA+ and yes, UDMA is checked.

HELP!!!


#2

just uninstall the ide channel…primary or secondary…it is on and reboot and let WinXP reinstall it…happened with my DVD and this worked like a charm


#3

Check in your BIOS, some newer epox bios have the ability to enable or disable udma for cd-rw and it is disabled by default.

I think it is under advanced settings or maybe chipset features, it is not in the same place as the rest of the dma settings for the controller.

edit

since it is reported in the bios post it is not likely a windows problem.


#4
  1. UDMA is enabled in the BIOS.
  2. Agreed, sounds like it is NOT a windows problems as it is reported in the BIOS.

#5

I had this same issuse with one of my lite-on drives. After flashing the drive it reinstall the drive and problem was solved. so I would have to say to try unlistalling the IDE channel and see if that will help.


#6

Hi,

I have tried the following:

  1. Made sure that UDMA for CDRoms was enabled in the BIOS.

  2. Uninstalled the secondary IDE controlled in Device Manager. When XP rebooted, it said new hardware found, but the Liteon 12102b was still MW DMA Mode 2 (and still detected in BIOS as PIO Mode 4).

The other (master) device on the secondary channel is Ultra DMA 33.

Could it be because I flashed the BIOS on my Epox 8KHA+ motherboard (2529)?


#7

Yeah im having the same problem only weirder…i have two HDs on first IDE channel, a dvd and a liteon 40125S on the other…in bios says all have dma enabled…but when i use neroinfotool etc…they say that both slaves arent DMA enabled…being one of my HD and the burner…go figure!?!


#8

Your IDE cables are probably faulty, try new ones.


#9

If the slaves are detected as PIO Mode 4 and the masters are detected as UDMA, I doubt the cables are at fault. This is my case too.

I am almost convinced it is because of the mobo bios update I did. Bloody Epox 8KHA+! Is there a work-around?


#10

I’m 99% sure that the LTR-12102B only supports PIO mode 4. (And then should show PIO mode 4 in BIOS).

In windows it should say running in Multiword DMA mode 2 when DMA is enabled.

So everything seems to be right…


#11

I had some hassle with this issue too and I was wondering what exactly this Multiword-DMA-Mode-2 means?

I mean there were PIO mode 1-4
the there was udma 33,66,10,133

and where does this Multiword-DMA-Mode-2 fit in?

I have an ltd 163 d and a ltr 32123S connected to different ide channels and for both dma is enabled in the bios, for both dma is enabled under winxp and the status is: running in Multiword-DMA-Mode-2 …

if this would mean that "Multiword-DMA-Mode-2 " is equivalent to udma33 which both of my drives should be able to provide all would be fine…


#12

Hmm, difficult to explain, English is not my native language either.

PIO-Mode 4 = 16,6MB/s This is the max speed for PIO 4 and is enough for CD-Drives, although some supports UDMA33 and better.

Still DMA (which have “nothing” to do with UDMA 33/66/100/133) must be enabled through the operating sytem. If DMA is not enabled you need a helluva fast CPU to be able to deliver data to the drive fast enough since all have to be processed by the CPU. By enabling DMA (Direct Memorey Access) you give the writer a direct connection to the Memory and not all data needs to be processed by the CPU.

Windows calls the DMA mode for “Multiword DMA mode 2” for PIO 4 Devices(16,6Mb/s).


#13

For repeated DMA errors.
Windows XP will turn off DMA mode for a device after encountering certain errors during data transfer operations. If more that six DMA transfer timeouts occur, Windows will turn off DMA and use only PIO mode on that device.
In this case, the user cannot turn on DMA for this device. The only option for the user who wants to enable DMA mode is to uninstall and reinstall the device.
Windows XP downgrades the Ultra DMA transfer mode after receiving more than six CRC errors. Whenever possible, the operating system will step down one UDMA mode at a time (from UDMA mode 4 to UDMA mode 3, and so on).
If the mini-IDE driver for the device does not support stepping down transfer modes, or if the device is running UDMA mode 0, Windows XP will step down to PIO mode after encountering six or more CRC errors. In this case, a system reboot should restore the original DMA mode settings.
All CRC and timeout errors are logged in the system event log. These types of errors could be caused by improper mounting or improper cabling (for example, 40-pin instead of 80-pin cable). Or such errors could indicate imminent hardware failure, for example, in a hard drive or chipset.

http://www.microsoft.com/hwdev/tech/storage/IDE-DMA.asp

When XP turns it off for me copying on the fly at 24X goes from using 1% CPU cycles to 100% CPU cycles and the buffer under run goes in to over drive.


#14

Had this problem over the weekend this fixed it.

"Originally posted in the M$ Newsgroups

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Contro
l\Class{4D36E96A-E325-11CE-BFC1-08002BE10318}\000x

Last four digits are likely 0001, 0002. Under those keys you will find MasterIdDataChecksum, SlaveIdDataChecksum. Delete the value corresponding to your drive. It will make the OS to redetect the device DMA capabilities after reboot."

Link in XP-erience.org forum where I found this bit of info.