HELP! Cant read DVDs, only CD's

Yep, title pretty much explains it and I have enclosed a picture for everyones needs, some feedback would be very very very much appreciated. Cant read DVD-ROMS such as Bioshock, Med. War II, Supreme Commander…Used to be able to, think DAEMON Tools screwed something up big, but uninstalling has no effect on the problem. Drive is brand-new as well.

anyone? think it might be a problem with the driver details, only have the CDrom.sys file in driver details…but uninstalling/reinstall has no effect…anyone with a fix?

Picture looks fine.

I know the picture looks fine, thats why Im confused as to why it wont read DVD’s… pops them up in that format that vista cant handle (cant think of it of the top of my head, but yes they are legit store-bought disks)

Uninstall the ide channels in devicemanager, also search for ide updated drivers.

did both problem still remains

Which chipset comes on your mobo and what ide drivers are installed?

k here is the information, sorry about the picture size

Try to find updated nForce drivers.

Try the drive in another system. It may be a faulty PUH/laser. :frowning:

updated drivers and of course have tried the drive in another system works, like i said brand new drive out of the box…think it might be a problem with whats installed under driver-details (see screenshot) right now getting blue-screen memory dumps on Vista 32bit with UDFS File System errors. For some reason cant get any DVD to read in this format and it currently only reads in IVIUDFS which is a format that I hear Vista cannot handle, thanks for the support thus far guys. Hope to hear back soon
~Gigot

anyone?

Have you tried to plug the drive into another slot on your mother board?Just a thought.

i have to keep mine set to cable select and connected as slave. if i jumper as master or connect cable select as master then i can not read dvds, only audio cds. i know this sounds strange but have tried and tried and the only solution i have come up with is to keep it hooked up as cable select and slave. now im not saying its a drive problem but it is the only solution i have. it looks like its your only optical drive so it might not be an option for you.

looking at your screen shots whats all the empty drive pics under (S)ata/atapi drives. also why are there three nvidia force serial ata controller installed. i would uninstall the your drive from device manager, uninstall your ide controlls. power down and unplug your drive. boot backup, then power down again and reconnect making sure cables are properly connected, then reboot and let windows install default window drivers.

troy


ya, it reinstalls devices as im uninstalling them lol :frowning: stupid vista. I ordered the x64 bit version and its coming soon, just gonna back up my stuff via network and clean install Windows 64 bit, hopefully that fixes this little annoyance :frowning: