Help, can't encode WMV

I just encoded some WMV videos using TMPGEnc last night, but when I try to encode some more today, the WMV codec is missing. What’s wrong? What do I need to install to get that back? Thanks.

Here’s a screenshot.

All I can think of offhand would be to try uninstalling the program and the codecs, running CCleaner and EasyCleaner or even NortonWinDoctor to clean out the registry, then rebooting and reinstalling to a different folder and see if it all resets itself.

I don’t know TMPEnc very well. Can you encode with Windows Movie Maker?

I haven’t tried Windows Movie Maker, but I tried Sony Vegas, it also says the WMV template is missing. So I can’t encode with Vegas either.

Well, since Windows Movie Maker is free and built into Windows, I thought it might be worth a try.

You could try re-downloading and re-installing the Windows Media Encoder direct from the Microsoft web site.

http://www.microsoft.com/windows/windowsmedia/forpros/encoder/default.mspx

Windows Media Encoder won’t install, I think I’m going to do a system restore, if that doesn’t work, I’m going to re-install Windows. Since I just got it running, there’s not much data to lose if I reformat.

Sometimes a clean install is the best way.

BTW, sometimes if you do error checking, delete all the temp files and folders and what not and then reboot and defrag, you can then use some registry cleaning tools and the like and get installs working again. Not always, but sometimes.

Sorry for the hassle. Hope it works out ok.

Which registry cleaner is the best? Thanks for the replies.

Two are free and good:

ccleaner: http://www.ccleaner.com/
easycleaner: http://personal.inet.fi/business/toniarts/ecleane.htm

Norton WinDoctor is part of Norton Utilities and costs money.

Those two should help though, I believe.

some format can’t be used or the effect isnot well.you can change it by some software,such as xilisoft and others.