Help! Bad Flash, Dead Drive

Can I recover from this? I tried to firmware flash my fairly new true 832S from the factory provided VSO1 to VSOA. I downloaded VSOA from LiteOn’s site, got out of all programs and then ran VSOA.exe. The screen came up to choose my drive and I chose it, then chose install and the installation started and the progress bar moved across the screen and got to 100%. The screen said “programming…” and the bar across the bottom of the screen stayed at the right at 100%. I waited over 15 minutes for the greyed out “Close” button to be available to click or something else to happen on the screen, but nothing happened. This seemed too long for a proper firmware flash on my P4 system. Nothing I’d seen in the forums talked about a firmware flash taking an excessively long time. After the 15 minutes or so, nothing seemed to be happening, so I thought maybe the installing/programming was really done and it was a quirk in the programming that the “Close” button wouldn’t become ungreyed for me to click.

Since there was nothing on the flasher screen to allow me to close the program, I right clicked the program on the task bar and closed the program and rebooted. Well, during bootup the 832S isn’t recognized anymore and it’s taking WinXP Pro over 10 minutes to boot up and when it finally boots up it doesn’t see the 832S anymore. Also, the drive doesn’t respond to the drive eject button anymore.

So the drive seems dead. Can anyone help me revive it? Thanks in advance for any help!

rrk28

Try to flash it with Mtkflash. Have a look here: http://dhc014.rpc1.org/howto.htm#mtkflash

You should to be able to use it with those instructions.
Hope you can recover your drive.

I’ve done some searching around and couldn’t tell if the 832S works with Mktflash. Does anyone know? BTW, my dead drive is the master on the secondary IDE channel with a TEAC CDRW as the slave. Thanks.

rrk28

:cool:

Yeah, your 832 is suported by mtkflash…and many more.

You got a link above. Look at bottom of that page for the commands.
It can look something like this: mtkflash w 3 VS08.bin

:stuck_out_tongue:

I had a problem with my Sony drive doing that. The flash failed and rendered the drive dead. Then when you would turn on the pc it would freeze at the POST screen so that I couldn’t even boot into DOS to try again.

What I ended up having to do was to plug in another drive into the IDE position that the SONY was plugged into. This way it would boot into DOS. Then I unpluged that drive (Yes, while it was still on) and plugged in the Sony again. Then I was able to flash the drive with the correct firmware using MTKFlash. Seeing that the Sony drive is a rebadged Liteon you should be able to do this as well. Good luck.

Thank you all. Glad that the 832S is supported. Was I wrong to believe that the firmware programming/flashing should be finished or something was wrong after 15 minutes? Should normally the flashing take that long?

rrk28

No, it should only take less than a minute.

Thanks, then probably there was something going wrong with the attempted flash. It seemed fishy that it was taking so long. But obviously closing out the program and rebooting wasn’t the right thing for me to do!

rrk28

it seems to have gotten stuck right at the last stage of writing. Oh well, it happens. Try doing what I suggested and use MTK 8.01 in DOS.

Thanks for the advice. Just found out I will need to watch my daughter barrel race tonight after work so probably won’t be able to try your suggestions tonight, but I will try them at my first opportunity and am eager to do so. Thanks again for the assistance and let me know if you think of anything else to try! I’ll post my results after trying the suggestions.

rrk28

A hope you made a typo… there is to my knowledge no such mtkflash version.

And I have to correct myself on above post mtkflash w 3 VS08.bin is not right,
It should look like: mtkflash 3 w /m VS08.bin (drive location before action command)

BTW, I use earlier versions, before 1.80 :cool:

Yes, I did indeed make a type. Sorry about that. Dislexia of the fingers. version 1.80 is the one you should get.

Just got back to desk and saw additional posts. Thanks for the suggestion on the command to use with mtkflash. So it should be version 1.80 that all think I should use with the 832S?

rrk28

Yup. And if you can’t get past the POST screen then try my suggestion above about swapping out drives to get past POST and then plugging the dead drive back in while it’s at the DOS prompt.

I had a Sony DVD-ROM that I had accidentally flashed with incorrect CD-RW firmware and would do the “hanging thing” at the POST screen. The LED wouldn’t even flash so it looked like the drive didn’t even have power. I had actually thrown the drive in the recycle bin and then stumbled onto a post at some site that told me what to do.

I can’t find the post that gave straight forward directions but here is what I did:

  • Create a real DOS boot disk with mtkflash and the correct .bin file.
  • Reboot the PC and, at the POST screen, enter the BIOS setup.
  • Set all ATA drives to NONE (yes NONE, not Auto or CD-ROM).
  • Set first boot device to Floppy Drive.
  • Save changes, exit and shutdown PC before it reboots.
  • Disconnect all drives from all controllers except the floppy drive.
  • Set the master/slave/cs jumper to master on the dead DVD drive.
  • Connect the dead DVD drive to the primary master cable and also give it a power connector.
  • Boot the PC to the floppy made in step 1 (yes, no drives will be detected).
  • Run mtkflash and tell it to flash the primary master.

Even though the drive didn’t show up on the POST screen, Mtkflash continued without complaints and successfully flashed the device. After that I went back into the BIOS setup, set all drives back to Auto, reconnected all my devices and everything was detected and ran as normal.

Saved me from having to buy a new drive!

Thanks once more for the great tips. I am printing them out so to follow them correctly. Do you all think I should try to contact LiteOn first to notify them of my bad flash experience and see if they have a recommendation or offer to repair/replace the drive before trying what you’re suggesting? I had contacted LiteOn a few days ago to tell them that my drive for some reason would not read or write +R media (Nero’s InfoTool only showed -R read and write features checked, even with my ASPI checking out fine). They came back and suggested I update my VSO1 firmware to VSOA and run SmartBurn and send the results to them. I never got around to the SmartBurn thing because of my failed attempt to update my firmware from VSO1 to VSOA.

sounds like you might just have a bad drive to begin with. it might just be a good idea to tell them that it wouldn’t accept the flash and get them to replace it.

Thanks, I was wondering if anyone has had much success dealing with LiteOn’s tech support for issues similar to this.

rrk28

I don´t think many of us here really care that much about lite-on “support”… :stuck_out_tongue:
We have c0deguys, good moderators and a lot of skilled members!

BTW, when are you gona flash your drive? :cool:

No question about the superior optical drive knowledge and skills that abound in this forum. I’ve greatly appreciated the assistance all have provided. I guess my question now is, if I use mtkflash and the methods folks have suggested in this thread to try to revive my dead 832S and it doesn’t work for some reason, if I return the drive to LiteOn for repair/replacement, will LiteOn be able to detect that I tried mtkflash and perhaps not be willing to honor the warranty?

rrk28