Help! Audio is Choppy Playing DVD's

vbimport

#1

Hello,

I was wondering if someone could help me fix my audio problem. :bow:

I just bought this computer about a month ago.

When I play a DVD the Audio is Choppy and the Video seems slower.

First I have a Dell Dimension 4700
I installed Sonic DVD Decoder

I have: Optiarc DVD RW AD-7170A
Lite-on CD-Rom LRN-4893

Under my Devices, my EDE ATA/ATAPI controllers, the first primary is set to DMA if available, Ultra Mode 5, auto detection.

The second Primary also set to DMA if available, Ultra Mode 2.

I don’t know what else I can do to correct this audio problem. My CD’s play and sound perfect, it is just playing DVD’s that sound very choppy and the visual looks like it may be running a bit slow.

My computer info is: Microsoft Windows XP Home Edition, Service Pack 2, Pentium® 4 CPU 2.80 Ghz, 2.79 Ghz 504 Ram.

I have Windows Media Player 11

I have Interactual Player, the DVD sound problem occurs with both.

I have troubleshot pretty much everything and nothing comes up. I have tried to update my drivers but it says there is none better than what I have, or something like that. I have also tried to adjust my volumes, but nothing there. HELP! Can somebody help me correct this problem? :confused:

Thank you for any help,

GoldyCat


#2

PRI MAS is the hdd, not a optical drive.

So make sure both optical drives are set to DMA, the Liteon to DMA2, the Optiarc to UDMA4!

If not, replace the ide cable.


#3

Thanks so much for your reply chef.

Below is what it is currently set to, how can I change the settings per your advice? There isn’t any options to change it to what you have advised.

There are two Primary IDE Channels, no secondary.

What I see in my IDE is 2 Primary IDE Channels, no secondary, the first one Device 0-is set to: Device Type (shaded), Transfer mode - DMA if Available, and current transfer mode - Ultra DMA Mode 5.

Device 1 - device type - auto detection, transfer mode - DMA if available, current transfer mode - not applicable.

The IDE Primary below the first IDE Primary is set to: Device 0 - Device type (shaded), transfer mode - DMA If available, current transfer mode - Ultra DMA mode 2

Device 1 (right below the Device 0) - is set to - Device type shaded, Transfer mode DMA if available, Current Transfer Mode - PIO mode (IS THIS THE PROBLEM?) and if so how do I change it? There are no options in the box to change the PIO to DMA.

Thank you so much for your help :bow:


#4

Maybe uninstall them into devicemanager, then restart and check again.


#5

Thank you chef for your reply,

Uninstalling both primaries in IDE ATA/ATAPI Controller and reinstalling them did not change the PIO to DMA it remains the same.

I did the action below and this did not help either,

I have tried deleteing the Master IDDATACHECKSUM and the Slave in the Regedit, but in 000 there was only the Master and not a SLAVE IDDATACHECKSUM, I deleted the Master and slave, in 0001, they were both there, there is no 0002 there. There is no Master or Slave or in 0003 or 0004 when I reboot then check them, what I have deleted comes back.

I have changed my DMA to PIO, then rebooted, then changed them back to DMA if available, but it still is set to PIO mode in the current transfer mode.

Any other ideas that you think would work? I really appreciate it.

GC


#6

Check the ide settings in the BIOS, maybe something there is nwrong.