Helllppppp ! invalid partition table entry

vbimport

#1

hi,

i have 2 harddisk drivers. 1st one is loaded win98se. 2nd one has win2000 pro

1st disk - primary master
2nd disk - primary slave.

here is what i did.

i physically diconnected the 1 st win98se hdd so only the 2nd primary slave was active.

then i installed http://btmgr.sourceforge.net/

i restarted and it worked fine. then i reconnected the 1st disk with win98se. and restarted the system and it booted into win98se - perfect. i was happy.

i changed between win98se and win 2000 by changing the first boot device in BIOS.

after few days of using i changed the first boot device in BIOS to the win2000 hdd (primary slave)

in the menu both hdd were visible. so by mistake i select the win98 hdd (primary master) !!!

argggggggggggggggggggg. it screwed my 1 hdd partition table !!!

when i rebooted with 1st hdd in BIOS. after the POST the screen stays blank. and after 30 seconds i get a error “Invalid partition table entry detected !!!1111111”

the disk has around 120 gb of data !!!

so tried to do fdisk /mbr still no hope.

when i booted into 2nd disk (by changing in BIOS) i can atleast see all my drives in both hdd and data is safe.

i tried fdisk and it shows allthe partitions but the description enrty (which should have been fat32) is “unkown”

somehow this bloody software http://btmgr.sourceforge.net/ has fuked my partition table entries

how do i recover them !!

ps : all my system are on fat32 (none are ntfs)

i am too scared to do anything :frowning: i have shutdown the pc and writing this from other machine

:bow: :bow:


#2

k problem solved :bigsmile:


#3

How did you solve it?