HD's not recognised after reboot on PromiseUltra133TX2

Trying to re-install win98SE from scratch on 80GB hd on PromiseUltra133TX2 controller on Asus Cusl2 mobo.
Whenever a re-boot occurs, the Promise controller doesn’t recognise the HDD anymore and so the necesary
bios drivers are not loaded.
When i do a “cold” boot, the Promise 133TX2 bios does recognises HDD correctly and W98 setup allows me to start.
Setup verifies the hd and copies files to the newly formated C:-partition (6GB). But, as soon as setup restarts,
the Promise controller doesn’t find any harddrives attached and setup cannot continue.
At that point I am forced to do a cold-boot and the hd is recognised again and (usually) setup continues where it left off.
After several tries and many hard/cold re-boots i finaly manage to get win98 installed, but then,
as soon as i install either the Asus chipset drivers or the Promise TX2controller drivers,
Win98 starts freezing over and over and after a few cold-reboots it’s as if the boot-sector gets messed up
and i have to start everything all over again.

Specs:
on Asus Cusl2
IDE 0 (M): Nec1300A-DVD-/+RW
IDE 0 (S): Plexwriter 161040
IDE 1 (M): LiteOn DVD-rom
IDE 1 (S): LiteOn CDRW 321240

on Promise Ultra 133 TX2 controller
channel 1 (M): ( - disconnected for now - 40GB HDD 7200 ata100 - with win2k intalled for duall boot later-on)
channel 1 (S): ( - disconnected for now - 30GB HDD 7200 ata100)
channel 2 (M): 80GB HDD 7200 ata100
channel 2 (S): ( - disconnected for now - 120GB HDD 7200 ata133)

P III 733 (5.5x133mhz not overclocked -for the time beeing)
128+256 SDRam 133mhz
Ati Radeon 7200 AIW (AGP)
SBlive 1024 player
Pinnacle PCTV rage

Any suggestions?
Or am i forced to do a compleet install of win98 first using one of the IDE channels on Asus mobo,
and afterwards move the hd to the Promise controller? (which has worked like that before…)

I dicided to tackle the problem the other way round:
Setup:
on Asus Cusl2 motherboard (Intel 815E chipset)
IDE 0 (M): Nec1300A-DVD-/+RW
IDE 0 (S): Plexwriter 161040
IDE 1 (M): 40GB HDD 7200 ata100 - with win2k intalled
IDE 1 (S): 30GB HDD 7200 ata100
on Promise Ultra 133 TX2 controller
-nothing installed-

Result: Everyting works perfect. W2kPro (SP4) takes about 1’20min to fully load (…nice and fast)

Now, when i move the HD’s with Win2k to the Promise UltraATA133tx2 controller, Win2k takes AGES to load (5’20min to be exact).
So-far I’ve tried 2 different driver versions 2.0.0.39 and 2.0.0.42.
I also swapped the controller to another PCI-slot and tried it on PCI1, giving it “high priority” in bios. Nothing makes any difference.
It acts as if it is working in Pio-mode.
It does however (upon a reboot) keep recognising HD’s correctly.

Can anyone help…pls…?

Your problem is between the Promise card and the drives. Drivers will have no impact. Try re-jumpering the drives, don’t use cable select. You don’t mention what kind of drives they are, but some cards have difficulty with specific HD’s, so check with Promise support on that. I’m sure you’ll find several KB articles on similar issues.
Also try with each drive connected separately and alone, and run full HD diagnostics on each drive while connected that way. (download from the drive maker) Sometimes one bad HD will effect the recognition of all drives. IDE cable and jumpering are the 2 most likely causes of your problem. Also double check the power connections.

Also, check your BIOS for any settings regarding boot sequence and priority, setting it to SCSI might be the ticket, but it sounds more like a problem with the card and HD’s.

[off-topic]
Why on earth would you want to load Win98 on a fresh setup? :stuck_out_tongue:
[/off-topic]

@ AlfaStation, from the problem you are having, it sounds like your drives are incompatible, I haven’t come a cross the exact same problem you are having my self , but I have heard some makes of HD’s don’t like running on Raid or as Slave with some other makes of drives, they are incompatible. Normally to have a trouble free Raid set up running at it’s best performance it’s always best to have the same brand and size HD’s and if possible new ones, if you are using 2 different size HD’s, the larger HD will only be recognized and used as the same size as the smaller one and sometimes it can cause problems . It looks like you are trying to run 4 different size HD’s on Raid, I think your Raid controller might be confused :confused: on what’s going on. If you don’t want to buy a new set of HD’s try swapping them around till you find a combination that will work

check promises web site. They might have a firmware update for your card (i know they have had them for other versions of their controller cards)

That might fix your problem.

Have to make something clear:

The Promise Ultra133TX2 is NOT a raid controller, but an ATA133 controller (so i could have a total 4+4 ide/ata-devices).

I used to have my optical drives on it, but especially the Plextor-drive didn’t like it (he seems rather picky on where he’s attached to).
At the moment i’m trying out different combinations, using Speed32 to test HDD-reading speeds and nero info-tool for the optical drives. I’ll post findings later. (note: Nero info crashes if i have optical drives attached to the Promise controller!)

@LordOberon
I’ll look into a firmware update.

@Rdgrimes
All devices are either Master or Slave (see “specs” above) and i’m using 40/80 ide-cables (except for the 2 liteOn’s, they’re on a 40/40 cable) .

off-topic]
Been using duall-boot W98se / W2kPro for years now without problems.
Both installed completely seperate on different HD’s & using boot-settings in Bios to choose which to boot. W2k i use for the “serious” work: DVD’s, photo&video-editing, music, while W98 i use for the “fun”-stuff: games, p2p-applications, e-mail, Msn, etc… and also for capturing analogue video (W98 is less “heavy” OS). Was going to replace W98 for XP 'till i found certain (older) games won’t run on XP. Also, W98 is easier to “tweak” and doesn’t do things behind your back like XP does.
[/off-topic]

So-far the set-up below works best, but people on other forums advise to put all ATAPI (optical-drives) on the motherboard.

On Asus CusL2 (Latest Bios-chipset 815E-PIII 733)
IDE0 (Master) Barracuda III ST340824A - 40GB (W2kPro/SP4)
IDE0 (Slave) Barracuda IV ST380021A - 80GB (W98SE)
IDE1 (Master) NEC ND1300A - DVDRW
IDE1 (Slave) Plextor PX-W1610A - CDRW

On Promise Ultra/ATA133 TX2 (latest Bios & drivers)
1 (Master) IBM Deskstar DTLA307030 - 30GB (only data)
1 (Slave) Maxtor 133 DiamondmaxPlus9 - 120GB (only data)
2 (Master) LiteOn DVD LTD163 - DVDrom
2 (Slave) LiteOn LTR-32123S - CDRW

I tried several different setup-combinations, but the above seems to be the only more or less “stable” setup so i could install and properly boot both OS’s (I choose which of them i boot directly from bios, so as to keep W98 & W2k completely seperate).
Other Problems I encountered:

  • Booting W2k from the Promise controller takes +/-10min. for windows to load and 3min to shut down (+/-1’30min to load on IDE)
  • When the bootable HD-drives are on the Promise controller they make a strange “TIC-TIC…TIC-TIC” noise.
  • Similarly, the Plextor “dislikes” beeing on the Promise controller. (gave me all sorts of “strange” problems, so moved it to IDE)
  • And Nero Info Tool crashes if an optical/ATAPI drive is connected to the controller.

Any ideas? Suggestions? Tests i can do to see if everything runs ok?
I allready tested with DiskSpeed32 (for HDD read), DVDDecryptor (for DVD-rip speeds) and CDEX (for DAE-speeds). Results seem normal.

Oh, and did i mention my HDD’s get real hot: +/- 43°C? Or is that a normal temp.?

Greetz, -Alfa-

All optical drives on the Promise controller are locked in PIO mode, in spite of the fact that the controller will show then in UDMA mode.

Move HD’s to the controller and run the opticals on the motherboard.

W2k does boot and load, but takes 4 to 5 times longer when its on the Promise controller.
Explorer & stuff also open much slower (drivers for tx2 are installed of course, tried v2.00.039 and v2.0.0.43).

Haven’t tried W98se on controller tho’ (except installing, which didn’t work)

Also, wouldn’t it be best to install the OS on the fastest drive (beeing the 120GB Maxtor 133?

Quick read-results Diskspeed32 (got more or less same results on all configurations i tried):
40GB (W2k) SeagateIII…34,2 MB/s
80GB (W98) SeagateIV…36,4 MB/s
30GB IBM DTLA307030…29,3 MB/s
120GB Maxtor133 DP9…47,7 MB/s

=>Mator is +/-30% faster! (due to ata133/UDMA6 vs. ata100/UDMA5 for the other drives)

Most likely you have either a bad controller or a bad drive that’s causing the detection problems.

I doubt you will see any real difference in performance on any of the drives, except that you will see difference between 8MB cache and 2MB.

Suggest you run full drive diagnostics on all HD’s. It sounds like one particular drive is causing the problems.

Problem solved:

  • Running full diagnostics on all HDD did not reveal any errors. HDD’s passed all tests with flying colors.
  • Moving Promise controller to PCI-slot 2 or slot 6 did not help.
  • switching cables did not work.
  • Having just W2k on the controller made no difference.
  • Using different bios-versions for the controller changed nothing.

BUT-------

“Instead of installing win 2000 on the mobo IDE then moving it to the PCI controller card, try pressing F6 during win2000 install and completing a full win 2000 install with the drive connected to the PCI controller.”

-------DID WORK!

So, in order to get everything working properly for a duall boot-setup i have to:

  1. Install W98se on the motherboard’s IDE controller, then move it to the Promise controller.

  2. Install W2k directly on the Promise controller, NOT move it from the mobo to the controller.

Thanks to everyone who helped me with this and thanks in particular to “TotalChaos” from the Doom9 forum who suggested the above.

-Alfa-