HDD problem



I have an external HDD, 2T. Using Win. 10, I have had it for about a year and have lots of programs on it. I don’t know what occurred, but when I try to open it I get this message M/:is not available. Access denied. In control panel it shows a healthy partition. Need some advice. T.I.A.


Hi durkinjt
Hmmm, I am initially fumbling blindfolded with most questions like this one as the amount of information provided is a little to little - like did you connect it to another computer prior to this happening? Is it an NTFS formatted drive?..

Anyway, here goes a general tip as it seems to me that the drive is probably NTFS, the owner of the drive hierarchy is someone else and your user is not currently found in the security settings for the drive.
I am not not certain of course, but since you get ‘Access denied’, it seems to be the case. Unless there is a good reason to (like files over 4 GB in size), avoid NTFS for external drives that is to be moved among computers as the security settings are going to give you a headache from time to time. If you choose to keep it NTFS, change the owner to ‘Everyone’ and set ‘Full control’ for the ‘Everyone’ account as described below…

Now, to help you along, I did convert one of my FAT32 external drives to the NTFS filesystem and made it inaccessible on this computer like it is on yours.

Open '[B]This PC[/B]
In the worst case scenario, it will look like this:

Notice how even the size and what is on the drive is hidden from us…

[B]right-click[/B] the drive in question and choose [B]properties[/B] you could get something like this…

Don’t worry about the troublesome numbers even if you have them (I just wanted to show you the worst case scenario), we are going to fix that, just click on the [B]Security[/B] tab:

Now click on the [B]Advanced[/B] button above as shown which brings us to this:

As I have shown above with the mouse pointer, click on [B]Change[/B] and please disregard the other choice as that does not necessarily gain you access to the drive (my method does).

Now you will see this requester, just click [B]Advanced[/B] as shown:

Then you get this requester. Here you simply click on the [B]Find Now[/B] button and you get a list as shown:

Scroll down and double-click your user account (It is displayed at the top of your [B]Start Menu[/B])

That brings you back to the window with your user account in view:

Just click [B]OK[/B]

That brings you even further back to this window again:

Check [B]Replace owner on subcontainers and objects[/B]
Click [B]OK[/B]

If you are lucky (a tad dependent on security settings in place) you will get this requester:

Just click [B]Yes[/B]

Then you will get a requester which will disappear when it is finished, but for the record, it will display a whole lot of files like this:

Wait for it to disappear by itself and do not click cancel :wink:

Once finished, you will be back to this requester:

Click [B]OK[/B]

Once back in Windows Explorer, [B]right-click[/B] the drive again and choose [B]Properties[/B] from the context menu once more. This may or may not bring up the following requester:

Click [B]Yes[/B] (revival of the contents of the recycle bin is way out of scope here and it probably does not contain anything important anyway)

In my case that brings me to the following screenshot:

Since you probably are outside of a domain, it probably shows your account and so you can click [B]OK[/B] after checking that it reads [B]Full control[/B] and you have complete access to the drive again…

For the sake of completeness, let us presume the user account shown is just ‘gargleblaster’ in the form of S-??-???.. Do not worry, just click on [B]Advanced[/B] and you get:

Hit [B]Add[/B]

That will bring up this:

choose [B]Select principal[/B]

Again you will get this, and again you should click on [B]Advanced[/B]:

Yet again you get this where you hit [B]Find now[/B] and scroll down to find your user account:

[B]double-click[/B] your user account above and you are back here:

Click [B]OK[/B]

That brings us back to this:

Now, click on [B]Full control[/B] then click [B]OK[/B]

Then you get back to this requester:

The important part here is to check the box in front of [B]Replace all child object permission entries with inheritable permission entries fro this object[/B] and then click [B]OK[/B]

Then you are faced with this warning:

Just click [B]Yes[/B]

Finally, you will get the following which should not be cancelled but be allowed to finish:

Now you can access your drive again as long as it is readable (though viruses may call for routines out of scope for this walkthrough).

The above was written after more than a few single malts and since my mind do work the Norwegian way even when writing English… If anything is unclear, please do not hesitate in asking… (there is nothing wrong with my knowledge language may be the culprit though)


Xercus…Thanks for going through the time and trouble for a fellow member to simply fix a problem. This forum is amazing with amazing members!!