HDD crash (pretty sure)

vbimport

#1

FUCK! pardon my french (sorry)…

think my 120GB Seagate PATA HDD just died…

no backup yet as it was relatively new…luckily there was no mission critical data on it but it was chock full of LEGALLY downloaded music…

ARRRRRRRRRRGGGGGGGGGGGHHHHHHHHHHHHH!!! :(:sad::a


#2

whats makes you so sure its dead?


#3

clicking and Promise controller says “No Device Found” - “BIOS not installed”

i just flashed my mobo BIOS up to the most recent version and upon restart i kept getting “Machine Check Exception” BSODs on Windows boot…thought it was my BIOS settings, but after much troubleshooting (process of elimination) i disabled the Promise controller in BIOS and started up without a hitch…renabled controller and got the above errors from the Promise controller…

trying to get a hold of Seagate right now to see if there’s a way to maybe reflash the BIOS of the HDD so it gets recognized again…

any suggestions, advice, tips?

edit: forget the HDD BIOS comment, it’s the Promise controller saying BIOS not installed rather…

btw, what rail do HDDs run off? the 5v or the 12v?


#4

Maybe can sound dumb, but can you try to connect your HD on another computer?


#5

not dumb…already tried that…same thing from other PCs Promise controller…

on the phone with Seagate now…most likely RMA time…

edit: yup, RMA time…

got 3 HDDs and 1 iPod to RMA now…woohoo…660GB of HDD comin’ back at me sometime soon…:rolleyes:


#6

Maxtor drives have an utility to check hard drive; does also seagate have one?


#7

not much a utility can do if the BIOS doesn’t even detect it…


#8

believe it or not clicking hdds can be revived temporarly by freezing it works in about 60% of cases,put it in an anti-static bag for 2-3 hours and then take it out of the freezer and connect right away (assuming it will work it wont last long so you must copy the data to another hdd so youll better have the os installed on a diffrent hdd or connect it to another pc) and if it wont be long enough to copy all the data you need just freeze again and again til youll get it all done,eventually youll have to rma it as this method isnt a true fix its only temporary

the promise controller message is normal considering the hdd is in bad shape,it uses both of the rails


#9

Sorry :o , forgot that bios can’t detect drives


#10

yeah, i’ve tried the freezer-trick on two dead HDDs in the past - both no-gos…thanks for the answer on the rails question…

@gene gonna see if SeaTools can help out at all…no apology necessary, you’re just trying to help…thanks :slight_smile:


#11

On seagate site there is this note:

“SeaTools requires an Intel-compatible system”

I don’t know if is referred to CPU’s or if want to say that is not functioning on linux systems


#12

its diffrent on each hdd sometimes it works and sometimes not just cuz it didnt work on 2 others it doesnt have to mean it wont work also on this one give it a shot if the data thats on it is important to you , anyway the 2 others you tried it on before were clicking too? the freezer trick may work only for clicking hdds
it will never work on hdds with burned pcb


#13

probably just means X86 compatible…so no RISC machines :wink:

i’ll give it a try eventually…going through all the typical things i can think of…the other two HDDs were SATA 250GB WDs (each died in a different machine)…one might have been because of a slight PCI-bus OC with no lock, the other was just bad luck (unless my un-locked Promise theory below has any merit)…

my mobo has AGP/PCI locks and i’m 90% sure the Promise controller is locked just like the Via…wonder if the brief attempt at OC’ing with the new mobo BIOS had anything to do with it (shhh, Seagate already gave me a case # for an RMA ;))

thanks for the help guys, much appreciated :iagree:


#14

so try it and cross your fingers :slight_smile:


#15

drpino i dont think you saw my previous reply as you replied just a second after i did,anyway its very unlikely for the hdd to go bad due to overclocking in some motherboards overclocking can cause data currption but it can never totally destroy it , if the data thats on it is important to you then you shouldnt rma it so quickly in that case its better to try the freezer trick or pay for professional data recovery if the freezer trick wont work


#16

Maybe a little dumb, but if so, i.e if there are only corrupted data, why bios can’t see the disc? If the only thing corrupted are data, then bios should see the disc, but give errors only when try to read corrupt data. Is it correct?


#17

yeah, i’m familiar with data corruption due to an OC’d PCI bus (have had it happen before)…

data isn’t that important, just days (if not weeks) of BT downloads (all totally legal radio show recordings from the UK)…i’ll give the freezer trick a try eventually (usually takes me weeks to actually part with my hardware for RMAs)…


#18

geno888 data currption got nothing to do with this case and in general data curruption cant destroy an hdd,indeed when data currption occours it wont be possible to read currupted data and errors might show up


#19

After u flashed ur bios did u reset bios to default failsafe startup settings then reboot go back into bios then enter ur usual settings?


#20

Clicking = hardware failure … it’s not detected not because of the data but because the mechanics in the Hard Disk had fallen out of spec, become damaged because of excessive use etc. AFAIK, no way to recover if it won;t spin up by itself, apart dissassembling. (Freezer trick may work, but be careful of condensation.)