Has the DVD writer died?

vbimport

#1

Can anyone tell me if I need to replace my DVD writer.

Received following imgburn error messages when writing:

[I][B]ScsiStatus: 0x02 - interpretation : check condition

Failed to write to sectors - invalid address for write[/B][/I]

I had previously just done a clean Windows xp install.
I have replaced cables.

Could this be motherboard controller problem?

Windows says all is ok and DVD rom reads fine but can’t write.

I only have one PC so can’t test the writer elsewhere.


#2

Welcome to the forums mistral30.

Are these dvds the same ones that you were burning before the new install of XP? Not just the same brand, but from the same cakebox? The reason I ask is that the error message you’ve posted usually indicates an incompatible blank disc with your particular burner. And buying the same brand doesn’t always insure that you are getting the exact same type of discs, as the brands will sometimes change suppliers with no external changes in the packaging. You have to go by the mid code (Manufacturer ID code) of the discs.

It would help to know the make and model burner you are using. This is easy to find in Imgburn. Older style PATA/IDE interface drives sometimes have issues with DMA status, which isn’t something that happens with SATA drives.

You might also have problems with upper and lower filters. ImgBurn offers a way to remove them through Tools–>Filter Driver Load Order. There is also a way to reset DMA in there if using an older IDE interface drive.


#3

Many thanks Kerry!

The DVDs are the usual brand standard Verbatim (not Blue Ray). Same batch as previously used.

The burner is LG multi - HL-DT-ST BD-RE BH10LS30 1.02-A0.

Never had problems before. Will try the filters/DMA suggestion.

Could re-install of Windows have affected filters/DMA?


#4

That is a pretty good blu ray burner. SATA interface. And we regularly recommend Verbatim brand dvds. There is one exception to that, in that Verbatim “Life Series” dvds have CMC mid codes and don’t use AZO dye. A real Verbatim will have a mid code that starts with MCC, for example, 16x +R Verbatim would be MCC-004.

Mid codes are also easy to check in ImgBurn. One way to do that is to put a disc in the drive and change to Discovery mode. The mid will show up in the window to the right.

Resetting DMA is not necessary for you, but filters can get screwed up. You seem to have the latest firmware available for your drive.

You can also try the Microsoft Fixit tool for optical drives, but I find it to be very ineffective for most. http://support.microsoft.com/mats/cd_dvd_drive_problems


#5

Regarding the reinstall of Windows…have you checked Device Manager to see if any problems show up there? And are you certain you have installed all the necessary drivers for your motherboard?

Are you using XP with Service Pack 3?

Edit: There were some problems loading SATA drivers into XP, involving hitting F6 and loading from a floppy. But its been years since I’ve dealt with it. I made a copy of XP SP3 and slipstreamed the SATA drivers in it. But I haven’t installed XP in anything in a long time.

But since it is working to read dvds, this shouldn’t be a driver issue. At least, I don’t think so.


#6

[B]MID: MCC 03RG20
[/B]

HL-DT-ST BD-RE BH10LS30 1.02 (ATA)
Current Profile: DVD-R

Disc Information:
Status: Empty
State of Last Session: Empty
Erasable: No
Free Sectors: 2,297,888
Free Space: 4,706,074,624 bytes
Free Time: 510:40:38 (MM:SS:FF)
Next Writable Address: 0
MID: MCC 03RG20
Supported Write Speeds: 8x, 12x, 16x

Pre-recorded Information:
Manufacturer ID: MCC 03RG20

Physical Format Information (Last Recorded):
Disc ID: 0@P-!-00
Book Type: DVD-R
Part Version: 5


#7

^Yes that looks normal.


#8

Device manager says all is OK

All drivers installed.

What is weird is that I can read Dvd’s fine.

Tried to burn using Windows explorer - would not let me even move a file into its window for burning.


#9

Well, I’m running out of options for you. You can try a different SATA port on the motherboard and see if that helps.

Since the drive uses a different laser for burning blu ray than it does for dvds, you could try burning a blank blu ray also. If that works, you might have a partial hardware failure in the drive that affects the dvd laser. If you have one, I’d burn a re-writeable BD-RE.

Might try a cd too.


#10

Just tried explorer again with a CD - attempted to write but said error in writing process.

Guess - - - new writer needed!


#11

Will try a BD.

Thanks Kerry


#12

No problem. Good luck with it.

And if you’re in the market for a new drive, the Pioneer 208 or 209 would be my first choices.


#13

Post the complete logfile…