Hard drive wont start up

[qanda]This thread is about the Western digital Caviar GP 1 TB. Click here to see full specs[/qanda]OK let me clarify this is a 1TB WD HD however after some complications with it’s original casing I was forced to buy another one the other one was a rocketfish enclosure casing, complete with a card reader and 2 extra USB ports.

It starts up as usual, but since the new enclosure has a card reader and 2 usb ports, it picks up the card reader even a device in the usb port is being read, but what happens after the hard drive in there makes that sound that says it’s being picked up by the computer it (only the HD inside) stops spinning.

It received some shock from a 2ft fall on it’s belly. I plugged it in immediately afterwards and it made a mechanical whirring noise at first but read as usual

But afterwards I think I afterwards unplugged it by accident, I plugged it back in and that’s when the thing started doing what I described above.

Bump

I would get new one and try to get your info. You don’t want this drive after a fall like that, just not worth it. You can get a Hitachi for 79 dollars at Frys electronics. Good Luck.

Two things, try a different enclosure, preferably one with no extra gadgets, just a plain enclosure.

If you can get the drive working with a plain enclosure, or if you are real adventurous, by plugging it inside your PC, then go to Western Digital’s website and download the DLG utility and run diagnostics.

it will still acknowledge the drive’s connection even if it doesn’t spin up? (I’ll connect it to the pc directly.)

Helloooooooooo…?

If the drive has had a hard knock and then will not work correctly the obvious answer is that it is broken.
It may be that the drive was corrupted when it was disconnected.
Have you tried a recovery program?
Since the previous advice have you tried the suggestions? Please post the results.

Same result in and outside. Funny thing is it doesn’t stop spinning UNTIL it is read by a computer leaving me t believe that when more power is applied (from reading and writing) it conks out. Either that or it’s technical and it malfunctions when it receives data from the computer and shouts down. Maybe the thing that manages the energy saver is starting up right away instead of a few minutes after.

Does anyone have the link to the precise utility mentioned?

The Western Digital utility?

Data Lifeguard Tools