Hard Drive shows "unformatted" What to do?

Along with two older hard drives, I have been running two new Seagate Sata 3 hard drives for 2 months now. A few days ago I started the computer and one of the new drives appears now as a “unformatted drive.”

This is a 320 GB drive using the NTFS file system. As far as I know, there are no viruses or other programs that could have caused this. This drive is a single partition used for storage only. The other three hard drives run just fine.

I have used Partition Table Doctor software to try to recover/rebuild the partition. This program sees the file structure on the hard drive and says that it has rebuilt the partition table and the master boot record, but on re-boot the hard drive remains unformatted and unaccessible.

Partition Table Doctor offers the option to “fixboot” but clicking on that returns the message that it cannot fixboot.

I have two questions:

  1. Any ideas on how to recover the data on the disk?
  2. What caused this? It appears to be totally random, but there must be some cause?

Thanks///// Bobbo

Something similar happened to me when I had a Seagate 80 gig. Every so often on boot-up, it would come up “unknown file system” (it was formatted to NTFS). Since I had nothing of value on the drive (it was just my OS drive), I just reformatted and went on my merry way. Didn’t stop it happening, it happened again several times after that.

However, when I thought to run chkdsk (and Seagate’s diagnostic utility), it turned out I had bad sectors, which may have been the cause of my problem.

Hopefully someone can advise you on recovering your data, but I’d strongly suggest that afterwards you run Seagate’s diagnostic utility as I did. :slight_smile:

Give TestDisk a try. :wink:

test the drives health with seatools for windows , get it here
http://www.seagate.com/www/en-us/support/downloads/seatools
if bad sectors will be found , then i highly recommend using spinrite (a software that reconstruct data from bad sectors as much as possible,the best of its kind,but of course not free) , if no bad sectors will be found then just use data recovery software (file scavenger,power data recovery,getdataback are some of the best)

Thanks guys. I did run chkdsk for about 20 minutes to about 33% done and it was finding no bad sectors. I will go ahead and finish a full test.

I’m finding more threads on the subject. The problem is described the same but so far I haven’t read any cause for it ((virus, lba 48 assignment, or 137GB limitations all seem irrelevant for a disk that was up and running for 2 months and no other disk affected?)).

Seagate technical said to run the diagnostic programs and absent that it was purely a file problem. I’ve used a few file recovery programs and they say they are finding files but none of them will open to show whats there. I’m sure my learning curve is an issue there, so i will try them again.

I wonder if this could happen to a Raid 5 array? ie–one disk go bad in the group. Would the disk just lose its format and become “bad” subject to being removed and reformatted and reinstalled/rebuilt by the array or would “maybe” the entire raid array go bad with that type of error?

So many variables. Well, since I can’t seem to fix the partition, going to give “Get Data Back” a try to recover. Their FAT recovery worked about 30% for me. Get to pay again for the NTFS version. Joy, joy, joy! //// Keep the ideas coming!–Bobbo

Hey Bobbo - if you run the online version of the SeaTools diagnostic, if it finds any bad sectors it’ll ask you if you want to RMA the drive.

Let us know how the tests work out :iagree:

Arachne–thanks for encouragement. The quick diagnostic disk test said no errors now run the longer test which I will do later tonight, but not expect much. I have had similar events on the hard drive in my caddy and I have always accepted it as a product of electrical interference given the additional connections–but never a total data dump such as this disk is doing now. Is the NTFS file system just more sensitive in some way? Is Win XP less reliable?===ie, I never had these issues running win2000 on Fat 32 systems. Upgrading for worse experience–booyah!!!

Get Data Back has another 5 minutes to run. On Track Easy Recovery was useless. It ran recovery but all the files it found were 7-10 megabytes in size==totally missing the video files all averaging 800 megabytes each.

I really “hate” not knowing/assuming/guessing/hoping WHAT CAUSES THIS? Don’t even care if its wrong, but random hard drive inaccessability should have a reason so I can atleast “try” to avoid it?

I need a new hobby. DvD recording is way too iffy. //// Bobbo

Bob is this a shared pc?

No problem :wink: - it is indeed encouraging that no errors were found on the short test, but do run the longer one if you can find the time, that’s the one I was running when my Seagate’s bad sectors were found. Mind you, chkdsk also found them.

I know what you mean, it’s a pain when something happens and you don’t know why.

IIRC, my ex had a similar problem with a WD drive a few years back - data totally wiped and he never did figure out why.

Good luck with the data recovery :smiley:

I bought two Sata Drives in order to test my Raid 1 Mirroring configuration and assumed any disk failure would show itself in a month. After one month, I broke the raid and started filling the drives with “new stuff.”

Well, I cant fix the partition table/mbr or whatever to get the disk back, but it looks like Get Data Back (for NTFS) is WORKING!! It can only recover about half the disk, but that is the half with the new stuff on it. First five file recoveries have full names, file sizes, and play perfectly–now just to find enough space to store the copies. I know the recovery is helped by the fact that all the files were contiguous–non fragmented–in that they were fresh material.

I will report back if there are any bad sectors after running the test tonight. Then I will reformat to FAT 32 and start using it again–maybe in another mirrored array to avoid all this. I think “on average” from the stand-alone set top box recorder to my computer, to my hard drives, to burning a new disk after editing commercials, I have about a 25-30 percent data loss. Just ain’t no fun at all.

Please—anyone with ideas as to how good hard drives become “unformatted?” //// Bobbo.

Hi,

before you try any more tools on that HDD (Note: Any write access might cause additional data loss), get a Knoppix or Kanotix CD, boot from that and see if you can access your data. If so, then copy them to another media, maybe a FAT32 formatted external HDD.

Michael

Rolling–almost missed you. No, my sole computer. Will kids really do that (and then not own up to it???—smile!)

My earliest “diy” project was to take my dad’s watch apart. I couldn’t put it back together. It turned up the next day missing and no one ever knew what happened to it. Never lost my interest in things mechanical—but I do own up now. /// Bobbo.

and Michael–must be some cross traffic here. Yes, I tried Knoppix. It sees the disk but cannot access it. Get Data Back has now recovered 46 files–first 12 working and valid recoveries. Love these programs “when they work!” Being able to recover corrupt files is the BEST reason I can think of to keep a hard drive de-fragmented. Yeah!!! /// Bobbo

topinambur—testdisk looks real good. I googled for a few hours and didn’t come across it===crowded out by all the for profit products? I thought Google was supposed to help avoid that stuff?----thanks. I’ll give it a try after the data recovery is done. /// Bobbo.

IMO it is a really nice piece of freeware… I used it several times, and at least twice to recover HDDs with the same problem as yours, i.e. appearing as “unformatted drives”, with full success (and without using any other recovery software). Worked great also with boot sector corruption stuff and problems related to dynamic volumes. I heard about it for the first time in a linux mailing list.

topinambur–I’ll post back one way or the other. Get Data Back is recovering files 100%. What gets me is I thought that disk was about full–but all the files that were on that disk were only taking up about 40%. I wonder if the empty space got recharacterized as “unallocated?” (((Given all my problems, I inventory disk contents once a month just to keep track of how much stuff I lose!!! I use Visual CD–excellent free DvD catalogue software)))

Any idea what causes “unformatted disk” to occur? All I was doing system wise was copying files to that disk and web surfing and editing video files. Not changing disk characteristics or anything like that. None of my disks are dynamic. I read about it and saw no reason to span disks so stick with the default settings.

I tend to doubt it will work given that Partition Table Doctor and Knoppix did not. If it does work, it will give me a comfort level to stick with my hobby—got to finish up with all the Soprano’s afterall? Thanks again. //// Bobbo.

Good luck and thanks for reporting back. :slight_smile:

Final Results:

I ran Test Disk and it acted just like the other partition rebuilding programs–it ran for about 30 minutes and said it had rebuilt the partition and to restart the computer. On restart, nothing had changed. So–having gotten all the files recovered with Get Data Back, I went ahead and reformatted the drive and it has worked as it should for 24 hours.

I downloaded Seagate Tools from the link Bunny provided above just to use the official software should something turn up. The drive immediately fails the short drive and long drive self tests, but passes the Short and Long Generic tests. I asked Seagate what the difference was between the two types of tests and they said they didn’t know. ((Thats what they said!–its two different ways to check the disk, but no details available, should I call again?===I would think all the techs talk out of the same book?))

I asked if failing the Self Test and Passing the Generic Test meant the disk was bad and if I should return it. Seagate TEch said “maybe” and I could do whatever I wanted to.

To be fair, Seagate was surprised there was no failure code or log or explanation and that usually there was.

I ran the same tests on another of my Seagate drives that is working just fine. I got the same results. I’m thinking its either a bad download of the software, or my system is in someway is incompatible? Microsoft checkdisk shows no errors on the disk and I’m thinking thats accurate given some other problems I’m having.

Thanks to all for your help. //// Bobbo.

You could try the online tests - IIRC with my dodgy 80 gig drive, I got an error code then.

As for chkdsk - yeah, I must admit that found the bad sectors on mine before the online Seagate test did.

Good to hear they’re currently doing what they should be - but obviously you’ll know to back up just in case :wink:

Damn Arachne–I was going to Boast about how my back-ups are 4 levels deep (for personal data/programs) and the problem was I can’t back-up all the partial seasons of tv shows I have recorded.

THEN - I remembered what I already knew==indeed, I have to again simply run atleast a few mirrored drives. Just cut back on the amount I save before burning to dvd.

I ran Raid-1 for months but only to check the validity of the drive, then break up the Raid and fill up both drives. As I posted in hardware forum, I think I’ve also got a controller issue, so, Back Up is what is needed==just on a larger scale than usual. but I am reminded some of my data failures have indeed involved more than one drive at a time. Maybe reading books really is a better alternative? ==Thanks Again /// Bobbo

Hehe, I think I’ve asked myself that question a few times as well :bigsmile:

Still, it looks like CDan might be onto something in your other thread - fingers crossed :wink: