Hard drive icon gone, how to fix it?

Ever since last night, my hard drive icon has been gone…Here is a pic of what it looks like:

in Windows explorer go to tools\folder options\file types, click on the drive icon in the menu and then click on the advanced button. in advanced there is an option to change the drive icon once you click on that you can find the drive icon in the icon cache that pops up and just choose the drive icon.

Hey bro, thanks for the reply…I tried that, but it didn’t work, I rebooted and tried it all again, but it is still the same. I attached screenshots:



Have yuo tried running scandisk? that is about the only other thing I can think of offhand.

Nah, I’m backing up stuff anyway for a fresh install, so I won’t worry about it.

Interesting. Have you try booting to Safe Mode and check if in safe mode the icon is also “gone”?

Ok, I rebooted again and the icon is back to normal. But now, when I double click either one of my HDDs, the search box (attached) pops up…I have to right click the drive icon and explore to see the contents. Any idea how to change it back to normal?


Fixed it!

Had to edit this regitry entry:

HKEY_CLASSES_ROOT\Drive\shell

And set the default value to “none.” :iagree:

Default what?
There are no entries at that location!!!

Heres what I have, the value I changed was set to find or search, I can’t remember:


Thanks DJMind.
I’m working on a computer for a client and it has the same partition icon issue.
The data value of that string is already set to none and it’s still not working.

I’m at a loss for a solution, I’m afraid.

You can check, if an autorun.inf file was accidently copied to the root of the partition. If yes, delete it. Good luck!

Thanks Tru,
However no such luck.

For the sake of those searching the forum with a similar issue, this solution posted by Tru does work.

As I had returned the computer to the client, I had him check for the autorun.inf and he said there was none.
I recently got a chance to check first hand and the autorun.inf was in the root of the partition.
Deleting the file corrected the issue.

Thank Tru.

You’re welcome, I am glad I could help!

I have the same Problem Mine won’t fiI’ve tried everything does anyone think they could help me

I tried impossible things :a , but the problem proved just like Tru said:

In my case it was not [B]“accidently”[/B] :rolleyes: , I create it for autorun CD (I like to appear some icon when CD run - what a curious :o ), but when I finished the job, I just forget to delete it :doh: . Тhere is no one to tell us, that Windows patition hate lovely [B]autorun.inf[/B] !

Thank [B]Tru[/B] :clap: , you are the Guru :bow: !!!

I have a drive that is in the same state but i just format it again, still comes up with no icon. There is no autorun, and its a external drive. I plugged in another external drive and it came up the same way. I need help

I know this is probably a old thread but i need help too… drive icon is gone

Bump!!!