Hard Drive disaster! PLEASE Help!

I used Acronis OS Selector: Rescue Media Buider to make a rescue CD.
I rebooted my PC and I was taken into OS Selector’s GUI.
It seemed to only have picked up 1 of 3 hard drives on my computer. It only picked up my 320GB hard drive- my biggest hard drive and one with the most data. (I have a different OS on each hard drive.)
It then prompts me, telling me that it needs to resize the partition contained on that hard drive from 298Gb -> 298Gb. So I click next, etc. It immediately brought a progress bar which wasn’t moving at all. I let my computer sit for about 5 minutes, and it moved 1 notch. I thought something was fishy, and I hit the reset button on my computer. I logged back onto XP(off my 80GB drive), and went into My Computer. I tried accessing the 320GB and was told that “F:\ is not formatted, would you like to format it now?”. In a rush of panic and fear, I used a program called Testdisk to rebuild the hard drive’s partition, as this program has worked in the past. I didn’t solve the problem.

Every time I now try to access the hard drive from My Computer, I am given the message
“F:\ is not accessible. The file or directory is corrupted and unreadable”
I am extremely distressed about this, and I can’t begin to explain how important the files in that hard drive are.
I REALLY REALLY need the information contained on this hard drive. PLEASE PLEASE give me some ideas on how to get the partition back, so I can access the hard drive like I used to. ANY help is much appreciated! Thank you !

PS. The hard drive is physically healthy, and has no mechanical problems whatsoever.

No guarantee, but try this first:

http://findandmount.com/

Post back.

If you have a copy of Linux, or know someone who does who you could bring the disc to, magicrescue and/or foremost might help - as far as I understand they’re both file system independant as long as long as encryption hasn’t been used. Keep in mind that you need something to transfer the files to, and the filenames will presumably not be kept.
http://www.student.dtu.dk/~s042078/magicrescue/manpage.html
http://foremost.sourceforge.net/

Had a similar problem this morning, my computer wouldn’t recognise one of my 120Gb drives.

Pulling the cable off and putting it back on (actually just the act of moving the connector on the end was what did it) made the drive work again.

if you have IDE drives always suspect the cables first.

It’s like when you have a flat tire, you go looking for a nail in the tire rather than a cracked rim.

AD

AD

To the OP is Acronis OS Selector part of Acronis True Image ?
You probably need to do a complete restore with Acronis.
I’m not familiar with Testdisk but when it rebuilt the HD partition it probably formated it & wiped out the data.
So I hope you have an Acronis backup already.
Also let Acronis restore the MBR for this drive.
298GB is approx the actual size of a 320GB HD.