Hard disk space missing



I have just had a problem with an 80GB IDE hard disk. It is an internal drive, originally installed on another computer. I removed it and hooked up to another computer externally, via USB. I formatted it, and now the drive shows only 34 GB. I tried everything I could, like showing hidden files, but there is nothing on the drive. At least, nothing visible.

I want to know what happened. It is more a curiosity than any real necessity, because I have other bigger SATA drives available with plenty of storage. But, as I said, I would like to know what the problem is.
Any help is greatly appreciated.


My guess is that there are two or more partitions in that drive.

Try to use disk manager to see how many partitions there are :slight_smile:


There is only one partition.


There is some unallocated space on the disk?


[QUOTE=geno888;2638425]There is some unallocated space on the disk?[/QUOTE]



Try to use TestDisk. That tool will analyze the HDD to check for any partition.

Did you use some encryption software on that disk? Maybe there is a hidden partition.

Another tool you can try is gparted. If I’m not wrong, it is able to find hidden partitions even if operative system can’t.

BTW, are you sure that the disk is an 80GB model? Try to run Speccy to find out exactly disk specifications.


I’ll try the software you mentioned, and then post back.
And yes, it is 80GB(I remember using about 70GB of the same drive a few months ago).


It has to do with FAT32, NTFS, or Jumper settings. Also the USB interface may not give you all the options. I suggest going to your External Drive Support or the 80Gb HDD Manufacturer Support.


In my foggy distant memories back before there was the 48LBA issue that limited hard drive capacity with some computer motherboards to 128GB there was another one that limited available capacity to 30-ish GB.

This was the reason why even some early SATA drives can be jumpered to limit capacity to 30gb…

but this is all something so obsolete I intentionally took time to forget it.