GSA-H55N won\'t burn any faster than 2x

[qanda]This thread is about the LG GSA-H55N. Click here to see full specs[/qanda]Hi everyone, I’m new to these forums. I looked around the web for this problem and had no results and people said this was the best place to go for my problem so hopefully some experts here will know how to help :bow:

So basically I have an LG GSA-H55N drive. My computer reads it as ‘HL-DT-ST DVD-RAM GSA-H55N’ and the firmware is version 1.05. Now I’ve burned a few dvds since I installed this, and all of them seemed to take like 40 minutes. For a 20x writer (albeit limited to 16x because of my media) it should not take anywhere near this long. Obviously.

At first I thought it might be a driver or firmware issue so I looked around and found that my firmware and drivers seem to both be up to date. Nero reads the drive as being capable of burning at 16x. I even ran the nero speed test but it shows it burning at a solid 2x and then somewhere shortly after 2GB have been burned it plummits to only around 1x. 1x!!! wtf

I have no idea what to do. I’ve tried burning dvds at 16x, 8x, 4x, ‘Maximum’ but still they all take around 40 minutes. It’s insane. Oh and in case someone asks about the media I’m using, I’m using HP DVD-Rs. They work fine on my two other computers as well as my friends computer so I really don’t think it is the media. Also I got one of my friends Verbatim DVD-Rs and tried that just to see and had the same exact problem. Can someone please help me here? I have no idea how to get this working.

Welcome to CDF :slight_smile:

Sounds like UDMA Mode might not be enabled - see the link in my signature (“How to check/enable DMA”) for instructions on how to get it enabled again :slight_smile:

Thank you thank you, I cannot thank you enough. At first setting the IDE to DMA if applicable didn’t work, and after about 4 reboots I was getting angry but I delved deeper into the issue and checked out your thread about uninstalling it using another method, and from there followed a method editing the registry keys for the device and after a reboot is it working and burning at correct speeds.

For anyone who may read this in the future and is having the same issue, try arachne’s method for enabling DMA, and if that doesn’t work then search for a way to override enabling DMA editing the registry.

Oh, and once again, thank you!

You’re welcome :D…happy burning!