GSA-H31N won't read/play bought DVD movies

vbimport

#1

The GSA-H31N drive in my Acer ASE700 computer stopped reading/playing bought DVD movies a little while ago. When a DVD movie disk is inserted, I can not see the content in Windows Explorer (shows zero object), and can not play with any of the player software I tried (PowerDVD, VLC, Media Player Classic, Windows Media Player etc), says no disc in drive.

I can read data DVD, and home made DVD movies. I can create data DVD and boot from it (e.g. Knoppix). But when it comes to bought DVD movies, no luck. It worked before, but somehow it stopped working.

I have tried re-flash the firmware (B109 from Dell site), but that does not help.

Any ideas?

I have heard that this could be caused by dirty lens. If so, how come it works for data DVD.

Thanks very much.

yangj


#2

Hi and welcome to the forum :slight_smile:

Did you install some software just before this problem started? usually are burned discs that cause reading issues, and not pressed ones.

Can you check what region is set your drive? ImgBurn can be used for this :slight_smile:

Select Write mode, then go to menu Tools --> Drive --> Regional Code --> Information

Drive region can be set only a limited number of times (i.e. 5), after then the drive is locked to the region currently set. If your drive is set to region 2 (for example), and you are trying to read a region 3 disc, the drive will not read the disc.

There are two possible solutions for this: resetting the drive code (or setting it to region 0) or using a decrypting software like AnyDVD so every disc will be decrypted on the fly and the drive will be able to read it :slight_smile:

To reset the drive region a modded firmware (i.e. unofficial) firmware is required, but I have no idea if such a firmware is available for that specific drive model.


#3

Thanks very much for replying.

I actually have no idea when exactly that happened. I don’t watch movies on my PC often, only occasionally. So no idea what caused this.

I have the correct region set (region 1), the same as the movie DVDs (North America) I’m trying to read.

I attached some information from the Nero InfoTool below, if that helps. Hope you don’t mind, it’s kind of long.

Thanks again.

Nero InfoTool 5.3.3.0

Drive Information
------------------
Drive                      : HL-DT-ST DVD+-RW GSA-H31N
Type                       : DVD±R/RW DL Recorder
Firmware Version           : B109
Buffer Size                : 2 MB
Date                       : 06-12-21
Serial Number              : 6<6:;CK$
Vendor Specific            :  06/12/21
Drive Letter               : E:\
Location                   : 0:1
Mechanism                  : Tray
Read Speed                 : 48  X
Write Speed                : 48  X

Read CD Text               : Yes
Return C2 Pointers         : No
Read CD-R                  : Yes
Read CD-RW                 : Yes
Read DVD-ROM               : Yes
Read DVD-RAM               : No
Read DVD-R                 : Yes
Read DVD-RW                : Yes
Read DVD-R DL              : Yes
Read DVD+R                 : Yes
Read DVD+RW                : Yes
Read DVD+R DL              : Yes
Read BD-ROM                : No
Read BD-R                  : No
Read BD-RE                 : No
Read HD DVD-ROM            : No
Read HD DVD-R              : No
Read HD DVD-R DL           : No
Read HD DVD-RAM            : No
Read HD DVD-RW             : No
Read HD DVD-RW DL          : No
Read HD-BURN               : No
Read Digital Audio         : Yes
Read CD+G                  : No
Read VideoCD               : Yes

Write CD-R                 : Yes
Write CD-RW                : Yes
Write DVD-R                : Yes
Write DVD-RW               : Yes
Write DVD-R DL             : No
Write DVD+R                : Yes
Write DVD+RW               : Yes
Write DVD+R DL             : Yes
Write DVD-RAM              : No
Write DVD-RAM              : No
Write BD-R                 : No
Write BD-RE                : No
Write HD DVD-R             : No
Write HD DVD-R DL          : No
Write HD DVD-RAM           : No
Write HD DVD-RW            : No
Write HD DVD-RW DL         : No
Write HD-BURN-R            : No
Write HD-BURN-RW           : No
Buffer Underrun Protection : Yes
Mount Rainier              : No
SolidBurn                  : No
Labelflash                 : No
LightScribe                : No
Modes                      : Packet, TAO, DAO, SAO, RAW SAO, RAW DAO, RAW SAO 16, RAW SAO 96, RAW DAO 16, RAW DAO 96

Region Protection Control  : RPC II
Region                     : 1
Changes User               : 4
Changes Vendor             : 4

CSS                        : Yes
CPRM                       : Yes
AACS                       : No
VCPS                       : No

Disc Information (E:\)
------------------
Type                                                                                   : :No disc inserted

#4

Sorry about replying to myself.

I tried with AnyDVD, and it also can not recognize the movie DVD. The “Status” tab says:

No Disc is present in Drive E:!
HL-DT-ST DVD±RW GSA-H31N B109 06/12/21


#5

If the drive can read/write burnable media, then there is something wrong in the software compartment, something causing conflicts.

Try to run a full antivirus scan and also a spyware/rootkit scan. Maybe something was installed without notification (a very common behavior of malware software)


#6

I didn’t find any virus/malware, at least that is what Microsoft Security Essentials tells me.

I also re-flashed the drive to make it region free, GSA-H31N firmware B110 patched with MCSE. Checked and now the drive is indeed region free. Tried again a DVD movie, still no luck. The drive spins a bit, but never fully spins up. When reading a data DVD (that I have no problem with) the drive spins up full speed and you can clearly hear it.

One more thing I’ll try is to use a Windows XP CD and see if I can repair any corrupted system files.

Any other suggestions?

Thanks.


#7

That’s really strange that you have problems only with pressed DVDs containing movies. Can you read pressed data DVDs? For example a game disc or anything but a movie.

If data DVDs can be read, there is definitely something wrong in your machine and the drive is not the culprit. The most extreme measure is a fresh install of the operative system, but you should consider this possibility only as last resource :slight_smile: