GSA-4167B Buffer/Underrun Problem

vbimport

#1

I can’t seem to burn a CD-R… yet to try other types of media, as my DVD-R’s haven’t arrived and I had CD-R’s lying around.

The drive is in an external case that INOi markets (INOi DW560U-1600) and connects via a USB 2.0 cable and is powered by a cord that connects to a power device of some type - DC input to the drive through an AC/DC converter. (Yes, indeed… done dirt… .)

I am using the firmware inherent to the drive (HL-DT-ST DVDRAM GSA-4167B, C05FE8FEB840; haven’t updated… explained bellow) and Taiyo Yuden CD-R’s - the spec. # I don’t know - and I have tried transfering the data through the simple Nero software (Nero Burning ROM 6.6.0.9 and Nero StartSmart 2.0.0.21; a bunch of other Nero drivers listed too) provided by the INOi package I picked up as well as Power Producer Gold; also upon the same software disc included.

I was trying the move various types of video files to CD just to try them out (.mpg, .vob, etc.) in VCD form, so I moved them through Nero and PPG which reformatted them before the burning process.

Each time, the burning (not the initializing or whatever it is called before the burn) “fails” - I don’t know what better term to use here - at 1-3% for PPG, or runs at 100% of the buffer around 8-11% of the burn in Nero… basically it stalls. (The burner’s power status light stays on and the disc access light flashes at a slow, intermittent rate… but the burner makes no noise comparable to that it makes when the burning process begins. On that note, my windows task manager CPU usage drops from the high-flying 90-100%'s for the set-up to virtually nill during this problem… though I assume this is no indication of the problem.)

The CD’s have files on them afterwards, but none of the files are recognizable files to execute video or even view a picture.

I’ve tried a different port on my Dell Dimension 4600i, but same problem. I switched a cable and that didn’t help. …I have a cheap PCI card that installs USB ports, but that was intended for my other computer, so I don’t wanna go that route.

I’ve tried setting the burn speeds differently - and even turning the underrun off in PPG - but I still hit the same wall each time. Even when I give the machine an immense amount of time to work through the problem, I return to the computer, turn the monitor power on, and then see that it failed or is at the same % burn.

I know that there is a newer firmware update but that has nothing to do with the problem as per my knowledge… …but I tried updating it through the pop-up that appears asking me to update, and so it ran to 99% and then… and then… etc.; it doesn’t fully update. (I read somewhere that a failed driver update - I think this is what firmware is - can sometimes mess up the drive permenantly.) I think I can download the update I need and execute it later - “flash” ? - if this is the probable cause.

I originally had the files stored on an external HD, but then realized that running through two USB cables seems a tad stupid. (A proper nickname for myself, might I add.) I then moved the files onto the internal HD and same problem. (Nero mentions defragging - which apparently does not mean being shot by a superior officer - amungst the several solutions, but I don’t need to mess things up even worse.)

There’s CD-ROM’s that came with my external burner/enclosure labeled “External DVD Dual Drive: Installation Disc” and “External Case: IDE/Atapi to USB 1.1/2.0: For PC: WIN 98/SE,” but the “manual” (re: folded piece of paper with ink on it) suggests that I not mess with manual installation “unless neccessary.”

I apologize that I have no error report or what-have-you as I do not know how to find one…

Possible Problems:

I read the post about the power supply problem but the possible solution seems to be in an alien language to me… and I don’t wanna look like Yahoo Serious or blow something up… yet anyway-er, ever.

I read about someone having an IDE cable problem within the drive, but this is newly bought I better be able to exchange with TD if this is the case.

I also read about possible buffer problems relating to DMA - which sets the path through which the information flows to the drive, I think - but I don’t know how to remedy it with my set-up if this is the case. (I can’t edit this through my software, as it says XP doesn’t recommend augmenting it and gives me no options.)

I read about the audio CD problems with the burner - which, I believe, are resolved through the new firmwares - but I’m trying to do a VCD, so these problems shouldn’t apply.

I read about updating Nero or trying other software, but again, I don’t see how this would be the problem.

Could there be a problem with my PC at-large?

I basically wanted to try the dang thing out first, and I only can assume the problems will get worse if I heave up the amount of data I wanna burn. (I even tried a single 100MB .vob file and it failed.)

At least now when it fails I will be using the (much slower) CD-RW format and not angredly cracking CD-R’s over my head. (NOT ADVISED!)

If I’m not overlooking something simple here - heck, I can’t even seem to be able to format a CD for some reason, yet I assume I have to… inCD only formats RW media (slowly) - and if I have exhausted all my reasonable OE options I hopefully can exchange it this week.

Oh… and my machine is crashing like crazy - without WTM displaying an increased CPU usage - since I added this stuff… not important, but gotta vent.

Should my attempt into DVD burning involve this much aggravation, or is this normal, in that you need an advanced GED in burning before even attempting to burn a dang VCD?

I appreciate any help in trying to figure this out… …and yes, I do know, eighty other people have bothered asking the same query and that I’m too stupid to find the answers in your aid to them.


#2

What OS are you using?

First, update Nero to the latest version of Nero 6 available (6.6.1.4 or 6.6.1.6). Nero 7 isn’t better, tends to be buggy and requires a separate license so don’t upgrade to that.

As for why the writer doesn’t seem to work, and flashing of firmware seems to fail, see here :

http://club.cdfreaks.com/showpost.php?p=1289282&postcount=7


#3

Thanks for the quick help!

I am using the Windows XP Home Edition (5.01.2600 Service Pack 2) operating system…

As far as the advice… I can update to Nero… but 33MB of files across a 26kb connection will take an immense amount of time, at best. (Maybe I don’t get it, but what does an update to newer Nero - or newer firmware - have to do with the problem?)

I read the firmware problems, and the advice seems to be that I need to return this and get a different external burner? (It has DL12 on it.)

I know that people have used this burner correctly through the user comments sections at sites, so I do not understand why this one should be different unless it definitively is defective… or OE.

I don’t see any updating ability anywhere in those posts regarding the external enclosure problems… I did find some zip files I could possibly download and execute afterwards, but I didn’t note where they were, so I cannot find them. There’s also something in those posts about shifting the driver to another type of driver through firmware (that will only run at 8x max)… but I’m quite sure that this will void me of being able to return this glorious paperweight.

I even tried it on someone else’s computer and even after I unplug the thing because it won’t eject the media it refused to format, the computer sees it as a CD drive… and then the CPU crashing began as well!

So… exchange it? …get a different one? …try a different, freeware editing/burning software? …remove it from the external enclosure and defeat the purpose of purchasing the external burner? (I’ve read that the INOi cases are difficult to open and close, so doing this increases the chance of not being able to return the lovely device… and the chance of me destroying the thing.)

I can play DVD’s on it, rip DVD’s from it, and I can even run a Nero CD-DVD Speed 4.51.1 test on the blank media. (The blank TY CD’s came out at 33.1x avg. running the benchmark test.)

Anything simple or stupid that I might have overlooked would be helpful.

Again, I thank anyone willing to help me here.


#4

Some versions of Nero had a few annoying bugs in them which might be the cause of your misery. The problem is I am not sure which version fixed what bugs so I played safe and suggested upgrading to the latest version of Nero 6. However, since the burner did not work even when tested on another burner, I think we can rule out Nero being the cause of the problem.

Hang on a second, are you implying that you were sold this drive as an external unit? As in it came already installed in that INOi case? The 4167B is an INTERNAL model and there is no external version of it. The people who have gotten this drive to work correctly use it as it was designed - as an internal drive. LG internal writers are notoriously unfriendly when used in an external case. You can stick most internal drives into external cases and they will work properly straight away but not LG writers.

If you were sold this drive as an external drive, you have been had.


#5

I bought it from here.

The Infotool indicates HL-DT-ST DVDRAM GSA-4167B, C05FE8FEB840, so I hope I’m correct. The update also lists it as 4167B.

Unless I am missing something here - other “tests?” - it is the GSA-4167B… however… under the comments of previous purchasers at TD someone lists Lite-On SOHW 1693s. (The other Xindows XP PC I used it on listed GSA-4167B and I tried it on a MAC laptop someone else owns, but I couldn’t display it anywhere.)

E-mailed INOi… who knows when a response shall come.

Here’s what the saved text from Info Tool reads (I’ve seen pics, but I don’t know how to pull them):

Drive Information

Drive : HL-DT-ST DVDRAM GSA-4167B
Type : DVD-RAM Recorder
Firmware Version : DL12
Buffer Size : 2 MB
Date : ?
Serial Number : C05FE8FEB840
Vendor Specific :
Drive Letter : E:
Location : 2:0
Mechanism : Tray
Read Speed : n/a
Write Speed : 48 X

Read CD Text : Yes
Return C2 Pointers : Yes
Read CD-R : Yes
Read CD-RW : Yes
Read DVD-ROM : Yes
Read DVD-RAM : Yes
Read DVD-R : Yes
Read DVD-RW : Yes
Read DVD-R DL : Yes
Read DVD+R : Yes
Read DVD+RW : Yes
Read DVD+R DL : Yes
Read BD-ROM : No
Read BD-R : No
Read BD-RE : No
Read HD DVD-ROM : No
Read HD DVD-R : No
Read HD DVD-RW : No
Read HD-BURN : No
Read Digital Audio : Yes
Read CD+G : No
Read VideoCD : Yes

Write CD-R : Yes
Write CD-RW : Yes
Write DVD-R : Yes
Write DVD-RW : Yes
Write DVD-R DL : Yes
Write DVD+R : Yes
Write DVD+RW : Yes
Write DVD+R DL : Yes
Write DVD-RAM : Yes
Write BD-R : No
Write BD-RE : No
Write HD DVD-R : No
Write HD DVD-RW : No
Write HD-BURN-R : No
Write HD-BURN-RW : No
Buffer Underrun Protection : Yes
Mount Rainier : No
SolidBurn : No
Labelflash : No
Modes : Packet, TAO, DAO, SAO, RAW SAO, RAW DAO, RAW SAO 16, RAW SAO 96, RAW DAO 16, RAW DAO 96

Region Protection Control : RPC II
Region : 1
Changes User : 4
Changes Vendor : 4

If all else fails, I hopefully can exhume the functioning burner and cop an IDE cable, or just fill in using the old CD-ROM IDE cable… I guess for the extra money I got an INOi case that’s destroying the drive. (It was double the price, with a rebate that cuts it into 1.5x the price.)

In less they augmented the drive somehow… I should be able to remove it… correct?

Are there checks for the augmentations they might have done?

Thanks a lot for the help! (I loathe emo-to-cons, else there’d be some smiling decapitated head here.)


#6

That is definitely a LG GSA-4167B.

My guess is that they take whatever drive is in stock at the moment and put it in the same case to sell. Since most drives work in external cases, they figured it wouldn’t matter. That is why the drive inside might sometimes be a Lite-On.

I don’t see why that drive shouldn’t work as an internal device, seeing as that was what it was designed for in the first place.

It doesn’t look like they did anything firmware wise so any sort of modification would have to be hardware based. Unfortunately, there isn’t any way to figure that out until you open the thing up.

Yup. My guess is that it is just screws and detachable cables. However, you do have the option of returning the thing don’t you? If you manage to get one of these with a Lite-On inside instead, it should work. Or at least I assume it should work. I’m mentioning this because once you crack that case open, you might not be able to return it anymore so now is the time to decide.

No problem. It’s a pity you got stuck with this. LG does have external models that would have saved you quite a bit of hassle.


#7

Well, the only external case chipset that is guaranteed to work 100% with LG drives is a prolific chipset, and that’s with using LG’s brigdeboard firmware. Though, seeing as Buffalo has USB only external LG drives, other chipsets may work fine as well, but there’s no official data telling us which. As karranguni said, INOi most likely did not do any sort of research before putting this together, nor any R&D afterwards to confirm it would work. Though, there is the possibility that you simply got a defective drive, or a there’s an incompatibility with your USB ports (quite common, really). In fact, if you really wanted an external LG drive, you’re better off buying a known working external cae and the internal LG drive separately.


#8

FWIW (and archiving/searching purposes)… INOi e-mailed back to try the trial version of NTI CD & DVD-Maker 7… and it worked. (TYG02 DVD-R media with video files at 4x and 8x.)

Dang I feel stupid, as this seems to suggest I overlooked something.

I apologize for taking up any time here.


#9

No problem. The important thing is you got the darn thing to work in the end.