GSA-4120B malfunction

vbimport

#1

I bought a Packard Bell computer last october including a LG-Hitachi DVD recorder GSA-4120B.

Until 3 days ago, all works well, using Nero 6.3.1.17. Usually I burn x8 Verbatims and x4 Princo with really no problems at the right manufacturer promise speeds.

But I don´t know why I cannot burn any DVD faster than x2 speed in last three days, yes, ¡it takes 28 long long minutes to burn a single layer DVD!. But thats not all, even reading the unit has the same problem. With my PIV 3,2 GHz, 512 MB RAM, using DVD Shrink my 10-12 minutes speed reauthoring DVD´s, becames to 40 minutes now.

Using another recorder software (Sonic Record Now) I have the same problems.

The firmware is the last one, A103. The OS Windows XP. There is only this I/O device, not another device in the same IDE channel

I ask to the Packard Bell call center and the only solutions they give me is to restore all the system, and if the problem persists, then they change the unit. I think they´re crazy.

Never heard before a problem like this.

Has anyone any smart idea to solve it?

Thanks in advance


#2

Your drive runs in PIO instead of DMA mode probably. Check status of IDE ports in device manager!


#3

Firmware A103 is meant for the GSA-4163B. Shouldn’t you be using A115 for your GSA-4120B? Please check LG’s website for the correct firmware to use, apart from surg’s suggestion. :wink:


#4

For surg: the PIO was one of the first things I checked, and as you say is in PIO mode, but when I changed to DMA mode (IDE secondary channel, device 0) simply nothing change. I change “only PIO mode” to “DMA mode if is possible”, but go on PIO mode in the window “actually transference mode”.
What am I doin wrong?. How can I change to DMA mode?
Sorry for my rude English…


#5

@z1018
After changing transfer modes a restart is obligatory. If DMA is not working after restart try to delete ALL IDE ports and do another restart.


#6

Problem solved! As you told me I delete the Secondary IDE port and when the window were be closed the system detected new hardware and install the right controller (ultra DMA 4) automaticly. Not necesary to delete the other DMA port.

Thanks a lot for your help.
For mokky: there is no problem concerning the firmware, your are right, is the A115 the firmware of my recorder, I made a mistake.


#7

I hope some expert in this forum can give me some insight.
I tried to flash my GSA-4120B from A102 to A115, it turned out
“fail to update” and its firmware dropped to COR1. Since then,
My drive even can’t eject disk by pressing the button. I tried
different firmwares, but all have the same problem.

I also tried to flash several times, but after 1 to 2 times, the dvd
drive will be “kick out” from the system, I need to cold boot the
machine.

OS: Windows 2000 server
Chipset: VIA
IDE: 2nd master

Please help…

Duke