Gsa-4040b problems

hi everyone,its my first post in here so bear with me.
ive had a gsa-4040b multi burner for a while now and its suddenly decided to stop reading/writing or even accepting that there is a disk in the drive.
ive tried re-installing ect and updated my firmware but to no avail.
would anyone have any idea what the problem could be?.
im running an athlon xp 2100 with winxp pro,sb audigy platinum,ect.
i would apreciate any help:bow:

The drive sounds dead; but not always the case to confirm this the easiest solution is to take it out of the machine its in and try it in another machine if it still doesn’t work then there’s the answer but if it does work then there is some sort of conflict or problem on your machine.
Other things to check / try.[ul]Change the IDE cable.
Check to see if the drive is recognised by the bios and the bios settings are correct for this drive.
Have you installed any new software / hardware since the last time it worked.
Is the drive getting power. ie does the light blink when first switching the machine on.
Try deleting the drive and the ide channel that its on from device manager then reboot.
[/ul]