Going POSTAL trying to change to AHCI mode

vbimport

#1

OK, my SSD arrived so it’s “Time” to set AHCI mode before migrating to the SSD.

Where I’m at…

HP d5000T Pavilion Elite Desktop.
ASUS IPIBL-TX MoBo, Q9450 CPU, 8gb of system specific RAM

OS is a stable (15month old) installation of Windows 7 Professional x64 that I am NOT willing to give up on (Suggestions that I reinstall windows from scratch are so profoundly unwelcome as to defy my specifying them in detail)

Current system drive is a 100gb partition on a WD Black 500gb

making a system image and mounting that image to a new drive
I have a handle on…

Where I’m having a problem is switching the SATA controller
to AHCI mode.

I’m currently in RAID mode.

I’ve tried the Regedit in localmachine, (brevity prevents my repeating it in detail) changing the parameter from “3” to “0”, which was a complete waste of time as that parameter was already set to “0”…

I already ran the Microsoft Fixit (http://support.microsoft.com/kb/922976)
suggested by Dee, still no go…

What happens:
When I go into setup and change the SATA controller mode from RAID to
AHCI I get a flash of a BSoD then an invitation to run Startup Repair
I’ve both let it run it’s course (and it says it can’t fix it) and chosen a system restore (equally useless) and the only thing that makes the system restart is changing the SATA controller mode back to RAID

I’m doing all this to a CLONE of my system drive that works perfectly
(I’ve been running it for a week) but I really don’t care if I screw it up

I can switch back to the primary drive and have a working system just by moving a sata cable…

I really want to set AHCI mode BEFORE making a fresh system image and before swapping in the SSD
but so far all attempts have only succeded in raising my blood pressure.

Suggestions?

What is really going to drive me nuts is if I don’t NEED to switch to AHCI at all…
because several explanations of AHCI say that RAID enables it just as well…

I just want to be sure that TRIM works because an SSD without TRIM is like
a Ferrari without Lube oil… it’s a laugh riot… until the engine seizes… after that, not so much…


#2

Assuming you have the SSD connected to one of the native Intel SATA ports, you’ll have TRIM in RAID mode as long as the SSD is not part of a RAID array (set in BIOS as NON MEMBER RAID), providing you are using the Intel RST (Rapid Storage Technology) RAID drivers.

If you must have the system in AHCI mode, you could try removing the RAID drivers, then switch to AHCI mode in the BIOS and see if this helps.


#3

Dee,

No I have no RAID array setup. RAID-0 I wouldn’t touch with
a 10foot Pole (or an 11 foot Hungarian:)

And RAID-1 (the other alternative) does best at providing a false
sense of security, because i d oesn’t protect you from momentary
attacks of stupidity.

IF ONE of the online tutorials about migrating to an SSD and switching
these modes to AHCI had first suggested CHECKING the parameter
rather than making it a blanket statement to change it…

Or overtly mentioned early on that many RAID implementations
OR the required drivers for any “Advanced format technology” HDD’s
have likely already upgraded your SATA controller…

I would have been far less confused and frustrated.

More “Fun” Is what I went through avoiding using either “Ghost” or “Acronis”

But that I can correct by just running off another image from the 100gb partition on the (currently disconnected) with Acronis.

I used Clonezilla to clone the windows7 partition as an image to another drive then mounnted that partition to the SSD.

Contrary to what the person who worked out that procedure stated
Clonezilla DID NOT copy the “System Reserved” partition, so while
I got a clone onto the SSD it was not bootable until I ran startup repair
on it.

The “Adventure” with Clonezilla was all worth doing just as a learning
experience. there are times when knowing an unconventional way of
accomplishing something, generally when conventional methods fail for one
unexpected/unexplained reason or another.

But the things I did learn,
the partition clone with clonezilla followed by a startup repair DOES
produce a working installation, even with Win7 x64.

That this method eliminates the system reserved partition

That while Normally disc management will “see” another cloned drive
(even if “Windows” will not) but the drive will be marked as "offline"
due to a “signature collision” that without the system reserved partition
present my computer will not boot with any of these drives connected
in addition to the SSD…

I don’t have that figuired out yet, but as I was (eventually) going to format
both of my 500’s I can always delete the partitions and format them with another machine.

But I am running off the SSD.

I’m not where I want to be… yet… but I’m getting closer.

AD