GH22NS40: tray won't unlock after reboot

Hi,

I believe most of you guys are familiar with diagnostic boot environments like Microsoft’s Recovery Console, which is available from the Windows XP installation disc, the “Knoppix” Linux Live CD and the Sysinternals ERD Commander.

Such environments typically issue a software command to lock the drive, rendering the eject button unresponsive during the session.

In my experience this state expires as soon as I reboot the system by either pressing the system’s reset button (hard reset) or shutting down the boot environment with the appropriate command, like EXIT in the Recovery Console (soft reset).

However, it is not so with this particular drive. The lock won’t let go until I power off the system and press the power button to restart.

I haven’t gotten around to trying the drive in another system but I can confirm that an Asus DRW-2014S1T behaves normally in the same system.

Can anyone who owns the GH22NS40 reproduce the issue?

I have tried the drive in another PC. Same problem. A different LG model in that system behaves normally.

I’m still not sure if this is a one-off fault in my unit or a firmware bug.