GH22LS40 cant burn Iomega DVD-R 16x

vbimport

#1

Im not sure if this is the right area to post but anyways…

I just bought a LG GH22LS40 drive and a stack of 50 Iomega DVD-R 16 x to backup my drives. After I insert the Iomega Disc, windows freezes up for a bit then i every time i check the drive info, it freezes ( like its having a hard time deciding if it wants to read the disc or not). So if i don’t do that and just go to Nero 8, and try to burn anything, it comes up with a max writing speed of 2x and spits out the DVD after i press burn saying that the disc is not writable. (it says that the media is DVD-R so it detects what kind it is)

this model is supposed to burn almost any DVD short of blu-ray i think

(haven’t tried burning other DVD-R disc - will try tomorrow once i buy some)

Already tried:

  1. burning HP DVD-RW 4x - worked
  2. reading other DVD-R - worked - not sure what brand it is but it says DVD-R 8x
  3. uninstalling the DVD drives in Device manager - no help
  4. using diff burning software, Nero 7,8, IMG burn, Deep burn
  5. Safe Mode - just to check if ther is something conflicting - no help
  6. Tried looking for a firmware update - none whatsoever - i think this is fairly new so no updates yet.
    7.Cleaning the registry
  7. I wanna try to reformat but again I need to back up my drives first…:sad:

any ideas???