GGW-H20L unable to rip BD+ encrypted blu ray movies

I have the LG GGW-H20L it does everything except what I want it to do, rip blu ray! AnyDvd HD just gives me an error after 5 minutes of processing saying “Error reading from drive E” (Drive E is the GGW-H20L) I’ve also tried using Nero and BluRayBackup, both error out while trying to rip as well. Nero gets to a certain percentage then errors out, AnyDvd and BluRayBackup error out immediately. AnyDvd HD and my burner had no problem ripping Black Hawk Down and 300 (Columbia studios and WB) but the only reason it had no problem was because both of those movies were not BD+ encrypted only AACS.

I am ripping at 1x
Any Dvd HD: trial version, Updated to date 6.4.5.7
Burner:LG GGW-H20L (Sata) Firmware: YL05 (up to date)

Movies ripped unsuccessfully so far:

Pirates of the caribbean Dead man’s chest (Disney) AACS & BD+
Pirates of the Caribbean curse of the black pearl (Disney) AACS & BD+
Donnie Darko (Fox) AACS & BD+

Specs:

Windows Vista Ultimate 32 bit service pack 1
EVGA 132-YW-E179-A1
Intel Core 2 Extreme Q6850
Nvidia 9800 GTX video card
2 gig’s of DDR 3 Ram
1 TB Western Digital Hard Drive

Possible burning programs that are interfering:

Nero
Roxio
BluRayBackup
Power2Go

AnyDVD HD’s specs for Donnie Darko (In Bold are questionable problems.)

Summary for drive E: (AnyDVD 6.5.4.7)
HL-DT-ST BD-REGGW-H20L YL05 001002082F92594305
Drive (Hardware) Region: 0 (not set!)

Media is a Blu-Ray disc.

Total size: 22375360 sectors (43701 MBytes)
Video Blu-ray label: DONNIE_DARKO
Media is AACS protected!
Media is BD+ protected!
Removed AACS copy protection!
Removed BD+ copy protection!
Can’t determine region code!

Try 6.5.4.9 (anydvd)

Nope, no luck.

Are you allowing anydvd internet access to get the keys it needs?

I am using a trial period, and have internet access on at all times, but how would I check if i am or not?

buy the software

I’m not going to buy it until I know it will work… The trial is the same exact thing as the real copy so it would be a waste of money for me until I know it will rip successfully.

Problem has fixed itself. Went to try again this afternoon and miraculously it worked. The only thing I changed that i can remember is that i installed makemkv and dvdfab. Maybe they installed some necessary codecs, drivers? Who knows.