Ggc-h20l plays BD but does not see any discs in Explorer

vbimport

#1

I have a GGC-H20L blu-ray ROM (HP version, firmware 1.07) and it behaves really strangely. It cannot read any CD, DVD, or BD discs in Windows Explorer (I use XP Pro), but it can play BD discs in PowerDVD 10. I’m fairly certain it isn’t supposed to do that because it is a DVD burner as well as a BD-ROM. It’s really strange that it can play a BD but not allow me to see the files on it. Any suggestions? The drive isn’t under warranty.


#2

Have you tried deleting the upper and lower filters? http://pcsupport.about.com/od/driverssupport/ht/upperfilters-lowerfilters.htm


#3

Thank you for the suggestion. I deleted the upper and lower filters - no effect. I’m 99% sure it is a hardware problem with the drive, as I tried booting from an Ubuntu CD in that drive and it did not recognize the disc either. It is so bizarre though, it can play BD in PowerDVD no problem yet Windows Explorer claims every disc is unreadable. I’m going to make 100% sure it is the drive by installing it into another computer.


#4

To which controller is it connected and how is that controller set up (check in the BIOS)?


#5

It’s hooked up to the regular SATA controller on my motherboard (P5Q-E). I confirmed it by hooking up the drive to my Phenom quadcore computer (M2A-VM) - same thing happens. It has to be the drive - I have a SATA DVD burner hooked to the P5Q-E motherboard and it works fine. Are there separate lasers for the Blu-Ray and DVD/CD on this drive?


#6

Yes, there are separate lasers for them. Have to be since blu ray uses completely different spectrum.

DVD drives have separate lasers for dvds and cds also.