GGC-H20L Device cannot start (Code 10)

vbimport

#1

My apologies if this question has already been asked and answered, but I couldn’t find it. I’ve got an LG GGC-H20L installed in my Vista SP1 machine, but it is unable to start for some reason. It shows up in the Device Manager, but the following error appears:

This device cannot start. (Code 10)

The computer is a beefy Dell Precision 690 workstation.

Any ideas on the problem and (even better) the fix?

Thanks!

–Jim.


#2

Incidentally, I’m seeing posts with “Please Help:” in front of them – should I post this some other way?


#3

[QUOTE=feckman;2148130]Incidentally, I’m seeing posts with “Please Help:” in front of them – should I post this some other way?[/QUOTE]

Patience is a virtue, if someone knows he or she will help you.


#4

Go to Device Manager > DVD/CD-ROM drives > and locate your LG. Is there a yellow explanation mark there? If yes, right click on the LG and Uninstall. Then reboot so windows will re-detect your LG drive.

Please report back.


#5

[QUOTE=vroom;2148156]Patience is a virtue, if someone knows he or she will help you.[/QUOTE]

Sorry about that – I just wanted to be sure I wasn’t breaking forum etiquette. :slight_smile:

–Jim.


#6

[QUOTE=zaina;2148201]Go to Device Manager > DVD/CD-ROM drives > and locate your LG. Is there a yellow explanation mark there? If yes, right click on the LG and Uninstall. Then reboot so windows will re-detect your LG drive.

Please report back.[/QUOTE]

Thanks for your reply! Yep, yellow exclamation point is there. I uninstall, reboot, it detects the “new” hardware and tries to install. In a minute or so I get the “Device driver software was not successfully installed” notice. Clicking on that bubble presents the following info:

"Please consult with your device manufacturer for assistance getting this device installed.

HL-DT-ST BDDVDRW GGC-H20L ATA Device Failed"

I did speak with LG yesterday (twice) before posting this message. Both techs claim the issue is with Windows and are therefore unwilling to help. When pressed, one guy did suggest the following MS Knowledge Base article:

http://support.microsoft.com/kb/929461/en-us

I tried deleting the upper and lower filter settings to no avail. In fact, now iTunes can’t burn CDs on my other drive.

Thoughts?

–Jim.


#7

I use a 690 at work and IIRC, the onboard SATA controller is SAS-based. It may or may not work properly with SATA optical drives. If you aren’t running RAID hard drives, I suggest to change the controller to ATA/IDE mode. There are quite a few controllers listed in the BIOS, so it may be a trial-and-test method.


#8

[QUOTE=KTL;2148416]I use a 690 at work and IIRC, the onboard SATA controller is SAS-based. It may or may not work properly with SATA optical drives. If you aren’t running RAID hard drives, I suggest to change the controller to ATA/IDE mode. There are quite a few controllers listed in the BIOS, so it may be a trial-and-test method.[/QUOTE]

Hmm…interesting. I am running a RAID configuration, but it’s only on the main channel, I believe. I’m not really sure how this machine is set up, but there are an awful lot of SATA connectors on the motherboard.

I know the four “regular” ones are set up with two sets of mirrored drives, but there’s a whole other bank of SATA connectors, and this drive is the only one on that “bank” of connectors.

Do you know if you can selectively enable/disable that way?

–Jim.


#9

I know my workstation isn’t running RAID, but do have two drives connected to the controller, and there were 4 spare black SATA connectors. I tested a SATA DVD/CD optical drive, not a BluRay/HD, and it seemed to respond ok when it was set to ATA/IDE mode. It seems that bank of connectors may be separate from the hard drive connectors.


#10

[QUOTE=KTL;2148769]I know my workstation isn’t running RAID, but do have two drives connected to the controller, and there were 4 spare black SATA connectors. I tested a SATA DVD/CD optical drive, not a BluRay/HD, and it seemed to respond ok when it was set to ATA/IDE mode. It seems that bank of connectors may be separate from the hard drive connectors.[/QUOTE]

Cool! Well, I’ll do some trial and error and see how I make out. Thanks for giving me someplace to start!

I’ll report back shortly.

–Jim.


#11

Bingo! We have a winner! Switching to ATA mode seems to have done the trick. The SAS controller is a separate thing on the 690, so I haven’t noticed any ill-effects as a result of the switch.

Thanks so much for your help!

–Jim.


#12

Glad to hear it worked! :slight_smile:


#13

[QUOTE=feckman;2149046]Bingo! We have a winner! Switching to ATA mode seems to have done the trick. The SAS controller is a separate thing on the 690, so I haven’t noticed any ill-effects as a result of the switch.

Thanks so much for your help!

–Jim.[/QUOTE]

It is ready some time ago, but i have now a similar problem. Can you tell me where in the Bios and how you changed anything?


#14

Hi and Welcome!

since any motherboard has its own feature set, you’d better check the manual of your motherboard.
You are looking for settings that influence the Sata operation mode.

Michael


#15

thanks for quick reaction. motherboard is asus p5qpl-vm epu. but i fear to be not able enough to find what to do! where do i have to look for?


#16

Go through the Bios chapter of your motherboard manual. There should be an option to configure the Sata controllers. Don’t touch the settings if you are running a Raid configuration with at least two HDDs.

Michael