Getting win98se to recognize my 3520a

vbimport

#1

Hi everyone…I’m new to the forum so please let me know if this should be in the general DVD recorder forum or a different forum.

I’m trying to get my old dinosaur of a computer (running win98SE) to use my NEC 3520A CD/DVD burner. Below is a description of the setup and everything I’ve tried that has failed so far (the good folks at PC Perspective referred me over here after several attempts to help):

I have a generic USB 2.0 PCMCIA card with NEC uPD721100 chipset. The card installed without difficulty with some drivers from windows and some from the accompanying CD. My device manager now looks like this, so it seems that it installed properly:

The drive is in a generic enclosure which also has an NEC chipset. The enclosure manual says that the drive must have the jumper set to “master”, which it is. The manual says that if USB 2.0 drivers have been properly installed, one only needs to install the USB Mass Storage driver for win98SE. There’s a tiny (44k) executable called Necutray.exe on the CD that came with the enclosure (it’s identical to the CD that came with the PCMCIA card). I’ve run the executable and an hourglass appears for a fraction of a second, then nothing happens.

Upon connecting the drive/enclosure to the USB 2.0 port, win98 opens a window that says it’s detected a USB 2.0 device and it wants drivers. When I tell it to search for drivers on the CD and on windows update, it finds nothing. When I direct it to the CD, it finds two .inf files (I’m pretty sure that one is the driver for the PCMCIA card, and the other is the USB Mass Storage driver); if I select either one, windows tells me “the specified location does not contain information about your hardware.”

So I’m stumped. Someone suggested trying a different device in the enclosure, but I don’t have a hard drive or anything, nor do any of my housemates.

When looking to see if others had this problem, I came upon this article: http://www.theinquirer.net/?article=9856 in which the author suggests trying these drivers: ftp://www.siig.com/USB2.0_v2.06.exe . I tried those too once I couldn’t get the drive working initially. But still no luck.

According to posts at pcper, others have used USB 2.0 drives in 98SE without a problem, so the problem is solvable. Any help would be very greatly appreciated!


#2

This is a long shot, but if you are sure that the INF’s on the CD are the correct ones, you could try installing them by hand by right-clicking on them and choosing “install”. Connect your drive to the pc before doing this.

Which company is your enclosure from?


#3

Not sure if you have done this, but you also need to install the USB Mass storage safe-removal fix for win 98 (SE) - otherwise when you get things working you will have immense problems trying to safely remove them - and detection also does not work properly in my experience.


#4

TommyCP: I tried what you suggested, but no luck. The enclosure is generic with a NEC chipset.

icey: I installed the USB mass storage support for win98 that came on the CD with the PCMCIA card. Is that the fix you mean, or is there something else? If so, could you direct me to where I could download it (it wasn’t obvious from googling “usb mass storage safe removal 98”).

Still no luck getting it working. When I plug in the drive, windows still detects new hardware (a USB 2.0 device) and wants to install drivers for it. Several questions if you guys can help:

[ul]
[li]When I plug in the drive, what should happen?
[/li][li]Should win98 ask for drivers?
[/li][li]If so, where should they be located?
[/li][li]Who would provide the drivers? (The drive came OEM and NEC doesn’t provide drivers on their website. The drivers for the NEC drive aren’t available on the CD that came with the enclosure or the PCMCIA card)
[/li][li]How will I know when win98 recognizes the drive?
[/li][li]Right now in my task bar there’s the icon that has an arrow over a rectangular thing. Does that mean it recognizes the drive?
[/li][li]If so, how do I get it to appear in My Computer? (even being able to read a CD would be a huge success right now)
[/li][/ul]

Those who’ve gotten a USB2 burner to work with win98, where did you get the drivers and what was the process of getting it to work?

Thanks so much for the help. I’m very grateful for the support.


#5

nevermind read your first post a little quick.


#6

kamikazee: I read your original post before you edited it. I assume then that my motherboard does support USB2 considering the PCMCIA card installed properly and the device manager shows the USB 2.0 root hub.

Otherwise, how exactly will I check whether my motherboard supports USB2? I’ll still check the intel site and see what I can find for my chipset.