Getting a 3tb drive recognized?

vbimport

#1

Finally bought a large drive, a WD 30EZRX drive…

Only problem is that on my Windows 7 x64 system when the RAW
drive is installed in the system and GUID selected it only shows as a single drive of 746.39Gb.

I’ve “cleaned” the drive returning it to it’s RAW state via the command prompt twice and can get to see the full drive only when connected to the computer via a USB2.0 enclosure.

In an eSATA enclosure I’ve managed to only see a 2Gb partition

I was under the impression that 3tb drives were not an issue with x64 systems.

I don’t want to run this drive in a USB2.0 enclosure and don’t have a USB3.0 enclosure available to me right now.

I’d dearly love to see the full drive as an internal drive, but I’m thinking
that isn’t going to happen on this system.


#2

I believe that you need to initialize as GPT, if not you will only get 2TB.

What is your motherboard?


#3

[QUOTE=vroom;2689492]I believe that you need to initialize as GPT, if not you will only get 2TB.

What is your motherboard?[/QUOTE]

If memory serves me, you need to delete the volume that shows up under the disk management tool and then format using GPT/convert disk to GPT.


#4

GUID is the other name for GPT, so I did that.

I did that the disc is already GPT and shows as 746.39Gb UNALLOCATED

The Motherboard is an ASUS IPIBL-TX running a Q9450 CPU.

I can only see the whole drive, but as two separate partitions Via USB.


#5

Since this is the motherboard belonging to a relatively nice but still not exactly new HP system…

Neither the ICH9 southbridge nor Win7 64-bit should inherently prevent you from properly accessing the 2.7TB (as to be reported by Windows). It’s likely drivers or BIOS limitations, if not some formatting quirk.

Check to see if HP has any BIOS updates. If so, you might find support there.

While we’re on the topic of the motherboard setup itself, check the BIOS setup to see if the motherboard detects the full capacity of the drive. Or you might see an option to switch the SATA controller between legacy/IDE mode, RAID mode, and AHCI mode. If not, then HP may have requested those settings be locked down, and there’s no sense worrying about them.

Ensure all the proper Intel drivers are installed and updated to the latest version. This may help you see the full size.

If all else fails, you may be stuck getting a SATA controller card with proper support for 2TB+ drives. (With the right card, performance should be just as good as with the Intel-sourced SATA ports).


#6

I got it to recognize the drives full size about three hours ago.

I reinstalled the latest version of Intel’s Rapid Store Technology, their
new name for their storage management drivers.

I’d done this before but it seems my system “rubber banded back” to an earlier version of Intel’s matrix storage manager

And having done that I FINALLY persuaded my system to allow me to switch from the default RAID mode to AHCI… but there was a wrinkle to that, going from IDE mode to AHCI the Microsoft FixIt #50470 works, but going from RAID to AHCI
has flatly refused to work… until I read another suggestion on the M$ forums to go into the registry and reset the start value of the atapi driver to 0.

It finally got my SSD booting at the proper speed…

But these system changes also triggered something I’ve never seen on an HP computer… the need to reactivate windows. fortunately that went smoothly
if it hadn’t I’d be trying to figure out how to make Redmond Washington disappear from the face of the earth


#7

[QUOTE=AllanDeGroot;2689508]
But these system changes also triggered something I’ve never seen on an HP computer… the need to reactivate windows. fortunately that went smoothly
if it hadn’t I’d be trying to figure out how to make Redmond Washington disappear from the face of the earth[/QUOTE]

Linux or Mac OSX are candidates…


#8

I have to use too much windows software to be hamstrung by running MAC OSX

or crippled by being forced to write my own Linux software.

And I can’t fault Microsoft for want to make sure they’ve been PAID, I think
they are a bit over protective… why should switching my computer’s
SATA controller from RAID to AHCI mode trigger a reactivation request?

AD


#9

Windows registered you switching the mode between IDE/AHCI/RAID as a hardware change.

Keep in mind that each operating mode results in the ICH9 reporting its SATA controller with a different device ID. Also remember MS devised a way to count certain hardware changes as being more significant than others.

This particular “hardware” change happens to be a significant way of identifying the hardware being used (and, thus, the system being used). The additional registry edit probably counted, too. When you switched rapidly in such short time, Windows counted down through its acceptable number of hardware changes fairly quickly. [Summary: too many changes, too little time between changes].

But as you see, it was easy enough to reactivate. Even if you were forced to reactivate over the phone, it would have been okay. Unfortunately, there’s no easy way to avoid this nuisance.


#10

I did have to activate over the phone (the automated system) but I consider doing that “normal” because an activation actually working automatically is something
I typically only see working correctly on Dell hardware.

I can count on the fingers of one hand how many times “automatic activation” or “Activate Now” has worked.

and if I actually enter the CoA at the beginning of an installation that makes it certain that the subsequent activation is going to be a PITA.


#11

Ohhhhh… I see.

Oh, the lengths they go to prevent piracy. :rolleyes:


#12

They likely pay more overall to provide HUMAN customer service to people who have problems with activation than they actually lose to “piracy”

And people having problems irritates many of them sufficiently to make them switch to piracy to “Get even” for the lost time, plus the obvious annoyance…


#13

BTW, if anyone else runs into the same issue with getting a SATA controller set in RAID mode into AHCI mode and the Microsoft Fix It doesn’t work, the specific regedit is discussed HERE:

http://answers.microsoft.com/en-us/windows/forum/windows_7-hardware/changing-from-raid-to-ahci/4c94f678-6bd1-48a6-b871-8872c841023a?page=2

You want to read reply #7, it’s marked with a big green “ANSWER”

The Microsoft Fix It < http://support.microsoft.com/kb/922976 > will then work
and you’ll be able to go into setup and change your sata controller to AHCI mode.

AD


#14

A screenshot of that post (because you never know when links may break):



#15

My Asus board recognized the 3tb drives and formatted GPT to 2.7G without much problem on the W7x64 Sp1 O/S. And my board was from 2009 with the latest BIOS updated. I have like 7 3tb of which 4 are on Raid/Sata card and formatted while connected to the card for GPT format and the other 3 3tb on my board sata formatted to GPT without any problems. Besides this I have a 500G main and 2TB, 1TB black WD drives in my complete system/NAS and it works fine formatting the 3tb drives.


#16

Drives on RAID controllers, USB controllers and eSATA controllers are generally “seen” by the operating system and the computer as “SCSI Devices”

I could get the computer to “see” the full volume of the drive on USB but for some reason my computer was “running” on an older driver than I had previously installed

I had previously installed the latest Intel Matrix Storage Drivers and had also installed a prior version of the INTEL Rapid Store Driver that replaced Matrix Storage Manager.

Yet no trace of either was found on the system… I suspect some previous “System repair” had wiped it… otherwise I wouldn’t have had any issue getting the drive recognized. Then again without this “problem” I wouldn’t have done further searching about getting the SATA controller switched from RAID to AHCI mode.