Gateway AR-230 to LVW-5001 Hacked, Misflashed Drive...Success!

vbimport

#1

Hello…first post in this community…

First, thanks to all of you who’ve offered your guidance with the update I’ve done to my Gateway AR-230. The advice has been invaluable and I appreciate all the help.

I bought a Gateway AR-230 (which, as I’ve read, is a rebranded LiteOn LVW-5001) on eBay last week…it arrived with no remote…I picked that up at Litetrek site (http://store.litetrek.com/) for $14.99 and I was off and running…the unit came with the 1143 firmware (the third set of numbers in the serial number visible when in the “setup” screen was 1143.) The 2-9-6-0 code to hack the region free did work fine, but the unit was macrovision protected and didn’t offer a 3-hour recording mode…I decided to hack the firmware.

I downloaded the ilo hacker program from http://ilohacker.tripod.com and then found firmware for the drive…I went to Gateway’s site and downloaded their firmware, but the file I downloaded was an executable file (ending with .exe) so I ran the program, which unzipped the original download and created a folder on my C: drive called “cabs.” In this folder was a Gateway firmware upgrade (I think it was GWEA1086.exe) and the instructions stated to burn this to a CD for the firmware upgrade…I ran it through the Ilo Hacker program and it hacked it successfully, but the AR-230 only saw this as a data disc no matter what I did. I decided to download a LiteOn firmware upgrade, but the LiteOn site wouldn’t accept the serial number from my machine (obviously because the serial number identified it as a Gateway.) I found firmware for LiteOn at http://www.digitalfaq.com/dvdguides/buyerguides/dvdrecorders/liteontips.htm
and downloaded the LiteOn 1163 firmware and hacked it using Ilo Hacker, but the AR-230 still read it as a data disc. I then changed the file name from LNEA to GWEA and it took!..or so I thought…it asked if I wanted to update the firmware…I clicked OK and it started…I then got an error message telling me to contact support…after this, no matter what I did, I got a “put CD in” message but nothing worked.

The next day I downloaded the hacked 1163 firmware from the same page again and kept the LNEA file name, and it worked…it upgraded the firmware, but there was no splash screen visible on the TV…it just said F - UP on the unit lcd display (which I assume is Firmware Upgrade) then it said D - UP (which I assume is Drive Upgrade.) When it was completed, the unit repowered and started up with a LiteOn welcome screen on my TV. I was elated!

I then discovered that this upgrade has misflashed my drive! No matter what I put in the drive, I got a “no disc” message…I was crushed! I then did some Googling for drive replacement or reflashing.

I took my NEC-1300a out of my Dell desktop to try it. I removed the LiteOn DDW-451s drive from inside the DVD Recorder and plugged the IDE ribbon cable and power plug into the NEC unit…voila! It worked fine…I tested it with a few different DVD’s.

I didn’t want to have to throw out the DDW-451s, so I decided to try and repair it with the flashing program. I downloaded a flashing program from LiteOn, but it wouldn’t flash my drive, since it only offered firmware for the LDW-451s…I thought since the numbers were so similar, it might work, but to no avail…

I then downloaded the Liteon Flashing Tool here: http://upload.cdfreaks.com/ftools/LtnFW.zip

I then found the binary firmware file for the LDW-451s (I looked and looked for a DDW-451s firmware but couldn’t find it anywhere!) and downloaded it from http://dhc014.rpc1.org/Files/DVDR/LDW-451S_GSBAb.zip

I hooked the DDW-451S into my PC. I then ran the LiteOn Flash Tool (LtnFW) and ran a checksum on the drive…it was now showing up as a DDW-411S (I guess this is a result of the firmware I had loaded…it misflashed my drive and that firmware wouldn’t work…)

I used the LtnFW program and chose the LDW-451 binary file I downloaded to reflash the drive (I checked the Update Boot box as well) and it successfully flashed the drive to a LDW-451s.

I then replaced the LiteOn drive into the case and voila…it worked…well, kinda…

The DDW-451s and LDW-451s have an obvious difference…the polarity of the DVD drawer mechanism…I couldn’t get it to open or close unless i did it manually (open the drawer by pushing in on the small semicircular depression under the DVD drawer towards the left side…) but when I did it manually, everything worked…read the discs, recorded, etc…I remembered reading about reverse polarity on here before, so I decided to switch the plug on the drawer mechanism…(the small white plug with red and black wires directly under the drawer at the right side)…I used a small hemostat (like scissors, but it locks like a clamp) to hold the plug, then used a razor knife to remove the raised plastic on both sides of the plug (these raised areas are designed so that the plug only goes in one way…) Once I cut away (carefully) these raised areas on both sides, I was able to plug it back in reverse…sure enough, when I powered it back up, it worked perfectly!

I buttoned everything back up, and now my AR-230 has become a LVW-5001 with 3-hour record mode, region free, and no Macrovision (I recorded from a Disney tape today no problem…the AR-230 originally gave me a “protected content” message and wouldn’t record it.)

The only thing that was tough was figuring out how to remove the DVD drawer front and to replace it…once I figured it out it was simple…to remove the drive, open the DVD drawer then unplug the unit so it stays open. Carefully tilt the drawer front up from the bottom edge and lift up and it will pop off the drawer…to replace it, just do the reverse…slide the ends of the drawer front down onto the tabs, tilting it back forward and it will pop on…if you take the time to look at the tabs, you’ll see where it needs to go…also, when I replaced the drive I had to adjust the four screws holding the drive down until the drawer protruded through the opening just right…the first time it caught just a bit…

Hope this helps somebody else who feels desperately sick about upgrading their firmware and creating a large paperweight…I’ve brought my AR-230 back from the dead!

Happy Recording!
Pete in Connecticut


#2

Just wanted to say a quick thanks to Mr. Wizard for developing the Ilo Hacker program and Guitarman for making it available on his site…I made a small paypal donation to Mr. Wizard, figuring that with all the morons selling his program on eBay, he might as well get some of the monetary thanks…

Pete


#3

So Pete… knowing what you know now, how would you recommend doing this if you had to do it over again?

Thx!


#4

I would be sure that I was only updating my system firmware and not altering my drive firmware as well…the downloads from LiteOn’s website offer firmware for system and firmware for drives…make sure you’re only updating the system firmware as the drive update might alter your drive…especially if you’ve “changed” from the Gateway model to the LiteOn firmware…


#5

Pete, using your experiences and advice, I hacked my AR-230, but am not sure the MacroVision has been removed successfully. I just tried to record my (legally purchased) commercial VHS copy of Jungle Book and I’m not getting any messages that the material is copy protected, but the AGC is causing the luminance and chroma to oscillate between a bright and normally colored picture to a dull and very red picture.

Does this sound like the MV is still active?
Anyone???


#6

I found the problem. Yes, the MV filter was still active in the signal path, but it’s AFTER the AR-230. I just made a copy of Jungle Book and it works fine on all of our other players.

For those interested in the cause…
Since the coax out is only a passthru connection for the RF and doesn’t display the prompts or menus, and since I’m using an old TV for dubbing which only has a coax input, I’m connecting the composite and audio out to an old VCR and using its RF modulator to drive the TV. The VCR is detecting the macrovision signal and trying to “scramble” it, so what I see on the TV appears to be that the AR230 isn’t doing its job when it really is.


#7

I’m sorry for resurrecting such an old thread, but I do have a related question…

I modded my AR-230 with heatsinks and a (rear-internal) fan which draws in external air and pulls it across the area where the heatsinks are. I also drilled one hole in the bottom so a small air stream is keeping the underside of the circuit board cooler.

Everything’s been working fine for nearly 2 years, but I’m beginning to get concerned about the drive itself and apparently the 4xxS drives are no longer available.

Has anyone tried any newer drives to see if they’ll work? If so, which brands/models???

Thx!


#8

A drive from the list at http://club.cdfreaks.com/f102/replacement-drives-liteon-5xxx-recorders-207698/ should work if it’s a rebadged 5001. The drive that FiremanPete replaced in his recorder is the same drive I replaced in a 5005 recorder. BTW there’re links to purchase the Memorex MRX-530L at http://www.google.com/products?hl=en&q=Memorex+MRX-530L&um=1&ie=UTF-8&sa=X&oi=product_result_group&resnum=4&ct=title which is a working replacement burner according to post #180 of the first thread in this post.


#9

BTW also found the Sony DRU-7190A for as low as $25 which is also another good replacement according to post #200 in the first link of post #8 above at http://www.google.com/products?hl=en...num=1&ct=title. However, user in post #200 doesn’t state whether the Sony DRU-7190A erases RW discs in the LiteOn recorder. You may want to PM that user to check if that feature is important.


#10

Sweet!!!

Thanks. Btw, I did do a Google search and after an hour of searching was frustrated b/c all I found was the 4xx options. Ironically, I didn’t think about using 5xxx in my search terms.

Live-n-learn! (At 43, it’s still my motto.)