Gapless Audio CDs - Here's How

ok,i found another program that will do the gapless job easily…and it’s free. should have thought of it sooner, but i have not used it for a looooong time. it’s burnatonce. get it @ http://www.burnatonce.com/. install it. start it. go to settings/device settings. under Write Settings choose the drive you will be using to burn the CD then set the options as in the screenshot below

http://drugoverdose.250free.com/Files/001.jpg

now go to settings/options. in general you want the below settings if you have aspi installed. if no aspi is installed on your system then keep spti checked

http://drugoverdose.250free.com/Files/003.jpg

and in audio mastering you want

http://drugoverdose.250free.com/Files/004.jpg

now apply/ok

now go to mastering/audio cd/add files. choose your audio files and add them to the playlist.

http://drugoverdose.250free.com/Files/005.jpg

now you can right click on a title, choose track properties, and set any preferences you like, but for now DON’T change a thing.
http://drugoverdose.250free.com/Files/006.jpg

now click on compile. insert a blank CD into your burner [if you haven’t already] and click on Write.

why? it does nothing to remove the silences…

Roxio CD Creator.

Does it remove the pauses inside MP3?

it’s burnatonce.

what does it do to remove the silences?
Last time I tried, it did nothing.
It burned the tracks like they were stored, which is what a good program should do…

The correct way is what you said about Foobar2k, or removing the silences manually and burning with Feurio (or Samplitude, Sequoia, etc)…

O ye of little faith ! burnatonce works. try it and be amazed…

well, I’ve just tried the last version with Wavgain as you pointed, and there are still gaps…

The 1st image below has a gap more than 1000 samples long (2 sectors / 30 mseconds). It’s not very easily perceived but I can hear it…
Probably Foobar2k can do a better job…

The 2nd image shows the same zone for Feurio! without editing anything.
The gap is slightly shorter than with burnatonce but it’s still there.
You still have to manually remove it if you want nice discs.


With Feurio! standard (just “no pauses between tracks” setting):


thanks for those comparisons. good work. gives me some ideas. note that i post the burnatonce method as a free alternative only - not because i believe it superior to other methods :wink:

What about “MP3Trim”? http://www.logiccell.com/~mp3trim/

I encode to MP3 using LAME - through EAC. I don’t burn the MP3’s, but do transfer them to my 40Gb iRiver. I have also used WavTrim in the past, which removes the gaps from shows mistakenly burned TAO - but I haven’t used MP3Trim yet.

I also have an issue with gaps, and wonder if anyone has used a programme like MP3Trim successfully? I’m prepared to pay the £22-odd for this, as most of the discs I decode are DAO-burned live shows.

Any endorsements for MP3Trim out there??

i have used nero and foobar 2000 an ther are still gaps at the end of the tracks can any one help me ?

Nero automatically inserts AT LEAST a 2-sec gap between each *.cda and *.wav file I add to a compilation. I can change it to zero, but Nero changes it back to 2-sec.

possible reason for silence or gaps still between tracks even after using nero, foobar/nero or burnatonce is that your audio files have silence at begining or end. let’s clear up a possible confusion - the nero, foobar or burnatonce methods will work to remove the 2sec gap that burning apps often place between tracks, but they WILL NOT remove silence from the begining or end of the audio file/s itself. for that you will FIRST need to process the audio files with an audio editing/processing app THEN use the nero/foobar or burnatonce method to create your audio cd

but in nero i have clicked on the remove silence at the end of the track and it still dont work also any ideas for removeing the gap from the file manuly ? :slight_smile:

but in nero i have clicked on the remove silence at the end of the track and it still dont work also any ideas for removeing the gap from the file manuly ?

Yes, Nero is a poor program for audio burning.
The “Remove silence at the end of *.cda tracks” option doesn’t work.
It does nothing. You will get the same disc whether you enable or disable it.

The best program to manually delete them, is Feurio!
Open the Track Editor and use “Set start position” and “Set end position” to select the beginning and end of tracks.

If the tracks are MP3 files, then decode to WAV first (better done with Feurio), because the resolution of the zoom is better displayed for WAV files and not MP3.

I can change it to zero, but Nero changes it back to 2-sec.

Yes, it has been said several times that Nero is a limited burning program.
Use something serious like Feurio!
It will remember all your settings for the next session, including the position of all windows or menus… something so trivial but that Nero hasn’t been yet to do it.

Feurio will burn all your discs in DAO mode and with zero seconds pause. You don’t have to remember to do this for every disc anymore.

i will try that so how do you set the start time and stop time ?

Imagine you have a track with 3 tenths os silence at the beginning.
Drag and drop that track in a new Feurio CD-Manager project.
Press “Track Editor”.
Place the mouse in that track and “zoom” the beginning of the track.
“Zoom” the beginng, and press the left button once in the “3 tenths mark”.
Press “Set start position” (“Action” menu), and the zone before the cursor will be deleted.

The same for end of the track and “Set end position”.

EDIT: Of course, don’t forget to choose “No pauses between tracks” option for “Settings” of the project, the 1st option. You will only have to do this one time: it will be remembered for the following times.

You can hear the result before burning by pressing the “Play” button to play the project: “What You Hear Is What You Get”

that dont work it wont cut off the bit at the start or the bit at the end whot am i doing wrong :confused:

I don’t know: I’ve done it a lot of times and it works if the tracks are independent files.
If you ripped the tracks with Feurio!, you might get linked tracks (several tracks in only one WAV o MP3 file). If that’s the case, then “Set end position” will only change the position but it won’t cut the end.

If every track is only one file, then make sure you have chosen “Do not insert pauses between tracks - round track markers” instead of the default “2 seconds gaps” when Feurio is installed.
Select your project and press “Settings” of the project to make sure this is OK.

If they are MP3 files, make sure you have decode them to WAV, due to the limited precision when viewing MP3 files in Track Editor.

Big thanks for all the info, Ghosters and minix.

Nice to know that all the great info from old threads still survives.

It’s easy to burn a CD with no gaps, using Foobar2000 only.

Get the Special version of Foobar2000.

Enable the “Gap Killer” DSP plug-in.

Now use the “Audio CD Writer” component, with “Use DSP” checked.

Done.

Yeah I’ve found this. After reading about Foobar2k on here I gave it a try, has been the best program so far for burning something gapless. Its still not flawless, on checking some Funki Porcini, Prefuse 73 and Masters At Work blends between track, its ever so slightly jumpy. But its still the best translation I’ve heard so far. Naturally this means that if you’re trying to burn a mixed CD, you’re a bit scuppered really since volume is going to be pretty constant throughout the CD…

Shame, kinda exposes mp3’s as a bit of a shocking musical medium really. Almost assumes that people won’t quite need the beginnings and ends of the tracks. I’ve mastered up my own mixes on Soundforge, split tracks out and burnt from wavs and never had a problem using Nero, just a shame that the entire world trades in mp3s. I’ve never managed to stumble across anything Flac or Wav based at all.

I resort to sharing my own mix CDs by just ripping them as one long mp3. Not great if you want to go track skipping, but then you get the quality instead.

Been through so many different programs to try and resolve this, no joy as of yet.

Even decompressing the mp3s into Soundforge and pasting them together doesn’t work. Mp3s just seem to lose the plot at the end of a track!

You can have one large MP3 and still be able to navigate between its component tracks. Ever heard of CUE sheets?
There are plenty FLACs traded about, you only have to know where to look.