Gapless Audio CDs - Here's How

Required Software: Nero Burning ROM and FooBar2000 Special - links below.

http://www.foobar2000.org/foobar_special.exe
or go to
http://www.foobar2000.org/download.html scroll to the last listed foobar version…ie., special edition.

If you do not have Nero installed, download and install Nero Burning ROM. Trial versions from www.nero.com

Ok, let’s do it. Ever noticed there’s always a noticeable gap between tracks when you try to make an audio CD from MP3s ? Even after removing the ‘2 second gap’ option in your favorite burning software there’s always a noticeable pause between songs, especially when you’re listening to a live CD ? Well, there IS a way to burn CDs without any gap at all. Thanks to Phreak144 for the tip !

Here’s how:

Download and install Foobar2000 special edition. You need to install the special version because it has extra plugins. After installation close Foobar2000. Insert a blank CD. Restart Foobar 2000. Click on Playlist at the top, add the MP3s files you would like to burn. Highlight all the MP3s and right-click on them. Select Write audio CD. That should be it, the default Foobar2000 settings will write a completely gapless audio CD for you. Don’t believe it ? Test by burning the same files with another audio cd burning program, nero or roxio etc., and you will sure notice the difference !

Tip: you might want to volume normalise the mp3’s [recommended if you are compling an audio CD from various mp3s…sinlges etc. But not if the mp3s are all from the one album/CD] BEFORE writing to CD. … even though foobar has a replay gain option ,that i assume is meant to volume normalise the mp3s, i have found it does not work when enabled. IF you don’t have a program to do this i recommend MP3 Workshop. Get it @ http://myhome.iolfree.ie/~mp3workshop/ . Ignore the “List index out of bounds” warning went it starts. Use the Options/processing settings dialogue to set your preferences. Then you choose Queue/Add…and be sure the MP3 to MP3 tab is enabled if you are about to process/normalise the files you have added to the queue.

Thanks to http://www.chrismyden.com/nuke/article.php?sid=194&mode=thread&order=0&thold=0 for the essence of above. All i did was edit, add some tips and fix some links.

Doesn’t work here with Nero 5.5.10.56. Anything special about foobar’s installation?

hmm, what part doesn’t work ? the burning never begins ? try reinstalling foobar, when asked what components you want to install, tick both audio CD and disk writer boxes.

I don’t think you need anything special in Nero to do this… just select all tracks except the first one and change the gap to “0” (default is 2)… I’ve been doing it that way for a couple years, and never noticed any gaps in live CDs…

itz an odd thing, maybe it depends on the drive type [make/model etc.] ,though i doubt it, how some people report no trouble creating gapless audio cd compilations with nero and/or other programs, yet others have no success at all.,. i’m in the latter ;(

so i tested , tested, tested…for hours ! have to say that the nero+foobar method works wonderful … thank God too :wink:

It just doesn’t find my Premium. It searches through the scsi chain and gives up if it hasn’t found anything to burn with. Writing an ISO with the image recorder and burning the image afterwards works flawlessly – and without gaps. But it doesn’t find the damn writer.

There is a range within every mp3 file that contains data, And this is what causes the gaps even if you have set the pauses to zero. This is part of the mp3 “specification”. Don’t ask me why you don’t hear them … :bigsmile:

“It just doesn’t find my Premium. It searches through the scsi chain and gives up if it hasn’t found anything to burn with. Writing an ISO with the image recorder and burning the image afterwards works flawlessly – and without gaps. But it doesn’t find the damn writer.”

gee, those crappy plextors - so incompatible with everything ! :wink: ONLY JOKING…can’t afford one myself.

OK, now I see the problem. I haven’t heard them because I’ve never burned a live MP3 CD… only WAV files. All the MP3 cds I have are supposed to have gaps so I never noticed.

Feurio! can handle in a convenient way the silence at the end of mp3 tracks. Check this thread and the Hydrogenaudio forum link inside. :slight_smile:

Regards,

ET

yes, it’s difficult for Nero to burn a perfect gapless disc.

I mean, if you manually delete the silence at the beginning and end of MP3 tracks in a perfect way, it’s almost impossible for Nero to correctly burn them because they’re not multiple of 588 samples. This is a job for Feurio! and “no pauses” setting.

With Foobar2k you’ll probably get a disc with no perceived pauses and it will be fine most times. I guess it’s possible to get a “click” between tracks if, by chance, there’s too much difference in volume between the end of a track and the first samples of the following…
Anyway, it’s a good way to do it automatically…
To do it with everything under control, use Feurio!

FYI, even if you decode mp3 files to wav files, the gap will still be there.

Never mind :slight_smile: – the problem seems to be that I am working with both scsi and ide.

Well, the discs I have that are gapless didn’t come from mp3… they’re generally transcribed directly from a DAT. That’s good to know though…

Source of gaps, from the most common to the least common :

Nero inserts gaps. Solution : remove them everytime you burn a CD from audio files.

MP3 have gaps. Solutions : crossfade, auto detect, test on silence with adjustable threshold, etc… Exception : Lame Mp3s specify how much gap they have and Foobar2000 removes them by default.

CD introduce gaps between files that are not multiple of 588 samples. Solution : burn with Feurio with the gapless option, or with a mastering software like SoundForge, CoolEdit, Wavelab, Samplitude…

The files were ripped with a remove gap or kill zero samples option, which ruins the transitions between tracks. Solution : re-rip the original CD properly, with all its original gaps and samples.

You listen to the CD with a software, non gapless player, like Windows CD Player. Solution : get a gapless player, like Foobar2000, or Winamp 5, or use a real CD Player.

You burn in TAO. Solution : burn either in SAO or DAO.

You can’t burn in SAO or DAO. Solution : upgrade your burning software so that it recognizes properly your burner.

Your burner can only burn in TAO. Solution : Time to replace your 8 years old 2x CDR burner with a 52x new one.

You get clicks between some tracks in gapless playback even when you encode gaplessly from gapless wavs. Solution : try Vorbis for encoding, less sensitive to this rare artifact, or use a declicker for vinyl records after having decoded the compresed files to wav and joined them, before burning them.

You guys sure want to make it harder than what it really is right? :wink:
Just make a cue file and you’ll get gapless audio cds without the postgap Nero inserts.


FILE "blah.mp3" MP3
  TRACK 01 AUDIO
    INDEX 01 00:00:00
FILE "bleh.mp3" MP3
  TRACK 02 AUDIO
    INDEX 01 00:00:00
FILE "hmm.mp3" MP3
  TRACK 03 AUDIO
    INDEX 01 00:00:00

Tested with Nero 5.5.10.42 in DAO.
//Danne

Again, gaps are part of the mp3 specification. Correct mp3 files MUST contain these gaps and there is no way to avoid them unless you edit them in the track editor of your burning software or use foobar2000 as described above. Even your cue sheet file won’t help it.

Or here’s another way -
A Mac and Toast.

No gaps here!

How’s that for a quick reply

try cdrwin

I use Roxio CD Creator. I use Blaze Audio products to edit. Then burn with Roxio. IMO Roxio is much better than Nero.
Thanks Mike