GameJack 5 - How to use Game Starter exaclty?

vbimport

#1

Hi,

I want to know how to use the Game Starter of GameJack 5 exactly.
Either I am doing something wrong, although I already tried many things, or just doesn’t work on those game, although the protection scanner states that it should work…


#2

What is not working? It works very well on my side with the latest games protected with Securom, SafeDisc or ProtectCD. Which game do you like to start? I think onöy StarForce 3 is not working - but they clearly write this on their homepage…


#3

Can you tell me which game is not working? Please supply the protection scanner result as well. Basically, the game starter is used this way: Pick the main exe of the game (the one you usually launch to play the game), select the appropriate options, and save the configuration. Later on, you can run your game directly from within GameJack (be sure to insert the appropriate CD first as the game may want to load some additional files from there, we had tons of support requests where people tried to play a game without the cd (or image) in place - this is obviously doomed to fail :slight_smile: )
Furthermore, for some games you may have to install the game from the virtual drive if you want to (or have to) use an image file. These games store hardcoded paths to their game disc somewhere and fail to look for the cd in other drives. Doh! sigh


#4

So I still need the original disc for GameStarter or an image?

I thought that Game-Starter should work without this…

The game I tried to play is Sacred and/or Sacred Underworld, both have a very new ProtectCD5 version and GameJack claims that it should work.

The game normally doesn’t need the CD anymore, just for checking…

Because I now don’t have GameJack installed anymore and also not the trial-installer anymore I used Aray-Scanner to verify ProtectCD version… according to Aray-Scanner it hast ProtectCD Build 1118 (both of them)

But I will re-download GameJack and tell you afterwards more about it… but maybe you already know something now…

EDIT:

Strange I now found out that not even my original disc work… Although I know that it had worked already some time before… maybe this is why I have problems with the Game Starter and this game?
I says that I use emulation although I have not turned on any emulation…


#5

So…

I now fixed my problem with the not working original game disc (seemed that some program didn’t uninstall correctly).

But anyway how do I now use the GameStarter option…

NEW: New is the integrated game starter. This functions allows it, to play copy protected games without using a CD/DVD in your drive - without “No CD Crack” or something like this.

I thought this means that I can play the game without having the CD inserted and without any image… or does this mean that I need to create an image from the CD and put it into the virtual drive and run this over the Game-Starter?


#6

If you can read German, I suggest you the forum www.brennmeister.com/forum/ , especially this thread:

http://www.brennmeister.com/forum/viewtopic.php?topic=107019&forum=4

For ProtectCD protected discs you need the image, because these games are loading data from the disc. GameJack 5 can’t circumvent this.

These games are known to work 100% perfect with the game starter, because they don’t need to load any data from the disc while playing:

DRIV3R
Thief - Deadly Shadows
Star Wars - Knights of the Old Republik 1 & 2
FarCry - SD 3.20.22
NFU U - SD 2.90.40
NFS U2 - SD 3.20
Swat 4 - SecuRom 5.03.13

… and more…

OK?


#7

I will try this then… thanks for the info… but I thought I also tried with Alcohol Image in Virtual Drive and it didn’t work… but maybe I need GameJack Image or it was because I just had v5.0.2.5 that time…


#8

You need to remove Alc and DT from your system, even the registry strings, because these products are blacklisted… Only if you want to run ProtectCD protected discs…


#9

I know this… :slight_smile:

They are already removed… but as said I will re-try… maybe another problem at the time I tried…


#10

have retried this now with v5.2.8…
I have created new image with GameJack5, mounted in Virtual drive, detected Proectection through scanner and added through the option there and then I switched to game starter and right-clicked on the created game and said start and it didn’t work.
Whereas the original disc works.
And I have de-installed Alcohol, DT, BlindWrite, …

I will try on my NoteBook tomorrow because my Windows install on my PC is kinda old… and needs to get re-installed soon and I think that I have some trash drivers and registry entries somewhere I just don’t know…


#11

ok… on my notebook it works…
So I really think that I have some registry entries and such things on my PC that were not deleted… but I will re-install Windows on my PC soon.


#12

What do you think about GameJack 5?

By the way, just look at this:

http://www.cdr-zone.com/guides/gamejack_v5_quick_guide_page_1.html


#13

GameJack is not working with Sacred Underworld.
I have the Australian release. ProtectCD build1118.
Using GameStarter it says “Failed to load due to installed Copy Protection Emulation”
Tested with GameJack 5.0.3.1


#14

I get the same message on my PC, but on my notebook it worked with GameJack… so I thought that there probably is some registry trash on my PC or something like this…


#15

Fresh install of WinXP here.
De-selecting Advanced Emulation in GameJack, caused PCD to say “Disc Verification Error”
Selecting Advanced Emulation in GameJack caused PCD to report conflict with Emulation Software.
This is a pretty clear cut case of blacklisting.