FTP data corruption during transfers

vbimport

#1

I have 3 computers on a small LAN at home. They are connected to a Linksys 4 port Cable/DSL Router. For a couple years I have used a FTP server (Bulletproof) on one of the computers to transfer work in progress between myself and a friend (we both work on the same projects). All of a sudden, I am getting corrupt files served from my FTP. The weird thing is that the corruption comes and goes. Sometimes it happens, sometimes it does not. It does not matter what FTP client is used either.

As a test, I created 4 small video files, transfered across the network via FTP using both the public and private IP, all files were corrupt. I then created an sfv file to check for crc errors after transfer. After several attempts, I was able to transfer all 4 files and the sfv file did not detect any errors, yet when I went to unzip, corruption was found.
Only FTP transfers are affected. Transfer through HTTP, network shares, etc are all ok with no corruption.

Here is what I have tried so far:

  1. upgraded to the latest firmware for the Linksys
  2. installed BlackMoon FTP on another computer, which seemed to transfer without corruption for a few days, but now it is corrupting files
  3. changed cables/nics

I am at a lose as to what is happening here. Any help or insight would be appreciated


#2

I had a Linksys router and also encountered problems after a about year of usage. I then bought a D-Link Di-604 for $15 and it is far superior to the Linksys. No more corrupt data files. So I guess one suggestion is… maybe its the router?

Another suggestion…
Have you tried PASV mode? …just worth a shit.

If I think of more I will add-on later.


#3

Users outside have to use passive to connect. Corruption occurs.

I can use either port or passive on the LAN side, and still get errors.

I forgot to mention both servers run off of different ports. I was thinking maybe my ISP was using some type of hack against running personal FTP, because when I switched to Blackmoon on another machine on a different port, the problem went awy, only to come back 3 days later. I have tried running on different ports, but the problem persists.

I was suspecting the Router, but it is the one piece of hardware I don’t have an extra one around to test.


#4

Umm, sounds like your hunch might be a possibility. For example, Optimum Online keep sending e-mails about not running servers. But they don’t cut you off, just lower your bandwidth. I only run when someone needs something, also they don’t care as long as there aren’t constant hits and drains. I get as high as 9megabits download and 1 megabit upload. Cable really rocks.


#5

I have spent the last several hours trying different firmware for the good old Linksys, and finally found one that does not cause corruption. I transfered 10 gigs of data to each machine, verified, and unpacked.
I’m buying a different router tomorrow :slight_smile:


#6

Yea, I had a feeling too. I like D-Link, my DI-604 works flawlessly, and I have not once updated the firmware. Also, lots of VPN and FTP options, and maximum firewall control and port range opening and just tons of options.

Ehhh, for 15bux you cant go wrong…right?