Frustrated Burning Problem!

I haven’t changed the configuration of my system for the past year. Then all of a sudden I could not burn cd’s/dvd’s anymore. Nero’s error message: “invalid block address”. At first I thought it was because my burner was getting old (I had it for about 3 years). So I bought another Pioneer (DVR-116D) for about $20 bucks. I installed it and it was working fine for about a week. Then the problem occured again, but this time it said “Invalid write state” (more in error log below).

I was using Nero 6 so I uninstalled it and installed Nero 9 last night, then all of sudden, it worked again. This morning, the problem came back again…

Help?? I’m running out of ideas… I don’t understand how it could work and then not work then work again and then not work again. I have checked the DMA settings (as one of the posts suggested) and it is set to “DMA if available”, but the problem is still the same.

Any advice would be greatly appreciated!

Below is nero’s error log:

Windows XP 5.1
IA32
WinAspi: -
ahead WinASPI: File ‘C:\Program Files\Ahead\Nero\Wnaspi32.dll’: Ver=2.0.1.74, size=164112 bytes, created 10/26/2004 4:21:30 PM
Nero Version: 6.6.0.6
Recorder: <PIONEER DVD-RW DVR-116D>Version: 1.08 - HA 3 TA 1 - 6.6.0.6
Adapter driver: <atapi> HA 3
Drive buffer : 2000kB
Bus Type : via Inquiry data (1) -> ATAPI, detected: ATAPI
Connected to MMC as unknown drive with class-nr : 1
Drive is autodetected - recorder class: Std. MMC recorder
CD-ROM: <Optiarc DVD RW AD-7170A >Version: 1.04 - HA 3 TA 0 - 6.6.0.6
Adapter driver: <atapi> HA 3

=== Scsi-Device-Map ===
DiskPeripheral : ST3750640AS atapi Port 0 ID 0 DMA: On
DiskPeripheral : ST3500630AS atapi Port 0 ID 1 DMA: On
CdRomPeripheral : Optiarc DVD RW AD-7170A atapi Port 3 ID 0 DMA: On
CdRomPeripheral : PIONEER DVD-RW DVR-116D atapi Port 3 ID 1 DMA: On

=== CDRom-Device-Map ===
Optiarc DVD RW AD-7170A E: CDRom0
PIONEER DVD-RW DVR-116D F: CDRom1

AutoRun : 1
Excluded drive IDs:
WriteBufferSize: 83886080 (0) Byte
ShowDrvBufStat : 0
BUFE : 0
Physical memory : 2047MB (2097151kB)
Free physical memory: 2047MB (2097151kB)
Memory in use : 19 %
Uncached PFiles: 0x0
Use Inquiry : 1
Global Bus Type: default (0)
Check supported media : Disabled (0)

30.4.2009
CD-ROM (ISO)
7:17:34 PM #1 Text 0 File Isodoc.cpp, Line 6168
Iso document burn settings
------------------------------------------
Determine maximum speed : FALSE
Simulate : FALSE
Write : TRUE
Finalize CD : TRUE
Multisession : FALSE
Burning mode : TAO
Mode : 1
ISO Level : 1 (Max. of 11 = 8 + 3 char)
Character set : ISO 9660
Joliet : TRUE
Allow pathdepth more than 8 directories : TRUE
Allow more than 255 characters in path : TRUE
Write ISO9660 ;1 file extensions : TRUE

7:17:34 PM #2 Text 0 File Burncd.cpp, Line 2870
PIONEER DVD-RW DVR-116D
Buffer underrun protection activated

7:17:34 PM #3 Text 0 File Reader.cpp, Line 127
Reader running

7:17:34 PM #4 Text 0 File Writer.cpp, Line 122
Writer PIONEER DVD-RW DVR-116D running

7:17:34 PM #5 ISO9660GEN -11 File geniso.cpp, Line 3286
First writeable address = 0 (0x00000000)

7:17:34 PM #6 Text 0 File Burncd.cpp, Line 3155
Turn on Track-at-once, using CD-R/RW media

7:17:35 PM #7 Text 0 File DlgWaitCD.cpp, Line 257
Last possible write address on media: 359848 ( 79:59.73)
Last address to be written: 322487 ( 71:41.62)

7:17:35 PM #8 Text 0 File DlgWaitCD.cpp, Line 269
Write in overburning mode: NO (enabled: CD)

7:17:35 PM #9 Text 0 File DlgWaitCD.cpp, Line 2311
Recorder: PIONEER DVD-RW DVR-116D;
CDR code: 00 97 24 16; OSJ entry from: SONY Corporation
ATIP Data:
Special Info [hex] 1: D0 00 A0, 2: 61 18 10 (LI 97:24.16), 3: 4F 3B 4A (LO 79:59.74)
Additional Info [hex] 1: FF FF FF (invalid), 2: FF FF FF (invalid), 3: FF FF FF (invalid)

7:17:35 PM #10 Text 0 File DlgWaitCD.cpp, Line 431
>>> Protocol of DlgWaitCD activities: <<<
=========================================

7:17:35 PM #11 Text 0 File ThreadedTransferInterface.cpp, Line 829
Setup items (after recorder preparation)
0: TRM_DATA_MODE1 ()
2 indices, index0 (150) not provided
original disc pos #0 + 322488 (322488) = #322488/71:39.63
relocatable, disc pos for caching/writing not required/ required, no patch infos
-> TRM_DATA_MODE1, 2048, config 0, wanted index0 0 blocks, length 322486 blocks [PIONEER DVD-RW DVR-116D]
--------------------------------------------------------------

7:17:35 PM #12 Text 0 File ThreadedTransferInterface.cpp, Line 1042
Prepare recorder [PIONEER DVD-RW DVR-116D] for write in TAO
DAO infos:
==========
MCN: “”
TOCType: 0x00; Session Closed, disc fixated
Tracks 1 to 1:
1: TRM_DATA_MODE1, 2048/0x00, FilePos 0 307200 660762624, ISRC “”
DAO layout:
===========
Start|Track|Idx|CtrlAdr|RecDep_____
-150 | lead-in | 0 | 0x41 | 0x00
-150 | 1 | 0 | 0x41 | 0x00
0 | 1 | 1 | 0x41 | 0x00
322488 | lead-out | 1 | 0x41 | 0x00

7:17:35 PM #13 Text 0 File ThreadedTransferInterface.cpp, Line 1110
Removed 2 run-out blocks from end of track 1. Length: 322488 -> 322486.

7:17:35 PM #14 Phase 24 File dlgbrnst.cpp, Line 1832
Caching of files started

7:17:36 PM #15 Text 0 File Burncd.cpp, Line 4042
Cache writing successful.

7:17:36 PM #16 Phase 25 File dlgbrnst.cpp, Line 1832
Caching of files completed

7:17:36 PM #17 Phase 36 File dlgbrnst.cpp, Line 1832
Burn process started at 40x (6,000 KB/s)

7:17:36 PM #18 Text 0 File ThreadedTransferInterface.cpp, Line 2604
Verifying disc position of item 0 (relocatable, disc pos, no patch infos, orig at #0): write at #0

7:17:37 PM #19 Text 0 File Mmc.cpp, Line 21079
Set BUFE: Buffer underrun protection -> ON

7:18:04 PM #20 SCSI -1047 File Cdrdrv.cpp, Line 1432
SCSI Exec, HA 3, TA 1, LUN 0, buffer 0x04090000
Status: 0x04 (0x01, SCSI_ERR)
HA-Status 0x00 (0x00, OK)
TA-Status 0x02 (0x01, SCSI_TASTATUS_CHKCOND)
Sense Key: 0x05 (KEY_ILLEGAL_REQUEST)
Sense Code: 0x64
Sense Qual: 0x00
CDB Data: 0x2A 0x00 0x00 0x00 0x00 0x60 0x00 0x00 0x20 0x00 0x00 0x00
Sense Data: 0x70 0x00 0x25 0x00 0x00 0x00 0x60 0x0E
0x00 0x00 0x00 0x00 0x64 0x00

7:18:04 PM #21 CDR -1047 File Writer.cpp, Line 311
Illegal mode for this track

7:18:04 PM #22 Text 0 File ThreadedTransfer.cpp, Line 228
all writers idle, stopping conversion

7:18:04 PM #23 Text 0 File ThreadedTransfer.cpp, Line 222
conversion idle, stopping reader

7:18:05 PM #24 CDR -201 File WriterStatus.cpp, Line 200
Invalid write state
PIONEER DVD-RW DVR-116D\H3 T1

7:18:05 PM #25 TRANSFER -18 File WriterStatus.cpp, Line 200
Could not perform EndTrack

7:18:05 PM #26 Text 0 File Mmc.cpp, Line 15779
<PIONEER DVD-RW DVR-116D> start Close Session

7:18:27 PM #27 Phase 38 File dlgbrnst.cpp, Line 1832
Burn process failed at 40x (6,000 KB/s)

Existing drivers:
File ‘Drivers\CDRALW2K.SYS’: Ver=8.0.0.212 , size=9464 bytes, created 3/7/2007 7:51:00 PM
File ‘Drivers\PXHELP20.SYS’: Ver=3.00.56a, size=43528 bytes, created 3/7/2007 7:51:00 PM (Prassi/Veritas driver for win 2K)
File ‘Drivers\atapi.sys’: Ver=5.1.2600.5512 (xpsp.080413-2108), size=96512 bytes, created 4/14/2008 4:00:00 AM (Adapter driver for rec)

Registry Keys:
HKLM\Software\Microsoft\Windows NT\CurrentVersion\WinLogon\AllocateCDROMs : 0 (Security Option)

Any suggestions?? Appreciate it!

bad ide cable, replace it with a good 80 conductor and see what happens.

Looks like a media problem. Try burning slower at 32x.

I’d recommend “totally” uninstalling and reinstalling Nero. I don’t see a general clean tool for Nero 6, so an uninstall, reboot and reinstall should be fine. When you’re finished installing, run an update and then try burning a CD again.
Have you tried using something else to burn with? Since you’re used to Nero, I’d recommend CDBurnerXP ( http://cdburnerxp.se/). Did I mention it’s free too?
Image Burn is also top of the line “freeware” burner and highly recommended, but like I said, if you’re used to Nero CDBurnerXP should be more to your liking.

Hey zerocool_, I’ve replaced the IDE cable with a brand new 80 pin one (as it was suggested with other posts on problems similar to mine) but it still gave me the same error.

chef, I’ve tried the same batch of media TDK DVD-R’s and Sony CD-R’s and it works on other computers just not on mine…

Cozmo1, I’ve reformatted my computer just a week ago when this problem started happening (since I’ve searched and tried all the solutions I could think of and have found i.e. the two suggestions above) and the same problem still occurs. I’ve also tried removing nero completely by using a tool called “general clean tool 2.2.0.37” which took nero out completely. Then I reinstalled it again, and it still didn’t work :frowning:

My problem still remains the same with an error occuring on 6% into burning and it gives me: “Illegal mode for this track” then “Invalid write state” then “Could not perform end track” then “Burn process failed at 40x”.

I thought it was a copyright thing with the error of “Illegal mode for this track”, but I’m not trying to copy dvd’s, I was just burning some some random documents. I’ve tried burning other types of files and it gives me the same error. So…

Frustrated… I am… :frowning:

connect it to a different power cable and if that doesn’t work get another drive from a local store and try it. If the other drive works you can always return it and rma/exchange your pioneer.

Hey Zerocool, I just took apart my computer and tried to simplify the problem as much as possible. My system has the following components:

CPU: AMD Dual core 4450e
Mother Board: GA-MA78GM
Power supply: Antec 480W
2 SATA HD + 2 IDE dvd-rw’s

I use the on board graphics that comes with my MB so I think the 480W is enough and my computer was actually running really smooth since I put it together back a year ago until this problem hit.

I unhooked one of my HD’s and one of my DVD-RW’s. To test the problem out to see if I could find anything. I also plugged in a different power cable as you suggested. Here are my results:

The first DVD-RW (NEC about 2 years old) gave me a “Power Calibration error”. I searched on that and it told me to disable my IMAPI Service or try cleaning it’s lens a bit (with CO2 dust blower). I tried both and got the same error.

The 2nd DVD-RW (pioneer just bought it from newegg) gave me “Invalid block” error.

This is quite strange because before when everything was plugged in, it gave me the error as I first have stated.

I don’t know what else I could do… I’m slowly thinking it might not be software problem or problem with my dvd-rw. I think it might be my mobo or my power supply.

Suggestions? And thanks for giving me your previous ones!

Ok since you are commited to solve thsi problem, my suggestion is to http://www.gigabyte-usa.com/Support/Motherboard/BIOS_List.aspx?Keyword=GA-MA78GM-S2HP and update your bios. then reinstall xp and see if it solves it. If you still have this problem, your IDE controller is failing. 480 watts is ample power so I doubt it’s the psu. you can buy a pci/pci-x ide bridge for about 10$ on ebay Or you can get an external enclosure from a local store and see if you still have that problem. If you do, it’s the os and drivers otherwise your controller is failing. Also as a safety check buy another media and see how it burns, sometimes cd/dvd media is prone to rotting and layer separation. sometimes it’s obvious to the eye and sometimes it’s not.

Hey Zerocool, I’ll give the IDE bridge a try. Just ordered one (IDE to USB) from ebay and will see if it is my IDE controller that is failing.

I did go my mobo’s support site before I came to cdfreaks to update my drivers and I also went to pioneer’s website to get the latest firmware for my dvd-rw. The problem persisted so that sucked.

If the IDE bridge don’t work, I guess the next step would be to flash my bios and reinstall the whole system… :frowning:

Thanks for the tips! And I’ll update you when I get the ide bridge and see what happens.

if it one of these pigtail type bridges: http://cgi.ebay.com/USB-2-0-to-IDE-SATA-2-5-3-5-Hard-Drive-Converter-Cable_W0QQitemZ350189988478QQcmdZViewItemQQptZPCA_Cables_Adapters?hash=item5188f32a7e&_trksid=p3286.c0.m14&_trkparms=72%3A1234|66%3A2|65%3A12|39%3A1|240%3A1309|301%3A1|293%3A1|294%3A50 then i suggest you cancel the order as it uses a prolific chip and it’s menat only for harddrives. somehow these seems it is not pass mmc/atapi commands properly.

excuse my english, I just read what i wrote and it seems that it wasn’t a very good idea to open the laptop from sleep.

Crap! That was what I ordered, not exactly that kit, but I ordered the same pigtail bridge! :sad:

I just ordered an actual 5.25" external enclosure for the dvd-rw rom. I guess there are no cheap ways out…

I’ve got a couple of these IDE/SATA -> USB thingys and they work perfect up to 16x read and write speeds.
But it seems to depend on your mainboard too, not only the Chipset used.

oh, The ones that I had kept dropping connections and couldn’t burn but anything except dvd-ram’s so I assumed they are designed only for hard drives. Perhaps you might be having something with a different chipset as mine was hopeless for optical drives.

I think you’re going overboard with trying to resolve this issue, but it’s all up to you. I still say:

  1. Firmware update on the burner for more media compatibility.
  2. Burn with another burning software. Preferably one that doesn’t use the Nero api. I mentioned a couple above.