Format USB drive as CDFS

vbimport

#21

Well I got my space back so I feel better about that. I used testDisk to do it but after I did it Gparted did not see the size right and Windows does. The drive seems to run fine though at first Window saw it as an NFTS partition rather than a b (win95 fat 32) partition and did not show the additional space in Explorer. Once I reformated in Windows it then saw all the space. :clap:

I will have to go in later do what you did using LiveCD since it has dd in it as well. Although when I use dd --help there is so much on the sceen that it scrolls past the top part of the help info. I dont get anything from skip down in the list. :frowning: I will have to hunt down a site with the Linux commands, they are not the same as the Windows commands. Found that out when --list did not work to show me the partitions. :doh:

Live CD is great for anyone who needs the power of disk access where Windows :Z"protects":Z there users. This iso I will keep in my toolbox for a long time I can assure you.


#22

If you really want to wipe it clean, you can use dd and
/dev/zero to overwrite it. /dev/zero is a sort of virtual
device which generates an endless stream of zeros.

You already know the syntax:
dd if=/dev/zero of=/dev/sdx where x is the device
name for your usb memory stick. Mine is sdb because
my SATA hard-drive is sda. A small mistake here
would be very unfortunate.

This command will overwrite every byte of every
sector with zero. This will blow away the boot
sector and the partition map, leaving you with
a blank unpartitioned pendrive (or hard-drive
if you are not careful).


#23

Man does this bite. I have tried for hours now to get this to work. It does not seem that there is mkudffs for windows so I found a program that I know for sure is a 9660 iso program. Well it does a bunch more but I unchecked everything else for now. At this point, other than mkudffs, I am using the same tools you are and having no luck so I hope my iso is just not a 9660 iso file.

I feel like I am running out of options here. I have done it with no partiion, a partion, fat, fat 32, and NTFS and when I plug the drive in, nothing happens. The best I get is a drive with the cdimage.iso file on it when I stick it in a Windows box. Any ideas what I might be doing wrong? :sad:

dd if=/dev/hda6 of=/dev/sdb1

That is what used when I got the iso file to show up in windows but once again, it’s an iso file and not the program. When i tried…
dd if=/dev/hda6/cdimage.iso of=/dev/sdb1
I get /dev/hda6/cdimage.iso is not a directory. :a

Thanks,


#24

Where these tests done on a Windows Box when they mounted on their own?


#25

No. See post #16 above.


#26

That would copy partition #6 of /dev/hda (this is usually the
master drive on the primary IDE controller) to partition #1
on drive /dev/sdb Is that what you are trying to achieve?

/dev/hda is a device and not a file system.

Are you using the Gparted live CD for this?
If the hard drive that the ISO image is stored
in is mounted, you need to know where the mount
point is. If it is not mounted, you will need to
mount it before you can read the image file
from it.

Run ‘mount’ to see a list of mounted devices.
Detailed info here:
http://www.die.net/doc/linux/man/man8/mount.8.html


#27

Thats the post that made me ask. The first time I read this I took it the wrong way and after reading all the post, trying to figure out what I was doing wrong and why you got it to work and I can’t, it hit me that I might have been wrong.

After about the 8th or 9th time I read this I snapped to the fact that you don’t say you tested it on Windows. :clap:

What got me all the other times I read this was that in this section you differentiate between the 2 OS after formationg in UDF. I just assumed the tests you ran in the first section where done on Windows and Linux as well.

My thinking was that since I could not get to the file itself I would try the entire drive so I created a small partiion in windows off the master drive. It has an extened partion with 2 logical partitions in it. I just split one in to a smaller drive and copied the ISO to it. After using dd in this manner and plugging the drive in and saw the ISO file I realized right away. :doh: That is what I should have gotten. Remember, it’s like 3 AM at this point and half my hair is on my desk or under my nails and No, not what I wanted. lol

Yes I am. And thank you for the information on Mount. I will go check it out as well. The ISO is on a hard drive but if I tried to point right to it I got the “… is not a directory” information. This is why I belong in the Newbie forum! :bow:

One last clarification if you don’t mind. Are you able to create a pen drive that Windows sees as a CDFS and mounts on it’s own? Sorry for the confusion but I have to ask. :o

Thanks again Skelton!


#28

Ok I mounted the hard disk with the iso file on it. Used dd to dump the iso file over in many ways on many file systems and each time I place it in to my Windows box I getthe wrong result. Mount was very helpful though. Now I have a copy of the entire partition on the sample drive I have. It’s about 127 mb, if you want to download it make sure this post is at least one hour old. The file is uploading as I type and it should not take an hour.

http://www.iwarecd.com/newimage.iso

You should see the partitions on this thing. I even used dd to copy make this iso from the demo USB and then used dd to put the image on my USB and got nothing. I tried it with IBS and OBS at 2048, I tried it at default, I tried it until I was blue in the face. lol. I just don’t get it. I cant even image the drive. In fdisk when I do a p to print the partition info it tell me this is not even a partition table but then it spits one out. Maybe you can sell what they did here by looking at the ISO.

I gotta jet, my wife and I go out on Saterday nights to play cards.

Later


#29

I only did one set of tests on Windows. I found I could not mount
a UDF formatted memory stick on Windows-XP.


#30

The joys of broadband! I downloaded it tonight.

126615552 bytes

MD5SUM
092991937ad7653e0bff8e1d1c4ef9b4 newimage.iso

Full report tomorrow…


#31

Hello ssdmedia.

I burned your image to a USB stick and plugged it into
this Linux box. It auto-mounted as a DOS/Wndows
FAT32 drive. There is no sign of a partition map.

You can see the first few hundred bytes of the MBR
in this screenshot. I don’t have a Windows box
here, but I will try sticking it in a Windows-XP
PC tomorrow.

Looking at your disc image with hexedit shows that
there is a vast area of 0x00s and some data near the
end of the drive.

BTW, you can save a lot of bandwidth by ZIPing
the image file:
newimage.iso 121MB
newimage.zip 15MB
A blank drive where almost every byte has the
same value (0x00 or 0xFF) will compress to
a tiny fraction of it’s original size.



#32

Hi guys I have been reading your tread intensely and I too am trying to do exactly what ssdmedia is trying to do. I am a complete Linux novice, i.e. I have never used it. I would love to know how you (ssdmedia) mounted your hard disk with the ISO on it (post #28). Are you able to explain in more detail how you did this?


#33

I’ll move this to ‘[I]General Software[/I]’, where you might get more specific help :slight_smile:


#34

How can I convert a USB 2.0 in U3 Memory? Is it possible? Help me please.


#35

Interested in knowing the solution to the problem you are trying to solve…

can you tell us how to make it work? Reading the posts, it seems that the proposed methods don’t work in windows…


#36

I’ve been working on doing exactly the same thing. Create a USB drive that mounts itself as a CDFS. I will venture so far as to call it that, because i’ve seen it. Now you’re all asking where i saw this actually call itself cdfs and actually mount as “two drives”. IronKey. It’s a name brand “secure” thumb drive with hardware encryption. (they just came out with a 8 gig version) www.ironkey.com/. now, i’m a complete linux newb. never messed with it so far i’ve got the Gparted iso, but haven’t burned or used it much. i can actually get my hands back on this iron keey too, if there’s some way i can “reverse engineer” it to “borrow” it’s setup. note: this is a co-worker’s thumbdrive and i can’t really hurt it.

the most important thing to note is that it can be done on XP. when you go to manage your hardware, it tells you you have a CD drive and a USB drive connected. when you look at the properties of the “cd drive” it looks like a CD drive should with a “cdfs”. The thing i was thinking you were leaving out ssdmedia was some sort of a driver set. (i’ve read through your entire thread, but i’m not sure if any of the “partitioning software” you’re using actually tells the pc to use certain drivers.


#37

Hi guys. Sorry to step in but I’m looking for something similar as well.
I would like to format/write a USB pen drive as if it was a DVD. I guess this is almost the same thing as you’re talking about here?


#38

Old thread is OLD. But I see some recent activity on it so I am going to post this.

Hi, found this thread looking for a different solution to a problem I have.
I want to be able to have as many ISOs on a USB drive as I can fit and then have a bootmanager list them and then boot from the selected one. Not so easy, no bootmanager I can find will read ISOs , so I thouight if I fooled it into thinking they were CD/DVDs it might do the trick. Which is how I stumbled into this thread.
No such luck yet.
However, as far as ssmedias problem , I may have found a workaround for him.
The flash drive you spoke of as mounting a CDROM from the USB stick is likely a U3 enabled device. It is not a simple fomatting trick they use to get it to autorun, it is hardware as well. If you look at it even under linux it reports as a SCSI DVD/RW.
In order to autorun as a CD device certain criteria have to be met which as far as I can tell can only be done by hardware. See MS link for details.
http://www.microsoft.com/whdc/archive/usbfaq.mspx
HOWEVER… there is a trick to get the U3 software to update a customized ISO (which would have your software on it)
Not sure of the legalities re the DMCA but since you are not decrypting or reverse eng anything, I dont see a problem (IANAL).
Check out this link.>
http://wiki.hak5.org/wiki/Talk:Memorex_U3_ISO_Hack
So , you could buy up some cheap U3 enabled devices(if that file you uploaded if the extent of your software, then real cheap) customize them with your ISO and ship them out to your customers.

On a side note , there is also a darker purpose that a custom ISO can be tasked with. See this thread. >

Now I know why high security workplaces epoxy their USB slots closed.


#39

I chanced upon this forum as well. I have some old USB keys which I want to ‘autorun’ automatically.

  1. Use USBDeview from http://www.nirsoft.net - this helps determine the PID/VID of the USB key.

  2. Check the list at http://www.linux-usb.org/usb.ids - this may help to further identify the USB device

  3. Goto http://flashboot.ru/index.php?name=iflash&pagenum=1 (in russian) - from the PID/VID, determine the controller chip and whether there is ‘production tool’ available to reflash the USB key.

  4. Goto http://www.flashboot.ru/index.php?name=Files&op=cat&id=2&pagenum=1 (in russian) - download the ‘production tool’ if one is available.

I have a 1GB USB key with PID=0EA0 VID=2168 for which there is a ‘OTI_PT_Multi-Device_PTMD2.9.0.11.rar’ tool available. However this tool does not allow creation of a CDFS and a 2nd FAT partition on the USB key.

I also have a 2GB USB key with PID=0411 VID=0098 for which there is a ‘SMI_UFD_Utility.zip’ tool available to create a CDFS and a 2nd FAT partition on the USB key.

To create custom CDFS ISO images - search for ‘Universal_Customizer.zip’ - this is the first such tool I found and downloaded, it worked for me.

After some experimentation, I now have the 2GB USB key autorun using these 3 files on the CDFS partition, and I run PortableApps from the 2nd partition.

AUTORUN.INF contains
[autorun]
open=shelexec.exe autorun.bat
icon=shelexec.exe,0

SHELEXEC.EXE can be obtained by searching the Internet.

AUTORUN.BAT contains
@FOR %%f IN (C D E F G H I J K) DO @IF EXIST %%f:\StartPortableApps.exe SET usbdrive=%%f:
@start %usbdrive%\StartPortableApps.exe
@set usbdrive=

Hope this helps someone.


#40

Alright, this is exactly the opposite of what i am tring to do, i got a real cool looking USB drive, but it loads as a CD drive, and i am trying to format it (i only have windows), but it will not allow me, here is my thread

http://club.cdfreaks.com/f122/usb-drive-only-shows-up-cdrom-cannot-format-268518/