Forcing Pioneer BDR-S09 to NOT go to sleep

vbimport

#1

I just installed one of my Pioneer BDR-S09 sata drives in a Mac Pro (3,1).

All works ok, incl. burning, excep that:

The drive goes to sleep by itself. When this happens, the drive disappears from the Disk Utility, from Roxio toast and the whole system. One has to power down the system, reattach the cable and then the drive will show up again (for a while).

I’ve already set the Disk Sleep OFF in Preferences / Energy saver in OS X.

This has not solved the issue.

I do not have the same issue on the LG BH16NS55 sata drive. It keeps running and doesn’t go to sleep.

So, is there a way to program the BDR-S09 drive internally (perhaps in Windows) so that it doesn’t go to sleep?

Or is there an OS X hack that keeps a specific SATA device running by polling/accessing it in order to keep it awake?


#2

The drive doesn’t have a sleep mode, to the best of my knowledge. It doesn’t have a need to have one, and this shouldn’t happen. (Maybe it should have a low power SATA link mode, but…)

This sounds like an OS bug. While OSX has generic support for drives which don’t have Apple-specific firmware, you can run into bugs like this from time to time. Other people have had the inverse problem: the system polls the drive at regular intervals, or even make the drive open at random.

If I run across a hack that will replicate that random polling behavior, I’ll link you to it. That said, I’m of the thought that the drive may be getting disconnected/unmounted for reasons beyond a normal idle timeout, and it might occur even with regular access.

Can you check the system log in Console (Applications > Utilities > Console, or activate Spotlight & type “Console”)? When the drive disconnects, can you see if a specific event is reported?


#3

Thanks for the ideas, Albert. I will check.

I’m also planning of re-attaching the Pioneer to my PC/Windows machine and programming the drive settings (saved in drive firmware) differently.

I wonder what settings from the Pioneer Utility I should try:


#4

None of those settings are supposed to cause the issue you’ve encountered.