Force slim DVD and laptop HD on desktop motherboard to proper master/slave setting

vbimport

#1

I’m trying to add a slim DVD to my file server. The motherboard is a JetWay JNC81-LF, but I doubt the specific model is relevant, just that it’s a desktop Mini-ITX board. I’m using a Chenbro ES34069 case, which requires both a slim optical drive and a laptop hard drive due to space constraints.

The hard drive is a 40GB Seagate Momentus 5200.2. I am using an adapter like this one to connect it to the system.

The DVD drive I’m trying to add is a TS-L532B. I am using this adapter to connect it to the system.

Due to the space issues I mentioned earlier, I am using the 80-pin IDE cable “backwards”. That is, the blue end, which normally goes attached to the motherboard, is attached to the hard drive. The grey connector, normally slave, goes to the DVD drive and the black connector, normally master goes to the motherboard.

This is what I have tried

[ul]
[li]Hard drive by itself, no jumpers: HD gets detected as master. DVD by itself: DVD gets detected as slave.[/li][li]HD with no jumper set, DVD connected: HD gets detected as master, DVD shows up as slave, but the name is corrupted: “T≈S⌡cδr⌡ δVδ+Ñ-⌡”, and is shown as a 2300MB hard drive.[/li][li]HD with jumper set to cable select: Same result as when no jumper is set.[/li][li]HD with jumper set to slave, DVD connected: Neither HD nor DVD are detected.[/li][/ul]
While researching this problem I’ve learned that some slim drives just won’t work as anything but masters. Since I’m running Linux this actually doesn’t matter to me, the boot drive can be the slave with no problem.

Does anybody have any ideas about how I can have my hard and DVD drives coexists in this setup?


#2

Have you tried another ide cable (or not “backwards”) ? Is the drive from Dell, with Dell firmware ? Than you may try (at your own risks…) to flash it with a “standard” TSST firmware. (using -nocheck perhaps)

If it does’t work with “standard” firmware, maybe you could find a “slave” firmware here www.samsungodd.com/kor :slight_smile:


#3

Hi and Welcome!

from your description, this is most likely a cable issue. Perhaps a result of your “unconventional” cabling attempt. Yes, there is a reason for the colour coded connectors - ignoring that is calling for trouble.

If spec compliant cabling is not an option for you:
You might consider replacing the HDD by a Sata drive in order to have only one PATA drive left. Or replace the optical drive by a Sata unit. The TSST 532x drives were questionable anyway, so there is little to lose.

Flashing the drive to a “master” firmware (if such a firmware exists) is only something to think about if the drive is connected as the only drive on the IDE cable.

Michael


#4

Thank you both very much for your help. Indeed, running the cable the way it’s supposed to go solves my issue. I’ve ordered a longer IDE cable to connect the drives properly, and I’ll just tie/clip the excess out out the way.

Thanks again for taking the time to reply.


#5

Put it into a usb external and all problems are gone.