Floppy Won't Work

vbimport

#1

Can anyone help me my floppy drive has stopped working so I thought ok only cheap I’ll get another but that still dos’nt work.
When I boot the light comes on but it does not read the drives information. When I look in my computer at the properties of the drive it tells me that the disk in A:\ is not formatted, it even says this with mt start up disk as well. If I try and format the disk it just goes on forever getting nowhere. Have tried new cable, and windows drivers but nothing works, any suggestions Thanks

cosmicray;)

Live Long And Prosper


#2

I know this one!! (i think)
U need to make sure that your floppy cable is plugged in the right was up! This is a common mistake but can be found out because the light always stays on!!! If this does not work then go into ur BIOS (Basic Input Output System) and make sure its configed properly.
Need any more help write back
ChicaneWeaver
:):):slight_smile:


#3

I had some problems with my floppy too because my PC-case was pressing against the EJECT button for the floppy’s causing them not being able to be completely inserted. Make sure the floppy’s can be inserted properly.


#4

either that or a nicely toasted motherboard.

don’t you love the smell of toasted electronics in the morning!

as above from chicaneweaver - just remember the correct way round has the TWIST OFF the board - ie the twist is on the drive itself.!

Mr C


#5

Well thanks for all your advice but up to now I have tried new floppy drive, checking the cables are the right way round, new cable, checked Bios, reset Bios, have run the floppy from an ISA card (and even remembered to disable on board floppy controller) Light comes on the floppy when I boot up it checks the drive and then say’s boot record not found ( even with my start up disc) and then continues to load windows as normal. But if you try and check what’s on the disc the f**ker still tells me that the disc in a:\ is not formatted. If the FDC on the mother board is toast as suggested then you would think that I could still run it from an ISA slot? Please keep suggestions coming,

Cosmicray

Live Long And Prosper
:mad: :confused: :confused: :mad:


#6

All my suggestions:

  1. try formatting another disc and see if that works

  2. check the damn cable and make sure it’s on the right way. the red line on the floppy indicates pin 1, look for a 1 or 2 on the drive and match em up… lights always on usually means you have the cable on the wrong way. drive A is AFTER the twist

  3. check bios settings just to be sure!

  4. resetting cmos could solve the problem.

  5. try using the daughter board’s floppy controller and see if that works

  6. if it doesnt work on the daughter board, either
    A) both drives were bad
    B) your mobo is seriously fucked
    C) your cable could be bad!

  7. the old mobo could have been screwing your disks up when formatting them, so that may be causing the problem. you could try formatting one on the daughter board’s controller, but from what you say that wont work.

I have come to the conclusion that if none of these work, either:

A) Your mobo’s irq controller is fubar’d
B) Your mobo’s dma controller is fubar’d
C) You have no idea what the hell you’re doing
D) You’re just pullin our legs and its really working :slight_smile:

I’m thinking it’s option A or B


#7

Try both ide connection on ide cable…


#8

he’s got a floppy drive, not a hard drive :open_mouth:
floppy cable != ide cable


#9

Maybe the drive. Maybe cable. Do you know somebody that has a pc close to you, like work or one of your neighbors? try it in a different pc. You can also take it and the cable to a local store (I dont know if they would charge you to test thought.) and have it checked. If it fails elsewhere then properly the FDC might be hosed. But make sure that the end on the motherboard is properly connected. I had a problem when I built a system for my uncle, the cable it self was bad.


#10

Hello Everyone :slight_smile:

Well the bloody floppy is working now, took it to a friends and put it inside his PC and it was the cable after all. The annoying thing is that one of the first things I tried was a new cable and it still didn’t work. Just goes to show that even new stuff isn’t always guaranteed to work. Thanks to all for the suggestions that were made as usual CD Freaks comes through again sorted! :wink:

Cosmicray

Live Long And Prosper


#11

Well congrats on gettting it fixed. I just had to upgrade a power supply in one of my machines Friday and stuck the damn cable backwards myself.